«

»

fev 12 2008

Desafio da Semana – NAT

Atendendo a pedidos… o desafio desta semana é sobre NAT!

Atentem para o diagrama abaixo:

grafico.JPG

Sabendo que o router “Weaver” já se encontra com a configuração abaixo:

hostname Weaver
!
interface FastEthernet0/0
ip address 192.168.100.30 255.255.255.240
ip nat inside
!
interface Serial0/0
ip address 192.0.2.113 255.255.255.252
ip nat outside
!
ip route 0.0.0.0 0.0.0.0 192.0.2.114
!
line con 0
line aux 0
line vty 0 4
login
!
end

Complete a configuração do NAT, assumindo que:

  • inside global addresses: 198.18.184.105 à 198.18.184.110 /29
  • inside local addresses: 192.168.100.17 à 192.168.100.30 /28
  • Número de hosts internos: 14

Poste nos comments sua sugestão de configuração.

Boa sorte!

Marco.



Comente usando o Facebook!
0
0

16 comentários

Pular para o formulário de comentário

  1. sergiombrg

    Acredito que a configuração seja a seguinte:

    waver(config)# access-list 10 permit 192.168.100.16 0.0.0.15

    waver(config)# ip nat pool internet 198.18.184.105 198.18.184.110 prefix 29

    waver(config)# ip nat inside source list 10 pool internet overload

    No aguardo!

    Sds,

    Sérgio Meyenberg Jr.

    0

    0
  2. Farley Santos

    Olá Pesoal,

    Estive analisando o cenário apresentado pelo Marcos e pude notar que a interface FastEthernet0/0 de Weaver esta com a Mascara de subrede (255.255.255.0) diferente do apresentado em inside local addresses: 192.168.100.17 à 192.168.100.30 /28 (255.255.255.240).

    De qualquer forma usei o criterio do Inside Local address com mascara /28.

    Waver(config)#ip nat pool ISP 198.18.184.105 198.18.184.110 netmask 255.255.255.248

    Waver(config)#access-list 1 permit 192.168.100.16 0.0.0.15

    Waver(config)#ip nat inside source list 1 pool ISP overload

    Gostaria de verificar se esta configuração surtira efeitos com os detalhes citados acima.

    abraços.

    0

    0
  3. cleiton

    Sergiombrg;

    No lugar de prefix 29 no comando abaixo não seria netmask 255.255.255.248 ou pode ser assim mesmo?

    waver(config)# ip nat pool internet 198.18.184.105 198.18.184.110 prefix 29

    sds

    0

    0
  4. gesners

    Boa noite pessoal,

    Segue minha sugestão:

    waver(config)#access-list 1 permit 192.168.16 0.0.0.15
    waver(config)#ip nat pool internet 198.18.184.105 198.18.184.110 255.255.255.248
    waver(config)#ip nat inside source list 1 pool inernet overload

    No aguardo,

    Atenciosamente,

    Gesner Sorrentino

    0

    0
  5. Marco Filippetti

    Farley, desculpe a minha falha, e obrigado pela atenção 😉
    Já corrigi a máscara na interface F0/0. Abs!!!

    0

    0
  6. sergiombrg

    cleiton,

    De acordo com o livro do Marco (pág. 228) é possível utilizar o “prefix”.

    Particularmente acho a forma “prefix” mais prática!

    Sds!

    Sérgio Meyenberg Jr.

    0

    0
  7. Adinor

    Olá pessoal,

    Analisei o cenário do nosso amigo marco, montei a topologia no Packet tracer, porém devido alguns problemas do software nao pude testar a topologia, porém devo adiantar que minha configuração ficou exatamente igual a do nosso amigo Farley Santos, com uma única diferença é claro que o nome do pool está diferente, além de outras conguações para a rede funcionar sem problemas.

    Bem é isso ai galera.
    Abraços………

    0

    0
  8. alamon71

    é isso aew!!!

    access list 2 permit 192.168.100.16 0.0.0.255
    ip nat pool isp 198.18.184.105 198.18.184.110 netmask 255.255.255.248
    ip nat inside source list 2 pool isp overload

    no aguardo…

    0

    0
  9. alamon71

    ops, pequena correção no wildcard mask da acl2 de 0.0.0.255 para 0.0.0.15 !!!

    0

    0
  10. Rodrigo Falcão

    Bom, parece que todos nós concordamos com as configurações para esse cenário.
    Para não tornar-me repetitivo, eu configuraria da mesma forma que nosso amigo Farley.

    Abraços.

    0

    0
  11. Marco Filippetti

    Pessoal, parabéns aos que participaram! Pelo que vi, estão todos por dentro!

    Solução sugerida:

    Weaver(config)# access-list 1 permit 192.168.100.16 0.0.0.15
    Weaver(config)# ip nat pool {nome do pool} 192.18.184.105 198.18.184.110 prefix 29
    Weaver(config)# ip nat inside source list 1 pool {nome do pool} overload

    Tem que ter o overload já que temos 14 usuários e apenas 6 endereços no range de saída.

    Atenção para esta questão, pois é uma (das muitas) que aparece com a resolução errada nos TKs da vida. E eu diria que é uma FORTE candidata à cair no exame. Quem não tentou ou não entendeu, seria bom dar uma reforçada no tema.

    Um abraço e muito obrigado!

    0

    0
  12. PauloLagoia

    Adinor,

    Pq vc naum coonseguiu simular o nat no packet tracer?
    esse link pode te ajudar. http://james.bond.edu.au/courses/inft13337/053/Labs/week5.html
    qqr coisa eh so postar aqui novamente.

    []s

    0

    0
  13. Adalberto Nuno

    ip nat pool end_global 198.18.184.105 198.18.184.110 netmask 255.255.255.248

    ip nat inside source list 1 pool end_global overload

    ip access-list 1 permit 192.168.100.0 0.0.0.15

    0

    0
  14. priess

    ip nat pool CISCO 198.18.184.105 198.18.184.110 255.255.255.248

    ip access-list extended CLASS
    permit ip 192.168.100.16 0.0.0.15 any

    ip nat inside source list CLASS pool CISCO overload

    0

    0
  15. fabricioavil

    Ai Galerinha…
    Eu estou tentando configurar esse cenário no PACKET TRACER 5.0, mas colocando o NAT passando por protocolo de roteamento e não tá funcioando. Quando coloco uma rota default no router da ponta oposta do NAT apontando para o router que está o NAT aí funciona…
    Pelo que reparei os protocolos de roteamento (já testei no RIP, OSPF e EIGRP) não estão propagando a rede do NAT (pool), é assim mesmo? Tem que configurar algo diferente?
    Eu testei esse cenário sem NAT e funcionou legal. Tenho outros cenários salvos com vários routers em Eigrp, OSPF e RIP que funcionam de boa, mas quando coloco o NAT a rede que configuro o NAT não consegue pingar para fora da WAN, mas as redes configuradas no mesmo router eu consigo pingar.
    Acho que pode ser falha no Packet Tracer, o que vocês acham? Alguém sabe?
    Obrigado!

    ROUTER1
    !
    interface FastEthernet0/0
    ip address 192.168.100.30 255.255.255.240
    ip nat inside
    !
    !
    interface Serial2/0
    ip address 192.0.2.113 255.255.255.252
    ip nat outside
    clock rate 9600
    !
    !
    router eigrp 1
    network 192.0.2.112 0.0.0.3
    network 198.18.184.104 0.0.0.7
    no auto-summary
    !
    ip nat pool internet 198.18.184.105 198.18.184.110 netmask 255.255.255.248
    ip nat inside source list 1 pool internet overload
    ip classless
    !
    access-list 1 permit 192.168.100.16 0.0.0.15
    !
    =================
    ROUTER 2
    !
    interface FastEthernet0/0
    ip address 170.1.1.3 255.255.0.0
    !
    !
    interface Serial2/0
    ip address 192.0.2.114 255.255.255.252
    !
    !
    router eigrp 1
    network 170.1.0.0
    network 192.0.2.112 0.0.0.3
    no auto-summary
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial2/0
    !

    0

    0
  16. daniel83sp

    Fala galera blz ?
    seguinte, fiz uma nat aqui funciona direitinho
    porem quando vou chamar snmp udp 161 dos clientes NAT
    ele puxa o snmp do roteador.

    ip nat inside source static udp 192.168.2.238 161 201.xxx.xxx.238 161 extendable
    ip nat inside source static 192.168.2.238 201.xxx.xxx.238 extendable
    !
    access-list 1 permit 192.168.2.0 0.0.0.255

    eu quero puxar o snmp da maquina 238.
    Abraços.

    0

    0

Deixe uma resposta