«

»

abr 12 2008

Oito Dicas para Design e Troubleshooting de LANs

Caros, Este é um documento de “Troubleshooting Notes” que utilizava nos laboratórios de troubleshooting da FIAP. A intenção é a de ressaltar 8 problemas frequentes de design e troubleshooting de redes LAN.

Abcos, Lmatos.

——————————————————————————

1- Configurar Duplex and speed

Switch(config-if)# speed 100 
Switch(config-if)# duplex full

Troubleshooting Note: O host conectado a porta deve, obrigatoriamente, possuir velocidade e modo de transmissão fixada no driver da placa de rede. Caso contrário, o switch ficará com a porta configurada em 100 Mbits/Full duplex e o servidor ficará com a placa de rede configurada em 100 Mbits/Half duplex.

Sintomas : Incremento do contador de número de colisões na porta do switch, não admitido em ambientes full duplex.

2- Spanning tree Root

Per Vlan

Switch(config)# spanning-tree vlan <vlan_id> root primary

Processo de eleição do Root Bridge

  1. Bridge Priority – Numerical value held by switches. All Catalyst switches are 32768
  2. Se empatar, Bridge ID = MAC Address

Troubleshooting Note: É extremamente recomendado que seja designado como root bridge um equipamento com alto MTBF. Caso o root bridge fique indisponível, haverá um travamento na rede durante o novo processo de eleição e convergência da topologia.

3- Configurar porta para subir o link de forma mais rápida 

Switch(config-if)# spanning-tree portfast 

Etapas no modo padrão:

  • From initialization to blocking
  • From blocking to listening or to disabled
  • From listening to learning or to disabled
  • From learning to forwarding or to disabled
  • From forwarding to disabled

Troubleshooting Note: É extremamente recomendado que as placas de rede dos servidores possuam um menor tempo de transição entre o status down e up. Contudo, atentar para que sejam mitigados possíveis loops quando da não utilização do spanning tree nesta porta.

OBS: Outra forma de habilitar a mesma configuração:

Switch(config-if)#switchport mode host

4- Prevenção contra loop quando utilizar portfast
 
Bridge Protocol Data Unit = Bpdu
Solução = Bpdu guard

Switch(config-if)# spanning-tree portfast bpduguard 

Opcionais (Altera recover time da porta)

Switch(config-if)# errdisable recovery cause bpduguard
Switch(config-if)# errdisable recovery interval 400

(Default recover time da porta = 300 segundos)

Troubleshooting Note: É extremamente recomendado utilizar o bpduguard quando configurada uma porta como portfast. O Bpduguard colocará a porta em errdisable state quando “escutar” frames bpdu na porta que fora configurada como portfast.

5- Configuração VTP

Switch(config)# vtp mode transparent
Switch(config)# vtp domain cisco
Switch(config)# vtp password 123

Troubleshooting Note: É extremamente recomendado que novos switches que forem inseridos na rede de produção sejam inicialmente configurados no modo “transparent”. Caso o mesmo seja inserido na rede de produção no modo “server “ e possuir o mesmo domínio VTP e uma database
revision number maior, ele alterará todas as vlans da rede atual ocasionando inconsistência do vlan database.

6- Configurar Port modes

Acess, Trunk , Dynamic Desirable

Switch(config-if)# switchport mode trunk (ou access)

Troubleshooting Note: É extremamente recomendado não deixar nenhuma porta configurada como dynamic, este procedimento evita o futuro aparecimento de Trunks indesejados. Sempre configure todas as portas como “access” e depois altere para “trunk” as portas que necessitarem serem configuradas como trunk. Para que o trunk funcione sem problemas, obrigatoriamente, os dois equipamentos devem estar configurados no mesmo domínio VTP.

7- Configurar Trunk utilizando protocolo 802.1q

mode, encapsulation

Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk

OBS: Ao fixar o mode da porta, o protocolo DTP é desabilitado.

Troubleshooting Note: Existem switches que não possuem o comando “switchport trunk encapsulation”, estes switches utilizam o protocolo dot1q por default e não suportam o protocolo ISL.

8- Configurar Etherchanel nas portas f0/2 e f0/3 utilizando o protocolo PagP

Switch(config-if)# speed 100
Switch(config-if)# duplex full
Switch(config-if)# switchport mode access
Switch(config-if)# channel-group 1 mode desirable

Modes:

  • Desirable – Negocia etherchannel utilizando protocolo PagP
  • Auto – Modo passivo, apenas escuta solicitações para negociação
  • ON – Não utiliza PagP, configura etherchannel de forma incondicional

Troubleshooting Note: Antes de configurar Etherchannel entre os switches , obrigatoriamente, primeiro coloque as portas em modo “administrative down” através do comando shutdown. Caso contrário, o segundo equipamento (que ainda não foi configurado) detectará condição de loop uma vez que o etherchannel configurado no primeiro equipamento divulgará o MAC ADDRESS da primeira porta em todas as portas que compõe o channel group. Obrigatoriamente todas as portas que pertençam a um channel group devem possuir as mesmas configurações referentes à velocidade e modo de transmissão.



Comente usando o Facebook!
0
0

10 comentários

Pular para o formulário de comentário

  1. ferrugem

    Olá Luis Matos.. Legal ver um post seu por aqui .. Post mais vezes.. Tenho que sua vivência e sua experiência na área têm muito a contribuir com este espaço!!!

    Bem, quanto ao post, achei bem legal .. Algumas coisas eu já conhecia, como ter que colocar um novo switch no dominio VTP como no modo “transparent” .. A porta do switch estar na mesma velocidade do servidor, switchs que só funcionam o 802.1q …

    Agora muita coisa eu não sabia ainda.. portfast eu nem sequer tinha ouvido falar!!! 😀

    Na parte 7, Configurar Trunk utilizando protocolo 802.1q, quando fez a observação e disse DTP, seria STP!?!?

    Abraços Luis!!!

    0

    0
  2. Italo Amaral

    Parabéns Luis!

    Excelente conteúdo! Seu post foi como um guia rápido de switching.,,

    Italo Amaral

    0

    0
  3. Italo Amaral

    Prezados,

    Para quem não sabe o termo MTBF refere-se a Mean Time Between Failure. Ele é um ponto muito importante a ser considerado durante a fase de Design de uma Solução (pré-venda).

    Abraço,

    Italo Amaral

    0

    0
  4. Marco Filippetti

    Muito bom post Luis! De interesse geral, sem dúvida!

    Ferrugem, DTP = Dynamic Trunking Protocol. Dê uma olhada no link abaixo para maiores informações…

    (http://www.cisco.com/en/US/tech/tk389/tk390/tk181/tsd_technology_support_sub-protocol_home.html)

    Abs!!

    Marco.

    0

    0
  5. ferrugem

    Ah sim .. Blz Marco.. Valeu !!!

    0

    0
  6. Fabricio Neves

    Ótimo post Matos!! valeu pelo esclarecimento tb Ítalo e Marco.. estava sem saber ambos ehheheh

    0

    0
  7. RHama

    Boas dicas Matos…
    Só gostaria de saber se possui informações sobre Gigstack.
    tem uma pilha em contigência interligada por Gigastack e ele só assume Half. Isso não causa problemas em redes full ?
    Já detectei erros nas interfaces Giga e não sei se deveria retirar estas contigências.
    1 pilha com 10 Switches
    a primeiro e último SW interligado no Core em 100M full
    cascateamento por Gigastack ( Half)

    Até mais

    0

    0
  8. Fernando Nogueira

    Muito bom esse artigo, vou guarda-lo junto a outros que tenho. Será de grande valia.

    Obrigado…

    Abs…

    0

    0
  9. Rafael Isquierdo

    A dica do PortFast é muito massa. Fiz isso no PKT e percebi o quao rapido mais a rede converge. Só é preciso saber que o esse comando só é bom se aplicar em portas do switch do estão diretamente conectadas a Hosts, Server. Nunca usar em portas conectadas a Routers ou até mesmo a outros switches, ao menos que vc tenha absoluta certeza que isso não causará um loop ou perdas de pacote.

    0

    0
  10. Edson

    Obrigado Luis, dicas valiosas hein 🙂

    0

    0

Deixe uma resposta