«

»

jun 11 2008

Tutorial OSPF – Parte 3

Pessoal, vamos seguir com o tutorial sobre o protocolo OSPF, agora na parte 3!

Configuração do OSPF em um router Cisco

A configuração do protocolo OSPF em routers Cisco é bastante direta, e realizada em apenas 2 passos:

  1. Habilitar o processo OSPF no router via comando “router ospf {ID do processo OSPF}”
  2. Associar areas OSPF às interfaces, via comando “network {rede ou endereço IP} {wildcard} {area}”

O ID do processo OSPF não precisa ser o mesmo em roteadores distintos, e o mais interessante, vários processos OSPF podem ser executados em um mesmo router. Este procedimento não é recomendado, entretanto, já que cada instância consome grandes porções de CPU e memória. Em suma, um bom design não utilizaria mais de um processo OSPF em um mesmo router.

O parâmetro “network”, diferentemente do que ocorre na configuração de outros protocolos de roteamento, serve, no OSPF, para indicar quais interfaces participarão do processo, e quais as áreas OSPF a que pertencem. Esta é uma particularidade do protocolo. Devemos nos lembrar que, em uma rede OSPF, a fronteira é o link, e este é definido pela interface. Até aproveitando este gancho para responder a uma pergunta postada no blog: “Por que os parâmetros de sumarização, em redes OSPF, devem ser configurados na interface?”. Resposta: Pelo motivo anteriormente mencionado: As áreas.

O ID da área é definido por um número inteiro compreendido entre 0 e 4294967295, e também pode assumir a forma de um endereço IP (ex: área 0 = 0.0.0.0).

Autenticação OSPF

OSPF permite a autenticação de pacotes de forma que routers podem participar de domínios de roteamento baseados em senhas pré-definidas. Por default, OSPF não utiliza esquemas de autenticação. Basicamente, existem 2 métodos de autenticação que podem ser utilizados:

1) Autenticação Simples – Este método permite que chaves sejam configuradas por área OSPF. Routers em uma mesma área que desejem participar do processo de roteamento devem ser configurados com a mesma chave. A desvantagem deste método é que as chaves são trocadas pela rede, e podem ser facilmente interceptadas.

Exemplo:

interface Ethernet0
ip address 10.10.10.10 255.255.255.0
ip ospf authentication-key minhasenha

router ospf 10
network 10.10.0.0 0.0.255.255 area 0
area 0 authentication

2) Autenticação Forte (MD-5) – Neste método, uma chave e uma senha são configurados em cada router. O router usa, então, um algoritmo baseado no próprio pacote OSPF, na chave e no ID da chave para gerar um “message digest”, que é inserido no pacote. Este método permite a troca de senha sem a interrupção da comunicação.

Exemplo de aplicação:

interface Ethernet0
ip address 10.10.10.10 255.255.255.0
ip ospf message-digest-key 10 md5 mypassword

router ospf 10
network 10.10.0.0 0.0.255.255 area 0
area 0 authentication message-digest

Aguardem a próxima parte do artigo! Falaremos de áreas.

Abs!!

Marco.



Comente usando o Facebook!
0
0

7 comentários

Pular para o formulário de comentário

  1. Rodrigo Falcão

    Uma das coisas que eu acho fantástico nesse blog é isso! Vc está navegando e pinba…um novo post!!
    Quer dizer, tem sempre coisa novas, e muitas vezes nos falta é tempo de ler tudo com calma.
    Parabéns Marco, Colaboradores e amigos que fazem desse blog o Nº 1 na minha opinião!!!

    Abçs!

    0

    0
  2. Petry

    Pessoal,

    Para o povo do linux, conheçam o Zebra ( http://www.zebra.org ). É uma boa ferramentâ para estudos de protocolos de roteamento..

    []s !

    0

    0
  3. Toguko

    Não compreendi bem o autenticação forte, os dois roteadores precisam ter a mesma Chave e senha configuradas ?

    Ou a configuração poderia ser como abaixo, com key e senhas diferentes
    R1 teria a configuração abaixo:
    !
    interface Ethernet0
    ip address 10.10.10.10 255.255.255.0
    ip ospf message-digest-key 10 md5 mypassword
    !
    router ospf 10
    network 10.10.0.0 0.0.255.255 area 0
    area 0 authentication message-digest

    E o R2:
    !
    interface Ethernet0
    ip address 20.10.10.10 255.255.255.0
    ip ospf message-digest-key 11 md5 secondpassword
    !
    router ospf 10
    network 20.10.0.0 0.0.255.255 area 0
    area 0 authentication message-digest

    0

    0
  4. Marco Filippetti

    Toguko, o ID e a senha devem ser os mesmos para routers no mesmo domínio.

    http://www.avici.com/documentation/HTMLDocs/02223-06_revBA/ospf11.html

    Dica: Faça um teste no Dynamips… vai ajuda-lo a compreender a operação do que foi discutido 😉 !

    Abs!

    Marco

    0

    0
  5. Herbert

    Ainda não consegui compreender a funcionalidade de rodar mais de um processo OSPF em um router.

    0

    0
  6. Marcelo Costa

    vlw Marco, vou seguir os tutoriais e testar no dynamips tbm!
    e na espera pela continuação.

    0

    0
  7. Willian23

    Tenho uma dúvida que esta me deixando maluco com OSPF. Ao tentar configurar OSPF pelo packet tracer não da certo, um exemplo. Com um endereço /24, ao usar a wildmask 0.0.0.255 não funciona, mas se eu uso 0.255.255.255 ela funciona. Estou meio confuso, não sei se o packet tracer esta errado ou se estou calculando uma wildmask de forma errada, alguém sabe tirar essa minha dúvida?

    0

    0

Deixe uma resposta