«

»

jul 11 2008

[CCNA] Desafio 1 semana 2 – Julho de 2008

Pessoal, mais uma questão sobre o NAT.

Como já dissemos antes, o objetivo destes desafios é ajuda-los na preparação rumo ao CCNA, e não intimidá-los! Portanto, deixem suas inibições de lado, pesquisem sobre o assunto e… PARTICIPEM!!!

Lembrem-se de comentar sua resposta, e não apenas colocar a letra da alternativa. Isso vai ajudá-los a memorizar o assunto.

Abraços,

Fábio A. de Amorim

NAT



Comente usando o Facebook!
0
0

18 comentários

Pular para o formulário de comentário

  1. alamon71

    olá inaugurando então as respostas desse desafio.

    vou de ´´PAT is configured“ pois reparem que nos global address aparecem as portas TCP e UDP utilizadas na tradução de endereços por isso PAT (port address translaction).

    0

    0
  2. Fabricio Neves

    Letra C
    PAT is configured

    Podemos perceber na saída do comando que na coluna Global Inside – que se refere ao endereçde saída para a internet – permanece o mesmo IP, sendo alteradas apenas as portas, à medida que mais hosts internos (Inside Local) solicitam conexões.

    0

    0
  3. Daniel Rodrigues

    Vou de letra C tambem. PAT!
    Pois o endereco INSIDE GLOBAL de traducao é sempre o mesmo, alterando somente as portas.

    Nao entendi a sua colocao, alamon71 : aparecem as portas TCP e UDP utilizadas na tradução de endereços por isso PAT ?
    Como assim? se as portas possiveis para o NAT vao de 0 a mais de 65000 por ip?(teoricamente)

    []s

    0

    0
  4. Fernando Guerreiro

    Letra C “pat is configured”.
    Pois como já foi dito anteriormente apenas as portas variam a medida que os endereços são traduzidos ^^

    0

    0
  5. thiagocella

    Acredito ser a letra C.

    Pois pelo que da para ler no grafico , existem varias maquinas saindo com o mesmo endereco ip , mas com varias portas , caracteristica do PAT.

    0

    0
  6. Rafael Mendes

    Por usar diferentes portas, e o mesmo numero IP.

    Resposta C – PAT

    0

    0
  7. diogocampregher

    Letra C
    Números de porta representam PAT.

    0

    0
  8. Herbert

    Letra C.

    A tabela Inside global e inside local mostra que há uma correspondência de vários endereços IP’s locais e suas portas com apenas 1 endereço IP global, sendo essa uma característica do PAT.

    0

    0
  9. Eduardo Simao

    Letra C
    Além do inside global ser o mesmo, a tabela do PAT sempre tem as portas, e das outras não.

    0

    0
  10. Cleber Monin

    Letra C-

    0

    0
  11. Adalberto Nuno

    Acredito que seja a letra c, por que existe somente mundanças nas portas utilizadas nas traduções de endereços global. Os endereços internos ou locais são endereços de host.

    0

    0
  12. rodolphotdai

    Letra C

    Como podemos notar no gráfico, a tabela está sendo montada em cima do endereço 192.18.24.211(INSIDE GLOBAL) que é o endereço sujeito a tradução dos endereços internos (INSIDE LOCAL) que são os endereços apresentados no campo INSIDE LOCAL do gráfico, para tal tradução é trocado o campo IP origem dos pacotes entrada para o IP global 192.18.24.211, para o NAT se achar nesse metodo de tradução, são usados portas de origem para referenciar as diversas traduções e para o nat encontrar em qual IP e porta devolver os pacotes, esse método é chamado de Nat Overloading ou Port Address Translation(PAT)

    Podemos configurar isso com os seguinte comandos:

    router(config)# int f0/0
    router(config-if)# ip add 192.168.254.1 255.255.255.0
    router(config-if)# ip nat inside
    router(config)# int s0/0
    router(config-if)# ip add 192.18.24.211 255.255.255.0
    router(config-if)# ip nat outside
    router(config)# access-list 1 permit 192.168.254.0 0.0.0.255
    router(config)# ip nat inside source list 1 interface serial0/0 overloading

    Bom espero ter ajudado Abraços.

    0

    0
  13. elimax

    Estou em dúvida… não tenho certeza que o PAT funcione assim, atribuindo o mesmo número de porta no Inside e no Outside. Normalmente o número de porta traduzido é incremental.

    Está parecendo mais que foi configurado um NAT mas esqueceu-se de dar o “overload” no final. Assim, apenas o IP está sento traduzido, mas não a porta.

    Vou até fazer um labzinho pra confirmar, mas acho eu iria na “d”.

    0

    0
  14. elimax

    Esquece, é a “c”… A tradução só é feita para outra porta se a original não estiver disponível.

    http://www.cisco.com/en/US/tech/tk648/tk361/technologies_q_and_a_item09186a00800e523b.shtml#qa12

    PAT with one IP address:
    (…)
    5. If the requested source port is available, PAT assigns the source port, and the session continues.
    6. If the requested source port is not available, NAT starts searching from the beginning of the relevant group (starting at 1 for TCP or UDP applications, and from 0 for ICMP).

    0

    0
  15. alberto_villa

    Bom Dia,

    Resposta C – PAT is configured.

    As nomenclaturas de termos utilizados no NAT são :

    Inside Local – endereço do host local antes do NAT, endereço como é conhecido na rede interna.

    Inside Global – endereço do host depois do NAT, como é conhecido pela rede externa.

    O NAT pode ser configurado de 3 formas : estático, dinâmico ou overloading(PAT) .

    Na configuração estática vc associa diretamente um endereço Local a um Global. Vc precisa ter o mesmo número disponível de endereços globais que os locais, que pretendem acessar o meio externo.

    Na configuração dinâmica, vc cria um pool de endereços globais e vai associando os locais de acordo com a demanda.Se todos os globais disponíveis estiverem ocupados e for necessária uma nova conexão ficará aguardando um endereço ser liberado.

    Na configuração com overload, a identificação do host fica por conta da porta que é associada ao endereço, o que permite em teoria, 65000 hosts internos utilizando um único endereço global.

    Vale uma ressalva : O NAT foi um recurso(gambiarra ???) para extender a vida do IPV4 e como a faixa de endereço do IPV6 é MUITO maior, esse recurso não existe no IPV6.

    Abraços..

    0

    0
  16. Israel Carlos

    Olá galera,

    A resposta é a letra C.
    Veja que na coluna ” pro ” aparece as portas que estão sendo utilizadas pela rede. Abaixo deixo um exemplo de configuração:

    Configuração na interface:

    interface FastEthernet0.2
    description ** Engenharia **
    encapsulation dot1Q 4
    ip address 10.121.3.150 255.255.255.128
    ip nat inside

    0

    0
  17. Innocent

    A resposta é PAT is configured .

    Fica claro na saída do comando show ip nat translations a tradução por portas utilizando apenas um endereço IP inside Global .

    O rodolphotda , não foi nem um pouco humilde na sua resposta , hahahaha!!! , não deixou sobra para ninguém , hahahaha!!! , vou copiar e colar a resposta dele , hahahaha!!!! .

    Um abraço .

    0

    0
  18. Edson

    Comentário do Daniel
    “Pois o endereco INSIDE GLOBAL de traducao é sempre o mesmo, alterando somente as portas.”
    Matou a charada! 🙂

    PAT

    0

    0

Deixe uma resposta