«

»

jul 24 2008

Acoplando um Sistema de Aceleração – Juniper WX – a um Roteador Cisco via WCCPv2

Minimizar o impacto gerados por protocolos do tipo chatty (faz muito uso de conversas na rede) é uma tarefa bem interessante sobre redes de alta latência. Estes protocolos tais como: MAPI (Exchange Server) e CIFS (Microsoft) são exemplos clássicos de protocolos do tipo chatty.

O objetivo deste artigo é mostrar aos leitores como foi acoplado um sistema de aceleração de Wan em rotedores Cisco usando o protocolo WCCPv2 para fazer a operação de interceptação de pacotes.

O WCCP (Web Cache Communication Protocol) é um protocolo desenvolvido pela Cisco para integrar sistemas de Web Caching ou seja, o WCCP redireciona de forma transparente todo o tráfego para servidores proxy sem a necessidade dos usuários reconfigurarem seus browsers para usá-lo.

Neste caso, o roteador Cisco usa o Web Cache Communication Protocol (WCCPv2) para redirecionar todo o tráfego dos protocolos selecionados para o dispositivo ligado em off-path (Juniper WX).

O problema

Normalmente o acelerador fica em linha (in-line) entre a porta do switch interno e a porta ethernet do roteador. O problema gerado é que não poderíamos ligar o equipamento desta forma devido a problemas de topologia e também não alcançaríamos outras redes que chegavam entre o ambiente on-shore e off-shore. Neste caso a melhor solução foi ligarmos o equipamento fora de linha (off-path).

In-line

Ligação em Linha

Off-path

Ligação Off-Path

Ambiente de Teste Simulado para Homologação do Ambiente

Homologacao

Ambiente simulado em laboratório

O tráfego de redução de subredes e aplicações elegíveis são reduzidos – todos os outros dados são retornados para o roteador e encaminhados através da tabela de roteamento.

Obs: O WCCP ID 85 e 87 estão sendo utilizados para identificar os protocolos TCP e UDP respectivamente.

 Configuração do roteador off-shore

!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RT-OFF-SHORE

!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$KsDI$ThSPzJp1v1T/VvKQDj8AY/
!
no network-clock-participate aim 0
no network-clock-participate aim 1
no aaa new-model
ip subnet-zero
ip wccp 85 redirect-list 120
ip wccp 87 redirect-list 120
!
!
ip cef
!
no ftp-server write-enable
!

interface FastEthernet0/0
ip address 10.23.0.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.23.0.13 255.255.255.252
 ip wccp 85 redirect in
ip wccp 87 redirect in
duplex full
speed 100
!
interface Serial0/0/0
bandwidth 1024
ip address 10.23.0.2 255.255.255.252
 ip wccp 85 redirect out
ip wccp 87 redirect out
encapsulation ppp
no fair-queue
!
interface Serial0/0/1
no ip address
shutdown
clockrate 2000000
!
router ospf 100
log-adjacency-changes
redistribute connected subnets
network 10.23.0.0 0.0.0.3 area 0.0.6.3
!
ip classless
ip http server
!
!
access-list 120 permit ip any any
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
scheduler allocate 20000 1000
!
end

Configuração do Roteador On-Shore

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RT-ON-SHORE

!
boot-start-marker
boot system flash usbflash1:c2800nm-advipservicesk9-mz.124-9.T1.bin
boot system flash
boot-end-marker
!
enable secret 5 $1$v/Bn$0l4u2GSVRZgCvNqABn0De.
!
no aaa new-model
!
resource policy
!
ip wccp 85 redirect-list 120
ip wccp 87 redirect-list 120
!
!
ip cef
!
voice-card 0
no dspfarm
!
interface GigabitEthernet0/0
ip address 10.23.255.251 255.255.255.128
duplex auto
speed 100
!
interface GigabitEthernet0/1
ip address 10.23.0.9 255.255.255.252
ip wccp 85 redirect in
ip wccp 87 redirect in
duplex full
speed 100
!
interface Serial0/0/0
bandwidth 1024
ip address 10.23.0.1 255.255.255.252
 ip wccp 85 redirect out
ip wccp 87 redirect out
encapsulation ppp
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 100
log-adjacency-changes
redistribute connected subnets
network 10.23.0.0 0.0.0.3 area 0.0.6.3
network 10.23.0.8 0.0.0.3 area 0.0.6.3
network 10.23.255.128 0.0.0.127 area 0.0.6.3
!
!
!
no ip http server
no ip http secure-server
!
access-list 120 permit ip any any
!
control-plane
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
scheduler allocate 20000 1000
!
end

Configuração do WCCP no Acelerador de Wan

WX-2

Com isso a infraestrutura de rede está pronta para configurarmos o acelerador, mas isso não é tópico deste blog . 😉

Até o próximo artigo….



Comente usando o Facebook!
0
0

12 comentários

Pular para o formulário de comentário

  1. Minu

    Meu Deus, que loucura!, Ótimo artigo!! 😀

    0

    0
  2. rodolphotdai

    Esse Marcos Pitanga é uma máquina de redes
    Ótimo post, anexando ao banco de post’s

    Abraços
    Rodolpho

    0

    0
  3. Mizael Andrade Reis

    O cara é bom mesmo!!!!

    0

    0
  4. Plinio Monteiro

    Cara, show de bola… Excelente post…

    Parabéns!

    0

    0
  5. Rodrigo Falcão

    Valeu Marcos, show de bola, como sempre!!

    0

    0
  6. maciel.santos

    Muito bom, é a convergência ultrapassando fronteiras , parabéns Marcos !!!

    0

    0
  7. Rodrigo C. Soave

    Isso me faz lembrar os workshops que tive sobre qual appliance usar para otimizar WAN. Comparando Cisco WAAS e Riverbed, e a Riverbed se saiu melhor em todos os testes.

    Alias o que eu tenho ouvido falar é que a Riverbed tem se saido melhor frente a todos concorrentes com relação a esse tipo de solução.

    Link para alguma consulta: http://www.tredent.com/riverbed/riverbed-steelhead-vs-cisco-waas.php

    Abs

    Rodrigo

    0

    0
  8. Marcos Pitanga

    Em alguns aspectos o Riverbed ganha do Juniper e em outros ele perde. Já participei de alguns POC (Provas de Conceitos) entre Juniper, Riverbed e Cisco.

    0

    0
  9. Rodrigo C. Soave

    comparativo melhor entre cisco waas e riverbed no youtube: http://www.youtube.com/watch?v=59fVmvhsI7o

    Abs

    0

    0
  10. Daniel Neto

    Esta é apenas uma das maneiras encontradas. Há outras igualmente eficientes 😀

    0

    0
  11. Marcos Pitanga

    Claro que sim Daniel, tudo depende do cenário.

    O melhor cenário é usá-lo IN-LINE mas neste caso não podíamos executar este modelo de deployment.

    Poderíamos fazer a injeção de rotas via RIP ou PBR. Mas em nosso ambiente de homologação e por recomendação da própria Juniper o WCCP saiu-se muito bem.

    []´s

    0

    0
  12. diogenes

    Prezado Marcos,

    Aproveito o post para tirar uma dúvida pois aqui no trabalho o pessoal usa o Juniper e gostaria muito de entender melhor seu funcionamento e conceitos, aqui meu acesso é limitado não configuro o Juniper para os clientes apenas tenho acesso para verificar ofensores quando o pessoal reclama de lentidão no local, e sempre me disseram que ele “obrigatoriamente tem de ficar” entre a LAN e a WAN para otimizar o tráfego, por isso não entendi bem essa ligação fora de linha (off-path), isso foi devido o LAB de simulação ou realmente existem cenários onde podemos liga-lo assim na prática??? obrigado e até mais.

    Diógenes.

    0

    0

Deixe uma resposta