«

»

ago 01 2008

Gerenciamento de Rede Fora de Banda (OOB – Out-Of-Band)

Uma rede fora-de-banda (OOB) é um recurso empregado por administradores e projetistas de rede que permite a tarefa de gerenciamento e monitoramento  em regiões onde não se trafega dados de uma rede, seja ela Lan, Man ou Wan. Ou seja, as interfaces de roteadores, servidores, firewalls, portas de switches recebem o nome de interfaces “In-Band”. Nestas interfaces temos o tráfego tradicional gerados pelos ativos de rede. Imagine então uma rede composta por muitos equipamentos de rede. Não vou colocar nem tantos assim,  imagine uns 15 (quinze) roteadores e 40 (quarenta) switches dispersos pelo Brasil sob sua administração. E, as vezes, você não possui equipes especializadas nas localidades e, para piorar sua situação, você perde a conectividade com estes equipamentos via rede “In-Band” (via Telnet, SSH) por exemplo. Quem nunca passou por uma situação aqui descrita que atire o primeiro router 😉

Bem este é o objetivo deste artigo, mostrar ao leitor como montar um rede fora de banda capaz de permitir acesso as consoles destes equipamentos remotamente. E por incrível que pareça isto é um problema muito comum e, costuma ocorrer com bastante frequência.

A maioria dos equipamentos gerenciáveis de rede possuem dois tipos de conexões:  em banda (In-Band) e fora-de-banda (Out-Of-Band).  Assim como ilustrado nas figuras abaixo:

Switch - OOB

Switch Gerenciável

Roteador - OOB-2

Roteador Cisco

Para permitir o gerenciamento remoto destes ativos de rede fazemos uso do recurso de terminal server , normalmente um computador com múltiplas interfaces seriais que, utilizando  o sistema de Telnet Reverso consigamos acessar as interfaces de console dos equipamentos de rede.

Existem diversos fabricantes de Terminal Servers, mas por que não fazermos uso de um  AS-2511 para executarmos esta tarefa?

Um Cisco Access Server 2511 possui uma porta ethernet, duas portas seriais síncronas e  16 (dezesseis) portas seriais assíncronas.

OOB-3

Rede OOB – Out-Of-Band

De acordo com a figura estação possui duas opções de gerenciamento: In-Band através do telnet ou ssh direto para a interface 192.168.2.253 do roteador e, out-of-band através do telnet reverso para o terminal server na porta 2001). Ou seja, se você perder a conectividade pela rede In-Band basta acessar seu equipamento através do Access Server por intermédio de um Telnet Reverso na porta serial mapeada ao roteador de destino. Para isso basta executar o comando telnet 192.168.1.100 2001.

Configurando o Access Server 2511

Para ligarmos os equipamentos ao 2511 basta observamos a figura a seguir.

 

OOB-5

Ligação de uma rede OOB

Iremos acessar, por exemplo meu Lab particular composto pelos seguintes equipamentos:

Equipamento		Porta Física AS-2511		Porta TCP

SW-3750g		1				2001
SW-2950			2				2002
SW-2950			3				2003
SW-2970			4				2004
SW-2900XL		5				2005
RT-2611			6				2006
RT-2611			7				2007
RT-1721			8				2008
RT-1721			9				2009
RT-805			10				2010
RT-805			11				2011
PIX-515e		12				2012
PIX-515e		13				2013
FW-SSG-20		14				2014

O arquivo de configuração:

service timestamps debug uptimeservice timestamps log uptime
service password-encryption
!
hostname AS-2511
!
enable secret level 5 5 $1$8lsn$Cfn8W2hKFV4J79r8MdCTz0
enable secret 5 $1$3z7/$6DeABpEF7b5F2pS06Ta4M9
!
clock timezone EST -5
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
ip address 192.168.1.100 255.255.255.0
!
interface Serial0
no ip address
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!
ip classless
no ip http server
ip pim bidir-enable
!
snmp-server community public RO
snmp-server community private RW
snmp-server contact Marcos_Pitanga
snmp-server chassis-id AS-2511
snmp-server host 192.168.1.1 publicline con 0
login
line 1 16
exec-timeout 0 0
no exec
transport preferred telnet
transport input all
transport output lat pad telnet rlogin mop udptn nasi
stopbits 1
line aux 0
line vty 0 4
exec-timeout 0 0
!
end

Digitaremos o comando “show line” para listarmos as portas e respectivas conexões:

AS-2511#show line

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
0 CTY - - - - - 0 0 0/0 -
1 TTY 9600/9600 - - - - - 0 5 0/0 -
2 TTY 9600/9600 - - - - - 0 0 0/0 -
3 TTY 9600/9600 - - - - - 0 0 0/0 -
4 TTY 9600/9600 - - - - - 0 0 0/0 -
5 TTY 9600/9600 - - - - - 0 0 0/0 -
6 TTY 9600/9600 - - - - - 0 0 0/0 -
7 TTY 9600/9600 - - - - - 0 0 0/0 -
8 TTY 9600/9600 - - - - - 0 0 0/0 -
9 TTY 9600/9600 - - - - - 0 0 0/0 -
10 TTY 9600/9600 - - - - - 0 0 0/0 -
11 TTY 9600/9600 - - - - - 0 0 0/0 -
12 TTY 9600/9600 - - - - - 0 0 0/0 -
13 TTY 9600/9600 - - - - - 0 0 0/0 -
14 TTY 9600/9600 - - - - - 0 0 0/0 -
15 VTY - - - - - 0 0 0/0 -
16 VTY - - - - - 0 0 0/0 -
17 VTY - - - - - 0 0 0/0 -
18 VTY - - - - - 1 0 0/0 -
19 VTY - - - - - 0 0 0/0 -
20 VTY - - - - - 0 0 0/0 -
21 VTY - - - - - 0 0 0/0 -
22 VTY - - - - - 0 0 0/0 -
Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

telnet 192.168.1.100 2001

Trying 192.168.1.100...Connected to 192.168.1.100.

User Access Verification

Username: cisco
Password:

SW-3750g>

Agora confirmaremos a conexão no terminal server.

AS-2511#show line

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int0
CTY - - - - - 0 0 0/0 -
* 1 TTY 9600/9600 - - - - - 3 5 0/0 -

Com isso meu Particular LAB  estará pronto para fazermos alguns exercícios para CCNA e CCNP  aos integrantes do grupo

Até ao próximo artigo…



Comente usando o Facebook!
0
0

13 comentários

Pular para o formulário de comentário

  1. Minu

    Ótimo recurso, visa facilitar e muito a vida de um administrador. Eu não conehcia, mas analisando acho que este recurso pode salvar até mesmo um emprego 😀

    0

    0
  2. sergiombrg

    Ótimo artigo! Ótimo recurso!

    Assim não precisa do técnio pra ir até o equipamento e reiniciar heheheheh

    [ ]’s

    0

    0
  3. Marco Filippetti

    Um adendo! O gerenciamento OOB tb pode ser realizado via Modems conectados à porta AUX ou CON de routers e switches. Desta forma, quando a coisa for mesmo “para o brejo”, você tem a opção de ligar para o número da linha na qual o modem remoto encontra-se conectado e conseguir o acesso OOB ao equipamento. Existe tb a opção de se utilizar um “power switch” como o da APC (http://www.apcc.com/resource/include/techspec_index.cfm?base_sku=AP9225) para realizar um “power cycle” remoto no dispositivo, tb via acesso OOB.

    Bom post Marcos!!! obrigado!

    marco.

    0

    0
  4. Roberto Mendonça

    Muito bom o Post.
    Também fiz uso desse recurso para estudar ao CCIE.
    Inclusive, esse é um padrão(pelo que percebo) das empresas que alugam Racks. Cheguei a alugar dois de empresas diferentes dos EUA e é assim que funcionam.

    O Caso mais simples de uso é fazer uma ligação direta entre a Auxiliar e a Console e fazer o acesso via telnet reverso.

    Normalmente para muitas conexões, como o exemplo do Marcos, fazemos uma associação dos ips+portas com os hosts, facilitando assim o acesso.
    Ex.: ip host R1 1.1.1.1 2001

    Abs,

    Roberto Mendonça

    0

    0
  5. diogocampregher

    Muito interessante!! Cada dia uma nova lição aqui no blog!!!
    Abraços a todos

    0

    0
  6. Rodrigo Colen (BH)

    Muito bom Marcos, parabéns!

    Esse recurso é realmente de grande valia, em grandes redes!

    Gostei muito do recurso apresentado pelo Marco, por exemplo, onde trabalho, temos mais ou menos 300 routers e mais de 1200 sw, as vezes quando temos um problema em uma agencia, fica dificil resolver remotamente.

    Se tivéssemos disponível esses recursos, para acessar o equipamento via aux, seria muito bom mesmo, tem ainda o gerenciador de energia, que pode ser utilizado para um reload, em caso de necessidade.

    Tomara que role um investimento nesse âmbito! rsrs

    Pena que essa solução exige um investimento na compra de equipamentos e as vezes se torna inviável para algumas empresas.

    Muito bom Mesmo!!!

    att
    Colen

    0

    0
  7. Érik Voitic

    Simplesmente espetacular…incrível essa ferramente. Até então era desconhecida para mim.

    Parabéns pelo post Marcos e obrigado por compartilhar.

    []’s

    0

    0
  8. vstrabello

    Um exemplo de uso para isso é verificar se há alguma power outage nos sites.
    Aqui no meu serviço, ligamos para nossos colegas e temos a opção de verificar através disso para documentação de incidentes, como falta de conectividade LAN/WAN

    0

    0
  9. Anderson Rodrigues

    Já tinha ouvido falar…
    Recentemente apresentarem (se não me engano) esta ou alguma solução parecida para rede daqui da empresa.
    Realmente é interessantissimo, vou montar um lab com estas configs.

    Abraços,
    Anderson

    0

    0
  10. Rodrigo Farias

    Excelente. Esse é o tipo de post que eu mais gosto: “Coisas do mundo real”.

    Abraço!!

    0

    0
  11. Johnny Vernin

    Baseando-se praticamente no que foi dito no artigo e mais umas implementações à parte visando mobilidade, acabou sendo um dos pontos mais fortes do meu TCC da facul… e passamos com extremo sucesso… ótimo artigo…

    0

    0
  12. Marcia Guimaraes

    Ótimo artigo, Marcos…

    Na medida para quem trabalha na vida real e precisa de acesso remoto. 🙂

    Sds.
    Márcia Guimarães

    0

    0
  13. Renato Silva

    Parabéns pelo posts, Marcos.
    Gerênciamento de redes não é simplesmente ver funcionando,é manter funcional.

    0

    0

Deixe uma resposta