«

»

ago 26 2008

Criando um “As Built” de Instalação de Rede

Documentar uma rede é tão importante quanto o processo de implementação da solução. Sabemos que poucas são as pessoas que gostam de fazer este trabalho. Mas fiquem sabendo que isso facilita em muito um troubleshooting e na inserção de novos ativos de rede. O objetivo deste artigo é mostrar como construir este tipo de documento.

1o Passo: Construir o cabeçalho do documento. Este poderá seguir o seguinte formato:

Figura-1


2o Passo: Criar um Histórico das Versões do Documento. Nesta página descreva as atividades executadas e inseridas no documento cada vez que atualizá-lo.

Figura-2

3o Passo: Identificar as pessoas diretamente ligadas ao projeto

Figura-3

4o Passo: Criar um inventário de hardware e software.

Nesta etapa é interessante descrever:

a) Nome do Equipamento
b) Número de Série
c) MAC Address caso seja necessário
d) Modelo
e) Part Numbers
f) Versão do Firmware e Sistemas Operacionais dos equipamentos
g) Fabricante
h) Endereços IP atribuídos

Exemplo:

Figura-4

5o Passo: Mostrar toda a estrutura do projeto

Neste passo descreva de uma forma básica e visual como estará composta sua estrutura de Lan e Wan.

Exemplos:

Figura-5

Cenário a ser implementado de Lan

Figura-6

6o Passo: Definição das Vlans, endereçamento e acesso aos equipamentos

Figura-7

7o Passo: Desenhar as ligações físicas e os arquivos de configurações inseridos

Figura-8

Arquivo de Configuração do Switch de Distribuição

#
sysname SW-D-02
#
igmp-snooping enable
#
queue-scheduler wrr group1 0 1 1 2 2 3 3 4 4 5 5 9 6 13 7 15
#
radius scheme system
#
domain system
#
local-user admin
password simple [email protected]
service-type ssh telnet terminal
level 3
local-user manager
password simple manager
service-type ssh telnet terminal
level 2
local-user monitor
password simple monitor
service-type ssh telnet terminal
level 1
#
vlan 1
igmp-snooping enable
#
vlan 975
description VoIP
#
interface Vlan-interface1
ip address 10.230.25.12 255.255.192.0
#
interface Aux1/0/0
#
interface GigabitEthernet1/0/1
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/2
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/3
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/4
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/5
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/6
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/7
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/8
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/9
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/10
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/11
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
shutdown
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/12
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
shutdown
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/13
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/14
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/15
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/16
stp edged-port enable
port link-type hybrid
port hybrid vlan 1 untagged
broadcast-suppression pps 3000
undo jumboframe enable
voice vlan enable
description hibrida
priority-trust cos
#
interface GigabitEthernet1/0/17
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/18
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/19
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/20
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/21
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/22
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/23
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
shutdown
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/24
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
shutdown
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/25
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/26
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/27
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
undo jumboframe enable
priority-trust cos
#
interface GigabitEthernet1/0/28
stp edged-port enable
port link-type trunk
port trunk permit vlan 1 975
broadcast-suppression pps 3000
undo jumboframe enable
priority-trust cos
#
interface NULL0
#
voice vlan mac-address 001a-e800-0000 mask ffff-ff00-0000 description Siemens
voice vlan 975 enable
#
ip route-static 0.0.0.0 0.0.0.0 10.230.1.10 preference 60
#
snmp-agent
snmp-agent local-engineid 8000002B001AC1E015006877
snmp-agent community read @[email protected]#
snmp-agent sys-info version all
#
undo cluster enable
#
ssh user admin authentication-type password
ssh user admin service-type stelnet
#
user-interface aux 0
authentication-mode scheme
user-interface vty 0 4
authentication-mode scheme
protocol inbound ssh
#
return

Ao final, descreva o SLA, como acionar o suporte e o processo de escalação quando o SLA não for atingidoo

Exemplo:

Figura-9

Espero que tenha sido ao agrado de todos e até ao próximo artigo.



Comente usando o Facebook!
0
0

19 comentários

Pular para o formulário de comentário

  1. Plinio Monteiro

    Ótimo post Marcos, vou passar isso aqui pro pessoal que está fazendo uma documentação do cluster de alta disponibilidade que chegou .

    0

    0
  2. rafaelbn

    Marcos,

    Que engraçado. Ontem aqui na empresa estavamos discutindo uma maneira de montar esse tipo de documentação. Realmente o seu modelo aborda tudo, desde topologia até arquivos de configuração.
    Mas aí vai a minha pergunta, meio que de prova… =P

    Em uma rede que esta constantemente mudando, qual seria na sua opinião uma maneira de manter essa documentação viva? Pois o seu modelo me lembra uma documentação feita para um projeto específico, daquelas que são entregues em formato PDF. Mas e para o pessoal de produção, que está quase que diariamente realizando algum tipo de alteração na rede… Será que existe uma solução para esse dilema?
    Li uns artigos dizendo que a melhor maneira de fazer isso seria utilizando uma wiki. A idéia parece boa por conta da documentação ficar exposta de uma maneira simplificada e ainda ser possível controlar o acesso/edição através de logins/senhas. O que acha? Recomenda alguma coisa?

    Abraços,
    Rafael Bianco

    0

    0
  3. Daniel Rodrigues

    Rafael,
    acredito que nesse caso a questao seria centralizar as informacoes e atualizacoes em uma base e acessivel a todos envolvidos. Para isso pode-se usar um daqueles programas para gerenciamento de projetos. Conheco um free para linux chamado: dotproject.(www.dotproject.net). ele roda em php e vc cadastras variuas empresas, projetos e funcionarios..
    Acho que era isso que vc questiounou..
    espero ter ajudado..

    Marcos:
    Excelente POST..como ja comentaram acima, muito completo!
    []s

    0

    0
  4. wanpiane

    Gostei do seu modelo, onde eu estou estudando nos deram um modelo também, mais a vantagem do seu modelo é a clareza de alguns itens como: configuração dos equipamento e a simplicidade, a criação desse tipo de documento não só ajuda na hora dos problemas como deixa a boa impressão de trabalho organizado e transparente.

    0

    0
  5. Marcos Pitanga

    Wanpiane: Quanto mais simples melhor será a compreensão por parte de todos os envolvidos.

    RafaelBN: Este modelo é baseado na entrega de um determinado projeto, ele servirá de base para os processos de Gerência de Mudanças e Gerência de Configurações segundo o ITIL. É interessante que alguém da equipe sempre esteja responsável em atualizar o documento.

    0

    0
  6. Rodrigo Farias

    Marcos Pitanga,

    Este post foi brilhante!!
    Já salvei até nos meus favoritos para consultas futuras.
    Abraço

    0

    0
  7. band2headboy

    Ótimo, função perfeita para um estagiário!
    hahaha 😀
    brincadeiras de lado, belo post!

    0

    0
  8. Italo Amaral

    Pitanga,

    Excelente! Documentar é importantíssimo!

    Abraço,

    0

    0
  9. cristian

    Excelente!!!Espero ver mais modelos de como documentar uma rede e o processo de implementação da solução, desde uma rede simples com 50 micros e switches até rede como essas.
    Um excelente trabalho.

    Abraços,

    0

    0
  10. Rodrigo Falcão

    Show de bola Pitanga!!
    Bem detalhado e muito claro, o que facilita a leitura e alteração do documento.

    Abs!!

    0

    0
  11. Fabricio Neves

    Excelente post!
    Parabéns Pitanga! Já salvei nos meus favoritos tb heheh

    0

    0
  12. guilhermehgalves

    Muito bom post

    0

    0
  13. Fabio A de Amorim

    Muito bom Marcos!

    Abraços!

    0

    0
  14. Leonardo Degobi

    Excelente post!

    Já está no favoritos e no hd: dicas do blog.. hehehehe

    0

    0
  15. Mizael Andrade Reis

    excelente Marcos.

    0

    0
  16. ice

    Vou comer muita farinha para chegar há esse nível de documentação, manda bastante água que dever chego lá!!!!

    Muito bom!!!!
    Parabéns!!!

    0

    0
  17. Fabio Santos

    Marcos, 3 meses atrás documentei a rede da filial da conssecionária onde eu trabalho. Achei chato e cansativo faze-lo. No entanto, como vc cita em seu post é imprescindível. Hoje posso perceber a facilidade que isto gera na hora de manutenir o sistema. Vou usar este seu modelo – muito mais técnico, para fazer a v2 da minha documentacao.

    Valeu!!!

    Fábio Santos

    0

    0
  18. Claudio Marcolino

    Gostei!!! Mutio bom, quanto mais prático melhor.

    Sobre o coments do rafaelbn, trabalhei nuam empresa e fiz varias documentação e também alguns procedimentos pertinentes ao TI utilizando wiki para gerenciar., realmente é muito prático…

    A documentação é impressindível e este modélo é o bicho ta perfeito.

    Parabéns Pitanga!!!

    Claudio

    0

    0
  19. Mateus Belluzzo

    Marcos,

    Uma das coisas que define uma pessoa de sucesso é a habilidade de como compartilhar e usar o conhecimento, e não a quantidade. Pois se a quantidade de conhecimento fosse regra para o sucesso, os homens mais ricos do mundo seriam os Doutores e PhD’s , aliás você conhece algum PhD bilionário?

    Parabéns por compartilhar este material, certamente você tem lugar garantido no mercado.

    Estou elaborando um projeto de cabeamento estruturado e certificação de rede para uma grande multinacional, e utilizarei o seu modelo como base para o As-Built deste projeto.

    Saudações,

    Mateus Belluzzo

    0

    0

Deixe uma resposta