«

»

fev 18 2009

[CCNA/CCNP] Desafio 1 da Semana 3 – Fevereiro de 2009

Estavam sentindo falta de um desafio, não estavam? Pois segue mais um, para fazer vocês pensarem um pouco… este, sobre EIGRP, um dos protocolos de roteamento cobrado no exame 640-802 (CCNA), e também no exame BSCI (CCNP). Procurem compreender a questão, pesquisem e, somente então, respondam!

Bom trabalho!

Dois roteadores foram configurados com EIGRP conforme ilustra a figura abaixo:

figura.jpg

O router CK1 e o router CK2 não estão formando adjacência EIGRP. Quais as possíveis razões para este problema?

A) A configuração de bandwidth nas interfaces de ambos os routers não bate

B) Os routers pertencem à sistemas autônomos distintos

C) EIGRP não forma adjacências usando endereços IP secundários

D) O parâmetro “network” da config EIGRP não bate com a subrede configurada na interface Ethernet

E) Auto-sumarização não foi corretamente configurada no router CK1



Comente usando o Facebook!
0
0

94 comentários

Pular para o formulário de comentário

  1. jab

    Letra C, até onde sei, o EIGRP não forma adjacencias com IP Secundário! Tô certo?

    0

    0
  2. gustkiller

    esta foi facil, letra B.

    sistemas autonomos distintos, um esta com as 100 e outro 200, nunca fechariam adjacencia.

    0

    0
  3. jab

    Verdade.. Eu juro que lí 100 em vez de 200. É a pressa! Sorry 🙂

    0

    0
  4. Guilherme Montoanelli

    B) Os routers pertencem à sistemas autônomos distintos

    0

    0
  5. Cleber Monin

    Olhando pela topologia eu diria que seria o endereçamento IP dos roteadores(209.224.111.41/30).
    But…. Os ASs são de fato o maior problema.
    B) Os routers pertencem à sistemas autônomos distintos

    0

    0
  6. marciomoura

    Oi, Marco pelo que parece os sistemas autônomos estão configurados diferentes ai não funciona. (100 e 200).
    A resposta certa é a letra B.

    0

    0
  7. alfredo_cpd

    Letra C, pois cada roteador pertence a um sistema autônomo diferente. Desta forma não conseguem formar adjacência.

    0

    0
  8. Fabricio Neves

    Letra B
    Configurações EIGRP com As distintos não formam adjacência.

    0

    0
  9. hespanha

    Letra B, AS diferentes entre os routers.

    0

    0
  10. gustkiller

    Como eu mudo o avatar aqui? rsrsrsrs

    0

    0
  11. Roberto Domingos

    Vale Observar que o IP que está fechando o Link é SECUNDÁRIO e na teoria só vai ficar ativo quando o primário cair , quando isso acontecer eu diria que ai sim nao fecharia a Adjacencia Pelos AS Distintos.

    logo Eu Responderia a C pois está na cara que é uma pegadinha.

    0

    0
  12. Bruno Rangel

    A resposta correta é a letra B, Os routers estão rodando em AS distinto.

    Ps:Roberto Domingos não entendi o seu coment, porque mesmo estando em AS distintos, formaria adjacencias com a queda do 1 Ip ???

    0

    0
  13. Roberto Domingos

    nao pq estão em AS distintos. o que eu quiz dizer eh que o Link Secundário está fora ate o primário cair… quando isso acontecer o Secundário Vai Assumir e tentar formar adjacência Sem Sucesso por causa dos AS Distintos

    Espero ter explicado bem =D

    0

    0
  14. Minu

    Acho que porque os sistemas autonomos são diferentes né? um tá como 100 e outro como 200. acho que letra B

    0

    0
  15. Minu

    Roberto, no site da Cisco eles dáo mais definições para a secondary:

    Assign Multiple IP Addresses to Network Interfaces

    The software supports multiple IP addresses per interface. You can specify an unlimited number of secondary addresses. Secondary IP addresses can be used in a variety of situations. The following are the most common applications:

    •There might not be enough host addresses for a particular network segment. For example, suppose your subnetting allows up to 254 hosts per logical subnet, but on one physical subnet you must have 300 host addresses. Using secondary IP addresses on the routers or access servers allows you to have two logical subnets using one physical subnet.

    •Many older networks were built using Level 2 bridges, and were not subnetted. The judicious use of secondary addresses can aid in the transition to a subnetted, router-based network. Routers on an older, bridged segment can easily be made aware that many subnets are on that segment.

    •Two subnets of a single network might otherwise be separated by another network. You can create a single network from subnets that are physically separated by another network by using a secondary address. In these instances, the first network is extended, or layered on top of the second network. Note that a subnet cannot appear on more than one active interface of the router at a time.

    Acredito que da forma que esta, possa sim criar adjacencias com o ip secundario.. como teste vou fazer um lab para tirar esta duvida.. 😉

    0

    0
  16. juliano.camargo

    Roberto,

    LETRAAAAAAAAA BBBBBBBBBBBBB!!!!
    A adjacencia não seria formada nem pelo primary e nem pelo secondary IP, devido o AS serem distinto para ambos.

    Abraço à todos…

    JLN

    0

    0
  17. André Ortega

    Resp:B – Autonomous Systems diferentes.
    http://www.brainwork.com.br/blog

    0

    0
  18. Richard

    Letra – C

    fonte: http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a008012dac4.shtml

    Acredito que mesmo com AS diferentes o eigrp forma adjacencia, mas coloca em sua tabela de roteamento com uma rota externa (D EX).

    0

    0
  19. Roberto Domingos

    Minu Eu Fiz o Lab Aqui mas Vou Postar Meu Resultado Depois de Você Blz?

    0

    0
  20. Minu

    Primeiro teste:
    Usando IPs primários nas interfaces e na mesma AS, formou-se a adjacência:

    Router#sh ip eigrp nei
    IP-EIGRP neighbors for process 200
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    0 209.224.111.41 Fa0/0 10 00:02:12 4 200 0 10

    Segundo teste:

    Agora com o IP na secondary na interface.

    Router#sh ip eigrp nei
    IP-EIGRP neighbors for process 200

    Não mostra mesmo a adjacência.

    Terceiro teste:

    Em AS diferentes e Ips na primaria das interfaces, também não forma adjacência:

    Router#sh ip eigrp nei
    IP-EIGRP neighbors for process 100

    Bom, taí o teste, tirei a dúvida.

    mas estranho, na documentação não diz que o ip secondary seria uma espécie de redundância do primário. Como o secondary funciona no final das contas?

    Abraçosss
    Paulo Sousa.

    0

    0
  21. Cleber Monin

    IP Secundario não e redundancia, e sim uma configuração virtual em uma interface fisica
    No caso se vc tiver duas interfaces fisicas, poderia ser um redundancia.

    0

    0
  22. Minu

    Bom foi o que entendi da explicação do Roberto:
    “o que eu quiz dizer eh que o Link Secundário está fora ate o primário cair… quando isso acontecer o Secundário Vai Assumir e tentar formar adjacência Sem Sucesso por causa dos AS Distintos”

    0

    0
  23. Tiago Frigério

    acredito ser alternativa B… os router nao estao formando adjacencias pois estao em AS diferentes…
    abc…

    0

    0
  24. lyon

    Bom vamos lá!

    Fiz essa configuração no dynamips e executei alguns testes:

    O ping do ck1 p/ ck2 não foi bem sucedido
    O ping do ck2 p/ o ck1 foi bem sucedido

    Os routers não fecharam adjacência!

    Resolvi mudar o AS do ck2 para 200

    O ck1 apresentou adjacência com ck2
    O ck2 não apresentou e mostrava o erro: 192.168.1.17 not on common subnet…

    Executei o debug eigrp packets nos dois routers e mostrou que envia o hello mas não recebe nada.

    Acredito que seja a resposta B pois com AS iguais o ck1 apresentou adjacência.

    Roberto, vc disse que o link secundario fica fora até o primeiro cair, como assim o primeiro cair? ou dar um no ip add …. pra derrubar? não entendi!

    Gostaria de saber tbem para que se usa o secundario?

    Esperarei outras respostas pra ver se entendo… rss

    abraços

    0

    0
  25. luciano t

    Estão em sistemas autonomos distintos, pelo menos foi o que aprendi no netacademy preparado para a prova 640-801.
    portanto é a letra B.

    0

    0
  26. Roberto Domingos

    esse conceito de Primario e Secundario eu estou usando com base no failover do ASA… só que acabei trocando as bolas e confundindo com o IPSLA que faz que o ASA tenha redundancia para a internet (caso o IP Primário Caia [Indisponibilidade da Operadora, ect…] o segundo link seria o Ativo. O Problema é que no ASA isso é utilizado com 2 Interfaces Físicas e não tem absolutamente nada a ver com o nosso problema em questão.

    0

    0
  27. Roberto Domingos

    PS: O Failover do ASA é só o Alta Disponibilidade (Se Um Equipamento der problema o outro assume)

    0

    0
  28. genildof

    Letra “B”. Estar no mesmo AS é imprescindível.

    0

    0
  29. Herbert

    Letra B porque é necessário que os routers estejam no mesmo sistema autônomo para formar adjacência.

    Não sei como explicar sobre as demais respostas do desafio, já que algumas delas me levantaram algumas dúvidas…

    0

    0
  30. Flávio

    Letra B, concerteza, AS distintinto

    0

    0
  31. cassiomarcel

    B) Os routers pertencem à sistemas autônomos distintos

    huhuh

    0

    0
  32. Roberto Domingos

    Nos Meus Testes Também Não Fecharam Adjacência com O Ip Secundário e Em AS Idênticos.

    e no router que estava com apenas o IP primário fica aparecendo a seguinte Mensagem:
    “00:21:25: IP-EIGRP: Neighbor 10.0.0.1 not on common subnet for Serial1/1 (172.16.1.1 255.255.255.252)
    R1-TSC(config)#”

    nesse mesmo router quando eu dou um “show ip eigrp neighbors” não aparece nenhum processo, já no outro sim:

    Eu configurei também uma rede qualquer no router que está com o IP Secundário e essa rede apenas apareceu na tabela de roteamento do outro quando eu removi o ip secundário.

    Minha Conclusão:
    Com base nos Testes do Minu, Meu e do Lyon a requisição quando sai do router que está com o IP primário apenas, consegue chegar ao seu destino, porém quando é o oposto o router Descarta o pacote pois o pacote terá como origem o IP da Interface Primária, ou seja, não chegará ao seu destino pois não estão na mesma Sub-Rede.

    para o Router que está com o IP Secundário alcançar o outro, faça um ping extendido que vc terá o reply

    PS: Todos os Testes que fiz foram com os mesmos AS para os dois lados não fiz a troca pois se como estão identicos não funcionaram se eu mudar o Numero do AS ai eh que não vao funcionar mesmo.

    Abs.

    0

    0
  33. Bruno Rangel

    Minu
    Realizei tambem o teste no dynamips e os resultados encontrados foram os mesmos que os seus:

    Depois realizei um teste colocando os dois routers no memo AS:

    Router100#show ip eigrp neig
    IP-EIGRP neighbors for process 100

    Router200#show ip eigr neig
    IP-EIGRP neighbors for process 100
    H Address Interface Hold Uptime SRTT RTO Q Seq Type
    (sec) (ms) Cnt Num
    0 209.224.111.42 Se1/0 13 00:00:01 1 2000 1 0

    0

    0
  34. Tiago Morais

    Como no enunciado tá explicito “Quais as possíveis razões para este problema?”

    Vou responder mais de uma.

    Vou de B,C,D e E.

    Abraço!!

    0

    0
  35. juliano.camargo

    Galera….uma curiosidade foi despertada nesse momento….rs

    Pesquisei o assunto abordado no POST, e achei a seguinte explicação…
    Segue,

    Does EIGRP support secondary addresses?

    A. EIGRP does support secondary addresses. Since EIGRP always sources data packets from the primary address, Cisco recommends that you configure all routers on a particular subnet with primary addresses that belong to the same subnet. Routers do not form EIGRP neighbors over secondary networks. Therefore, if all of the primary IP addresses of routers do not agree, problems can arise with neighbor adjacencies.

    Neste caso optaria pela resposta B -> Não formariam adjacencia por estarem em sistemas autonomos distintos e pela opção C -> O EIGRP não forma adjacencia com IP Secundários, até pq os endereços Primários precisam estar na mesma sub-rede.

    Valew galera!!!

    Abs

    0

    0
  36. Richard

    Q. Does EIGRP support secondary addresses?

    A. EIGRP does support secondary addresses. Since EIGRP always sources data packets from the primary address, Cisco recommends that you configure all routers on a particular subnet with primary addresses that belong to the same subnet. Routers do not form EIGRP neighbors over secondary networks. Therefore, if all of the primary IP addresses of routers do not agree, problems can arise with neighbor adjacencies.

    fonte: cisco.com

    Letra – C, está claro!

    0

    0
  37. juliano.camargo

    Isso aí Richard, foi onde eu pequisei, olha meu POST acima…rs!!!
    Porém, permanesso com as duas respostas, B e C, foi com AS distintos o EIGRP não forma adjacencia e com IP secondary tbm não, isso é fato!

    fonte: cisco.com

    Abraços manoOOow.

    0

    0
  38. lyon

    Lendo o post do tiago, em especial onde diz, “Quais as possiveis razões…”
    Vou de B e C

    A – bandwidth na fast não faz perder o link, o eigrp irá usar apenas para o calculo da métrica.
    D – os networks estão certos.
    E – auto-sumarização não influencia nas adjacências.

    acho que é isso!

    0

    0
  39. gustkiller

    Ip secundario na verdade é apenas um alias, resumindo, se vc tem um roteador de core com que roteia diversas redes, e vai usar apenas um roteador, vc define o diversos ips na mesma interface para ser gateway dos clientes decada uma destas redes/ subredes, exemplo vc tem uma rede 192.168.0.0/24 e outra rede 192.168.1.0/24 entao vc seta os 2 ips, na interface do roteador e com isto os clientes estando no mesmo barramento de rede vão utilizar cada um o seu respectivo ip de gateway ( um secundario ou o primario, ) aqui na rede que trabalho temos mais de 200 ips em uma mesma interface de roteador.

    0

    0
  40. Richard

    Ahhh, são 2 respostas, então é isso mesmo B e C.

    0

    0
  41. juliano.camargo

    Bom, pelo menos no meu conceito creio que seja essas duas respostas…
    Fiz um LAB no Dynamips e a adjacencia não foi formada entre ASs diferentes e quando alterei o AS deixando de ambos iguais o neighbor adjacency ou peer foi formado, e o fato da adjacencia não ser formada por IP secondary, fico com as duas respostas.
    Obs: Devemos nos atentar com relação as sub-redes mostradas na topologia, q no caso o endereço IP secondary de CK1 esta na mesma sub-rede do endereço IP primario do Router CK2, não formando a adjacencia entre eles.

    Como a Cisco recomenda que endereços IP primários devem estar na mesma sub-rede, isso já vale como resposta.

    Resposta –> B e C

    Abraço à todos!!!

    Juliano Camargo
    2S

    0

    0
  42. Tiago Morais

    Pessoal, tenho até medo de postar e falar asneira.
    Mas vamos lá como estou dúvida vou perguntar.

    Minhas respostas foram B,C,D e E pela seguinte analise.

    B – Os routers nao pertencem ao mesmo sistema autônomo

    C – EIGRP não forma adjacências usando endereços IP secundários

    Agora a parte que estou com dúvida:

    D – o endereçamento usado nas interfaces dos roteadores 209.224.111.41 e 42 / 30´é uma sub-rede, devido a isso o comando network não deveria ser o seguinte network 209.224.111.40 0.0.0.3 ?????

    E – E como EIGRP por padrão nao suporta redes descontíguas o comando no auto-summary não deveria estar configurado nos dois roteadores ?????

    Caso tenha alguém disposto a tirar minhas dúvidas agradeço desde já.

    Abraço!!!

    0

    0
  43. Herbert

    Tiago Morais, acredito que o protocolo EIGRP não utiliza wildcards para ativar a divulgação de rotas, fazendo com que a divulgação ocorra de forma correta.

    Acredito também que a falta do comando “no auto-sumary” causaria um problema no roteamento dos pacotes, mas não impediria a formação de adjacências EIGRP. Este somado ao comando “ip classless” permite os roteadores que utilizem EIGRP suportarem redes descontíguas.

    0

    0
  44. juliano.camargo

    Basta ler o tópico da cisco, onde para formarem adjacencia é necessário q os endereços primários estejam na mesma subrede…
    Segue o link
    http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a008012dac4.shtml

    0

    0
  45. Leandro

    Acredito ser as opções B C D E

    0

    0
  46. wagner

    Bom vamos lá…

    A – As configurações de bandwith realmente nao batem, mas isso nao influencia no EIGRP nao formar adjacencia.

    B – Os AS esão configurados errados. Em um AS 100 em outro AS 200 sendo assim, impossivel formar adjacencia, pois só é formado por AS iguais.

    C – Nao sei responder, fiquei na dúvida a respeito.

    D – Na configuraçao do EIGRP, nao é informado máscara no comando “network”, portanto errada.

    E – Em um o auto-summary está habilitado em outro não. Nao sei se isso impossiblitaria o EIGRP de formar adjacencia mas poderia sim dar um loop caso a rede fosse descontigua, mas arriscaria esta também.

    Respostas corretas: B e E.

    Bom pelo menos eu acho que é isso!
    Abraços!

    0

    0
  47. Herbert

    Esqueçam o meu comentário anterior.

    0

    0
  48. juliano.camargo

    Wagner,

    Com relação a alternativa C, pode ter certeza de que é fato, o EIGRP não forma adjacencia com edereços IP secundários (secondary IP).
    Caso tenha duvida sobre isso, leia a materia abaixo dretamente da fonte cisco.com;

    Does EIGRP support secondary addresses?

    A. EIGRP does support secondary addresses. Since EIGRP always sources data packets from the primary address, Cisco recommends that you configure all routers on a particular subnet with primary addresses that belong to the same subnet. Routers do not form EIGRP neighbors over secondary networks. Therefore, if all of the primary IP addresses of routers do not agree, problems can arise with neighbor adjacencies.

    http://www.cisco.com/en/US/tech/tk365/technologies_q_and_a_item09186a008012dac4.shtml

    E a letra B tbm está correta, o EIGRP não forma adjacencia com ASs distintos.

    Abraços

    0

    0
  49. Leandro Nogueira

    Eu iria de letra B, mais olhando os comentários a letra C tb esta correta !

    0

    0
  50. Cleudson

    Estando em AS diferentes não haverá adjacência. B.

    0

    0
  51. hatus

    Quando olhei a questão ja fui falando lentra B, porem lento os comentarios conheci sobre ip secundario e letra C esta correta também…

    Então vou de B e C.

    0

    0
  52. wagner

    Juliano Camargo,

    Muito Obrigado cara, nao tinha essa informaçao, muito bom saber. Entao, letra C também!

    Respostas. : B, C e E….

    0

    0
  53. Fabio Santos

    A letra B definitivamente deve ser escolhida. No entanto, a questão do secundary ip address precisa ser considerada. Para o CK2 a rede 200.224.111.40 é a primária, então em tese, o EIGRP nesta máquina formaria vizinhaça com o CK1 se estivessem no mesmo AS.

    0

    0
  54. Richard

    Tiago,

    Letra D está ERRADA. O Comando network no EIGRP pode ser usado do modo que está no exemplo, quando nao é informada a wildcard-network-mask ele pega a default (no caso 0.0.0.255) e aplica as configuraçoes do EIGRP a todas as interfaces nesse bloco de classe C.

    A letra E tambem está ERRADA. Porque só há 1 rede, nao há necessidade de aplicar o comando no auto-summary, a não ser que existisse blocos descontiguos subdivididos pelas interfaces.

    O correto sao as questoes B e C.

    0

    0
  55. Richard

    Fabio para que haja vizinhanca ambos tem que se reconhecer como vizinhos, na verdade acontece no exato momento que um vizinho recebe um hello de outro contendo a si proprio como vizinho.

    0

    0
  56. leonardo_jupesc

    Eu vou de letra B AS distintos não formam adjacências…

    0

    0
  57. Henrique de Almeida Ribeiro

    Também fico com duas opções B e C, pelos artigos que li sobre roteamento EIGRP essas duas alternativas são na minha opnião a resposta correta.

    0

    0
  58. Rodrigo Falcão

    A galera não perde tempo, rsrsr!!

    Bom, como a grande maioria, eu iria apenas de letra B de cara, mas depois das observações feitas sobre a questão de formar ou não adjacências com IPs secundários, eu vou de letra B e C.

    Abs!

    0

    0
  59. cfeitosa

    Eu creio que o maior problema é o AS que se encontra distinto um do outro letra B

    0

    0
  60. brunoff

    Com certeza a letra B.

    0

    0
  61. juliano.camargo

    Bom vamos láh….
    B- De fato que adjacencia não será formada por ASs disistintos, até pq para ASs distintos necessitariamos de um protocolo EGP (no caso BGP) para fazer com que ambos ASs se comuniquem.

    C- O EIGRP não forma adjacencias com endereços IPs secundários. O endereço IP primário da interface E0/0 de CK1 192.168.17.0 /30 não está na mesma sub-rede do Router CK2 (209.224.11.42/30).

    Por mais que o endereço secundário da interface E0/0 do Router CK1 esteja na mesma sub-rede e responder á pings (pacotes ICMPs), isso não quer dizer que eles possam formar a vizinhança, sendo assim ambos não formarão adjacencia devido um ser IP primary e outro IP secondary.

    Caso eu esteja equivocado em algum ponto, por favor me corrijam…rs

    Abs.

    Juliano Camargo

    0

    0
  62. hespanha

    Opções B e C.
    AS distintos nao forma adjacencia e o EIGRP não forma adjacencias com IPS secundários.

    0

    0
  63. kassyoalves

    Os sistemas autonômos sào diferentes. Letra B.

    0

    0
  64. ricardobarbosams

    Letra B
    Para formar adjacencias os routers tem que estar no mesmo sistema autônomos, nao em ASs distintos.

    0

    0
  65. Israel Carlos

    Teste Realizado no Dynamips

    Configurções propostas

    Certkiller 1

    interface FastEthernet0/0
    bandwidth 10000
    ip address 209.224.111.41 255.255.255.252 secondary
    ip address 192.168.1.17 255.255.255.252
    duplex auto
    speed auto
    !
    router eigrp 200
    network 192.168.1.0
    network 209.224.111.0
    no auto-summary

    CertKiller2

    interface FastEthernet0/0
    bandwidth 1000
    ip address 209.224.111.42 255.255.255.252
    duplex auto
    speed auto
    !
    router eigrp 100
    network 209.224.111.0
    no auto-summary

    Apos realizar as configurações apliquei o comando show ip eigrp nei, veja o que foi mostrado:

    certKiller1#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200

    certKiller2#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 100

    Logo, não forma adjacencia em AS’s distintas….continuando os testes, colocando os dois roteadores na mesma AS não formou adjacencia do lado de Certkiller2 por causa do IP secundário configurado em certiKiller 1, mas formou do lado de CertKiller1, só que fica oscilando. Proseguindo……

    Saída do comando sh ip eigrp neighbors :

    certKiller1#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    0 209.224.111.42 Fa0/0 12 00:00:43 1 5000 1 0

    CertKiller2#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200

    Ainda sim fica alarmando nos dois roteadores, olha só os logs:

    certKiller1#
    *Mar 1 03:35:38.551: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 200: Neighbor 209.224.111.42 (FastEthernet0/0) is down: retry limit exceeded
    *Mar 1 03:35:42.275: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 200: Neighbor 209.224.111.42 (FastEthernet0/0) is up: new adjacency
    *Mar 1 03:37:01.791: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 200: Neighbor 209.224.111.42 (FastEthernet0/0) is down: retry limit exceeded

    CertKiller2#
    *Mar 1 03:36:40.563: IP-EIGRP(Default-IP-Routing-Table:200): Neighbor 192.168.1.17 not on common subnet for FastEthernet0/0
    *Mar 1 03:36:55.107: IP-EIGRP(Default-IP-Routing-Table:200): Neighbor 192.168.1.17 not on common subnet for FastEthernet0/0
    *Mar 1 03:37:09.499: IP-EIGRP(Default-IP-Routing-Table:200): Neighbor 192.168.1.17 not on common subnet for FastEthernet0/0

    e continuando os teste, coloquei ip secundário do lado de CertKiller2 e a adjacencia foi formada pelo ip principal, veja a saída do comando:

    CertKiller1#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    1 192.168.1.18 Fa0/0 13 00:00:23 1 5000 0 4

    CertKiller2#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    0 192.168.1.17 Fa0/0 13 00:00:10 1 3000 0 19

    Logo as respostas corretas são, B e C

    abs

    0

    0
  66. Fabio Luiz Pagoti

    B
    ip secundário nem é questao para CCNA

    0

    0
  67. Israel Carlos

    ” Cobrado no exame 640-802 (CCNA), e também no exame BSCI (CCNP). “

    0

    0
  68. denfv

    A , B , C

    0

    0
  69. wroliveira

    correta é :

    Os routers pertencem à sistemas autônomos distintos – letra B.

    Routers configurados com o protocolo de roteamento EIGRP não trocam informações de roteamento e não formam adjancencias quando estão configurados com sistema autonomo diferente.

    0

    0
  70. diogocampregher

    A Cisco e suas pegadinhas, prestem atenção na pergunta pessoal: . Quais as possíveis razões para este problema? ( plural )

    Analizando a questão sabemos que as op~çoes B e C estão corretas…..posso estar enganado, mas creio que seja isso.

    0

    0
  71. teo_271

    Letra B galera! Sistemas autonomos diferentes.

    0

    0
  72. Hamilton Rocha

    letra ” B ” ( AS diferentes ) e letra ” C ” porque o EIGRP não forma adjacências com ip secundários .

    0

    0
  73. juliano.camargo

    Israel Silva,

    Mandou bem cara, fiz os mesmos testes porém não os postei conforme vc fez, mas de uma olhada no meu coments m pouco mais pra cima …Pesquisei, revisei, fiz testes, enfim, minha conclusão é a mesma que a sua. Creio eu que estamos correto, pq q pelo que aprendi e no que já implementei essas são as conclusões.

    Um grande abraço à todos.

    Juliano Camargo

    0

    0
  74. Hamilton Rocha

    Letra ” B ” AS diferentes e Letra ” C ” o protocolo EIGRP não forma adjacências dcom IPs secundários.

    0

    0
  75. Alison

    Pra mim a “B” é certeza (Sistemas autônomos diferentes).
    Mas tô na dúvida se é a “C” tb…

    Esperar pra ver a resposta.

    Abs

    0

    0
  76. Giovani

    Quais são as possíveis?

    B e talvez C (isso precisaria testar).

    0

    0
  77. juliano.camargo

    Táh faltando o Marco postar a resposta!!!
    Eu acredito q seja a B e C, onde jah postei umas 4x….UahuahauhUhauh

    0

    0
  78. Israel Carlos

    sÓ fAlTa O aLvArÁ dO MaRcO………

    0

    0
  79. Fernando Avelino

    Cheguei tarde, mas minha opinião é B, vi ligo de cara.

    0

    0
  80. Carlos Almeida

    Caramba!!!!!! O Post Bombou!!!!

    Acredito que a razão do problema é porque os routers são de sistemas autônomos diferentes!!!
    Então: letra B
    Flw!

    0

    0
  81. denfv

    Aqui vai uma explicação de minha resposta:

    A) A configuração de bandwidth nas interfaces de ambos os routers não bate
    -Este tipo não forma adjacência e torna a rede inconsitente como mostra o teste a seguir

    resposta apos configurar o bandwidth :

    interface FastEthernet0/1
    bandwidth 1000
    ip address 192.168.0.1 255.255.0.0
    duplex auto
    speed auto

    %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.0.2 (FastEthernet0/1) is up: new adjacency
    %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.0.2 (FastEthernet0/1) is down: retry limit exceeded
    %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.0.2 (FastEthernet0/1) is up: new adjacency
    %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.0.2 (FastEthernet0/1) is down: retry limit exceeded
    %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.0.2 (FastEthernet0/1) is up: new adjacency
    %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.0.2 (FastEthernet0/1) is down: retry limit exceeded
    %DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.0.2 (FastEthernet0/1) is up: new adjacency
    Router#

    “o router não consegue acompanhar o outro” , o outro roteador não apresenta problemas

    B) Os routers pertencem à sistemas autônomos distintos
    – ESTA RESPOSTA ESTA CERTA POIS ESTE É O PRINCIPAL CRITERIO A SER CONFIGURADO

    C) EIGRP não forma adjacências usando endereços IP secundários
    – COMO JA FOI DITO O EIGRP NÃO FORMA ADJACENCIA COM IP SECUNDARIOS

    D) O parâmetro “network” da config EIGRP não bate com a subrede configurada na interface Ethernet –
    -Mesmo se fosse verdade o protocolo iria anunciar as rotas normalmente , porem descartaria o pacote ao recebe-lo ( eu acho Oo)

    E) Auto-sumarização não foi corretamente configurada no router CK1
    – A questão é sobre adjacencia não sobre sumarização

    Logo alternativas A , B , C …

    Ja havia respondido antes mas aki esta a resposta completa , ja suspeitava da resposta A mas só tive certeza após os testes no packettracer

    0

    0
  82. lyon

    Ola pessoal!
    Com tantas respostas, resolvi fazer mais alguns testes.

    1º teste – configuração para fechar adjacência. Usei AS 200 ip endereço 209.224.111.40/30 e sem o bandwidth, as demais configurações são a mesma da questão.
    CK1
    interface FastEthernet0/0
    ip address 209.224.111.41 255.255.255.252
    duplex auto
    speed auto
    !
    router eigrp 200
    network 209.224.111.0
    auto-summary
    no eigrp log-neighbor-changes
    !
    CK2
    interface FastEthernet0/0
    ip address 209.224.111.42 255.255.255.252
    duplex auto
    speed auto
    !
    router eigrp 200
    network 209.224.111.0
    no auto-summary
    no eigrp log-neighbor-changes
    !
    CK1#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200
    H Address Interface Hold Uptime SRTT RTO Q Seq Type
    (sec) (ms) Cnt Num
    0 209.224.111.42 Fa0/0 13 00:03:11 1 3000 0 2
    CK1#
    CK2#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200
    H Address Interface Hold Uptime SRTT RTO Q Seq Type
    (sec) (ms) Cnt Num
    0 209.224.111.41 Fa0/0 12 00:04:03 1 4500 0 2
    CK2#

    Podemos ver que a adjacência esta OK, aqui podemos eliminar a alternativa D e E.

    2º teste – inserido bandwidth
    CK1 – 10000
    CK2 – 1000
    CK1#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200
    H Address Interface Hold Uptime SRTT RTO Q Seq Type
    (sec) (ms) Cnt Num
    0 209.224.111.42 Fa0/0 11 00:07:31 36 216 0 3
    CK1#
    CK2#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200
    H Address Interface Hold Uptime SRTT RTO Q Seq Type
    (sec) (ms) Cnt Num
    0 209.224.111.41 Fa0/0 10 00:07:43 32 200 0 3
    CK2#

    Chego a conclusão que o bandwidth não influencia na adjacência, apenas influenciará no tráfego, então podemos eliminar a alternativa A

    3º teste – inserindo o ip 192.168.1.17 e o 209.224.111.41 secundary na f0/0 do CK1
    CK1#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200
    H Address Interface Hold Uptime SRTT RTO Q Seq Type
    (sec) (ms) Cnt Num
    0 209.224.111.42 Fa0/0 11 00:00:13 1 5000 1 0
    CK1#
    CK2#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200
    CK2#
    CK2#
    00:35:26: IP-EIGRP: Neighbor 192.168.1.17 not on common subnet for FastEthernet0
    /0 (209.224.111.42 255.255.255.252)
    00:35:39: IP-EIGRP: Neighbor 192.168.1.17 not on common subnet for FastEthernet0
    /0 (209.224.111.42 255.255.255.252)

    CK1#ping 209.224.111.42

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 209.224.111.42, timeout is 2 seconds:
    …..
    Success rate is 0 percent (0/5)
    CK1#
    CK2#ping 209.224.111.41

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 209.224.111.41, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/56/68 ms
    CK2#

    Aqui no negocio complica… rss
    O CK1 fechou adjacência com CK2, mas não pinga para o endereço do CK2.
    O CK2 não fechou adjacência com CK1 e pinga para o endereço do CK1.
    Essa questão não sei explicar, vamos esperar que saiba para dar uma luz… rsss
    Como os dois router não fecharam adjacência, podemos concluir que a alternativa C esta correta.

    4º teste – mudando o AS do router CK2 para 100

    CK1#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 200
    CK1#
    CK2#sh ip eigrp neighbors
    IP-EIGRP neighbors for process 100
    CK2#

    Com AS diferentes nenhum router fechou adjacência, então a alternativa B também esta correta.

    Minhas respotas são B e C

    Não coloquei o resultado do sh ip route pois as redes são diretamente conectadas.
    acho que é isso
    abraços

    0

    0
  83. clediafe

    Eu vou optar pela letra B

    0

    0
  84. Daniel

    Para dois roteadores rodando eigrp formarem adjascência eles tem que fazer parte do mesmo sistema autônomo, e possuirem os parâmetros usados para cálculo de métricas idênticos(k values)(página 281 do livro do marco 4.1)
    No nosso caso eles estão em AS diferentes e possuem o valor de bandwidth diferente(K1). Por esses motivos não irão formar adjascência. Vou de letras A e B.
    Confesso que lendo os posts fiquei na dúvida em colocar também a letra C. Mas pelo que sei de endereços secundários, o primário não precisa estar fora para o secondary entrar em funcionamento. Teriamos conectividade para os dois endereços. Agora tenho a dúvida se o EIGRP forma essa adjascência com ips secundários.
    Obs: Plena segunda-feira de carnaval e eu estudando eigrp, quem diria…..valeu galera…..
    Abraços.

    0

    0
  85. lyon

    Daniel, o bandwidth é usado para calcular a métrica apenas, por exemplo:
    Se essa conexão fosse pelas serias, e o CK1 tivesse configurado o cloke rate como 100 e no CK2 o bandwidth tivesse com 56, eles iriam fechar adjacência, mas o eigrp iria usar o 56 para fazer o calculo da metrica no CK2.

    Acho que é isso.

    0

    0
  86. Wilton Paulo

    Pra mim, é letra B.

    Mas será que é de multipla escolha ???

    0

    0
  87. Marco Filippetti

    Pessoal, participação ESMAGADORA!!! Recorde total de participações aqui no blog, fiquei EMBASBACADO!!! rsrsrsrs!

    Muito obrigado pela participação de todos. Gostei muito de ver alguns colocando conceitos à prova no Dynamips ou no Packet Tracer e analisando os resultados! Esta é, sem dúvida, uma das melhores formas de se aprender. Alguns acertaram, outros acertaram apenas uma parte e, claro, outros erraram (faz parte!)! Havia mais de uma resposta correta, e eram as alternativas B e C. A “B” era mais ou menos óbvia, e se vc não acertou, este assunto merece ser melhor estudado! Routers em ASs distintos não formam adjancência no EIGRP (diferentemente do BGP, por exemplo, que pode formar adjacências com routers em ASs distintos).

    EIGRP tb não forma adjancências com IPs secundários, por um motivo bastante simples… o “HELLO” do EIGRP é enviado sempre com o IP primário da interface. Desta forma, o router vizinho receberá um HELLO com um IP de outra rede (no exemplo) e não o reconhecerá como uma adjacência EIGRP. OK?

    Um abs e até o próximo desafio!

    Marco.

    0

    0
  88. juliano.camargo

    E ai Israel…ACERTAMOS…Hahahahahah….
    Até em questão do BGP que havia comentado no post acima está certo!!!
    Valew galera pela iteração de todos, e mais uma vez valew MARCO!!!

    Yes, we Can!

    Rsrrsrs

    0

    0
  89. lyon

    Marco, gostaria de saber para que serve o ip secundario? e pq mesmo com o ip secundario em um router fechou adjacência mas não pingava?
    Fiz um teste desse e coloquei no post 82.

    0

    0
  90. Marco Filippetti

    Lyon, excelentes testes! Mas a adjacência não foi fechada ;-). O fato de vc ver a msg “IP-EIGRP: Neighbor 192.168.1.17 not on common subnet for FastEthernet0” é a prova cabal que não houve acordo na negociação de adjacência, e ela não foi estabelecida. Vc consegue pingar o IP secundário se usar o “source” no PING. Tente o comando “ping 209.224.111.42 source 209.224.111.41” e a coisa deve funcionar. IP secondário é uma forma de configurar mais de um endereço IP em uma mesma interface Ethernet. Simples assim… 😉

    Abs!

    0

    0
  91. lyon

    obrigado pela explicação Marco.

    abraços

    0

    0
  92. Israel Carlos

    Vlw juliano.camargo, até a próxima.

    Obrigado Marco.

    0

    0
  93. rafael rachid ferreira

    eu mesmo erei mais costei estol loco pelo prosimo desafio abraso a todos

    0

    0
  94. Edson

    Muito bom! Esse exercício é show!
    Muito legal ver os comentários e o desenrolar do exercício 🙂

    0

    0

Deixe uma resposta