«

»

ago 24 2009

[CCNA] Desafio 1 da Semana 5 – Agosto de 2009

Olá pessoal, estou gozando de umas merecidas férias e estarei um pouco fora do ar pelas próximas 2 semanas! Mas deixo aqui um desafio interessante para vocês, valendo um prêmio para a melhor resposta! 😉

Vamos lá!

Observe o diagrama abaixo:

25-08.jpg

R1# sh ip rout
  C 192.168.1.0/24 is directly connected to F0/1.1
  C 192.168.2.0/24 is directly connected to F0/1.2

O administrador da rede ilustrada criou uma nova VLAN no switch S1 e os hosts P4SC e P4SD foram associados a esta nova VLAN. As interfaces F0/13 e F0/14 do switch S1 foram, configuradas apropriadamente para fazerem pare da nova VLAN criada, entretanto, mesmo após concluída a configuração, o host P4SA consegue comunicar-se com o host P4SB, mas não consegue comunicar-se com os hosts P4SC ou P4SD. Baseado no diagrama apresentado e nas saídas apresentadas, O que, provavelmente, estaria faltando configurar (e em qual ou quais elementos apresentados) para resolver este problema? A melhor resposta vai levar um livro (depois digo qual) de prêmio.

Resultado no próximo Domingo.

Um abraço,

Marco.

0
0

53 comentários

Pular para o formulário de comentário

  1. ADISSON AIRES

    R2?

    0

    0
  2. Diogo Mendes

    Considerando que na verdade a saida eh do router R1, é necessário configurar uma nova subinterface no router com o endereço da da rede (192.168.3.0/24) e tag da nova vlan e configurar o gw das maquinas com o endereço IP que o router possuir nas respectivas subinterfaces, além de taggear essa nova vlan na porta do switch onde o router ta conectado.

    Abraços

    0

    0
  3. Luiz Fernando

    O que falta ser configurado é o roteador para fazer o roteamento inter-vlan e a interface que liga o roteador ao switch como trunk.
    O que deve ser configurado no roteador são as subinterfaces com as vlans q serão roteadas a partir da interface fisica.
    Ficaria mais ou menos assim a configuração do roteador.
    interface f0/1
    duplex full
    speed 100
    exit
    interface f0/1.2
    encapsulation dot1q 2
    ip address 192.168.2.1 255.255.255.0
    no shut
    exit
    interface f0/1.3
    encapsulation dot1q 3
    ip address 192.168.3.1 255.255.255.0
    no shut
    exit
    A configuração do switch seria mais ou menos assim:
    interface f0/1
    switchport mode trunk
    speed 100
    duplex full
    no shut
    exit

    0

    0
  4. lucio08

    Falta criar sub interfaces na Fa0/1 no roteador para que elas possam se comunicar com as novas vlans criadas no switch pois a partir do momento que são atribuidas vlans a um switch as mesmas so irão se comunicar atraves de um roteador.

    0

    0
  5. jonhlimabatata

    Tenhos essas observações a fazer.

    R2# sh ip rout

    0

    0
  6. guilhermehgalves

    Bem, baseado no enunciado e na saida do comando sh ip route nao podemos ter essa informação pois na figura trata-se de R1 e o sh ip route é dado em um outro router de denominação R2. Ja para o R1 falta uma sub interface para rede 192.168.3.0. essa foi facil hehheeh

    0

    0
  7. Luiz Fernando

    ainda acho mais q seja um erro do que pegadinha esse desafio ai…em relacao ao R1 e R2…

    0

    0
  8. matrod05

    Marcão,

    Primeiro tem de ver se esta logado no router certo :

    R2# sh ip rout
    C 192.168.1.0/24 is directly connected to F0/1.1
    C 192.168.2.0/24 is directly connected to F0/1.2

    Se na topologia é R1, porque tais logado no R2 ???

    Assim que estiver logado no R1 de verdade, ou corrigir o hostname (se for o caso); ai sim pode se dar um “show ip int br” pra ver se todas sub-interfaces estão corretas para o roteamento “Inter-vlan” criando a sub “1.3 com ip 192.168.3.2 que sera o gateway dos hosts da nova vlan”, access-lists no router caso queira restringir ou permitir algum pc depois, etc… .

    Mateus Rodrigues

    0

    0
  9. matrod05

    Marcão,

    Primeiro tem de ver se esta logado no router certo :

    R2# sh ip rout
    C 192.168.1.0/24 is directly connected to F0/1.1
    C 192.168.2.0/24 is directly connected to F0/1.2

    Se na topologia é R1, porque tais logado no R2 ???

    Assim que estiver logado no R1 de verdade, ou corrigir o hostname (se for o caso); ai sim pode se dar um “show ip int br” pra ver se todas sub-interfaces estão corretas para o roteamento “Inter-vlan” criando a sub “1.3 com ip 192.168.3.2 que sera o gateway dos hosts da nova vlan”, access-lists no router caso queira restringir ou permitir algum pc depois, etc… .

    Mateus Rodrigues

    0

    0
  10. Israel Carlos

    Só falta saber kd o R2 ? rs

    0

    0
  11. marcos-freire

    Olá pessoal…

    Para que ocorra uma comunicação entre hosts que estão em vlans diferentes e necessário que um router ou switch L3 esteja devidamente configurado para que possa haver a comunicação, pelo que montra a rede ilustrada, temos um router que fará esta comunicação entre vlan 2 e vlan 3. Na tabela de roteamento do router R1, temos a informação da rede 192.168.1.0 que está diretamente conectada a FA0/1.1 e a rede 192.168.2.0 diretamente conectada a FA0/1.2 e não temos nenhuma informação sobre a rede 192.168.3.0 onde está a vlan 3.

    Levando em consideração que os hosts ja foram configurados com seus respectivos gateway e as portas e as vlans foram já configuradas no switch S1, a meu ver só esta faltando configurar a porta fa0/1 do switch S1 com trunk e a configuração da fa0/1 do router R1 para que possa ocorre a comunicação entre as vlans.

    Segue a configuração.

    S1(config)#int fa0/1
    S1(config-if)#switchport mode trunk
    S1(config-if)#speed 100
    S1(config-if)#duplex full
    S1(config-if)#no shutdown

    R1(config)#int fa0/1
    R1(config-if)#speed 100
    R1(config-if)#duplex full
    R1(config-if)#no shutdown

    R1(config)#int fa0/1.1
    R1(config-subif)#encapsulation dot1Q 1
    R1(config-subif)#ip add 192.168.1.1 255.255.255.0

    R1(config)#int fa0/1.2
    R1(config-subif)#encapsulation dot1Q 2
    R1(config-subif)#ip add 192.168.2.1 255.255.255.0

    R1(config)#int fa0/1.3
    R1(config-subif)#encapsulation dot1Q 3
    R1(config-subif)#ip add 192.168.3.1 255.255.255.0

    R1#sh ip route

    C 192.168.1.0/24 is directly connected, FastEthernet0/1.1
    C 192.168.2.0/24 is directly connected, FastEthernet0/1.2
    C 192.168.3.0/24 is directly connected, FastEthernet0/1.3
    R1#

    P4SA>ping 192.168.3.15

    Pinging 192.168.3.15 with 32 bytes of data:

    Reply from 192.168.3.15: bytes=32 time=125ms TTL=127
    Reply from 192.168.3.15: bytes=32 time=124ms TTL=127
    Reply from 192.168.3.15: bytes=32 time=109ms TTL=127
    Reply from 192.168.3.15: bytes=32 time=125ms TTL=127

    Ping statistics for 192.168.3.15:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 109ms, Maximum = 125ms, Average = 120ms

    P4SA>ping 192.168.3.16

    Pinging 192.168.3.16 with 32 bytes of data:

    Reply from 192.168.3.16: bytes=32 time=125ms TTL=127
    Reply from 192.168.3.16: bytes=32 time=125ms TTL=127
    Reply from 192.168.3.16: bytes=32 time=125ms TTL=127
    Reply from 192.168.3.16: bytes=32 time=125ms TTL=127

    Ping statistics for 192.168.3.16:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 125ms, Maximum = 125ms, Average = 125ms

    0

    0
  12. Vinicius.vvr

    Boa noite a todos, bom esse é meu segundo post !! rsrsrs

    Vamos lá! É grandinho esse heim!!

    Problema de VLan,

    Aparentemente a VLAN2 esta associada aos micros P4SA e P4SB corretamente nas portas f0/2 e f0/3 como estão no mesmo range não temos grandes problemas neste momento.

    As máquinas P4SC e P4SD estão associadas na vlan3 e permitem se comunicarem por que estão no mesmo range.

    Para as máquinas das vlan 2 e 3 se comunicarem é necessário um layer 3 (router) neste caso para prover o roteamento. Como não sabemos os modelos corretos dos equipamento teremos um problema com encapsulamento que pode ser ISL e DOTIQ.

    Como no texto informa roteador “R2” e o desenho é “R1” tecnicamente fica quase inviavel saber a correta informação, pois o R1 pode estar ligado a outro SW (core) para prover o acesso do R2 ou ponto-a-ponto de fast.

    Portanto acho que a escrita da saida do comando IP router é R1.

    Com os dados em mãos fica fácil resolver o problema do nosso admin esquecido:

    Configuração do SW (levando em consideração um 2950-24T ou parecido):

    (assumindo Dot1Q, apessar que ainda existe ISL)

    em modo #
    conf terminal
    ip default-gateway 192.168.1.1
    interface vlan 1
    ip address 192.168.1.2 255.255.255.0

    vtp mode server
    vtp domain blogccna
    vtp version 2

    Criando a VLAN´s
    em modo #
    vlan database
    (vlan)#vlan 2 name TI
    (vlan)#vlan 3 name ADM

    Apos o mesmo:
    Não pense!! faça 🙂
    # wr
    # copy running-config startup-config

    Para conferir:
    # sh vlan

    Agora vamos para nosso amigo router(assumindo um equipamento dot1q em condições normais de funcionamento):

    em modo #
    conf terminal
    interface vlan 1
    ip address 192.168.1.1 255.255.255.0

    interface FastEthernet0/1.1
    encapsulation dot1Q 1
    ip address 192.168.1.1 255.255.255.0

    interface FastEthernet0/1.2
    encapsulation dot1Q 1
    ip address 192.168.2.1 255.255.255.0

    interface FastEthernet0/1.3
    encapsulation dot1Q 1
    ip address 192.168.1.3 255.255.255.0

    Em seguida:
    # wr
    # copy running-config startup-config

    Pontos necessários e ajustes:

    Estando no Router, levantar a F0/0 (para subir todas de uma vez)

    # conf terminal
    int fas0/0
    no shut
    wr
    copy running-config startup-config

    No S1:

    em #
    conf ternimal
    interface FastEthernet0/1
    switchport mode trunk
    spanning-tree portfast trunk
    duplex full
    speed 100
    no shut

    Ajustando e refinando mais o S1:

    #interface range fastEthernet 0/2 – 24
    (config-if-range)#speed 100
    (config-if-range)#duplex full
    (config-if)#spanning-tree bpduguard enable
    (config-if)#switchport mode access
    (config-if)#no shut

    Bom acho que é isso…

    Se tiver alguma coisa a acresentar/correção, tudo é valido 🙂

    Sucesso a todos,

    Vinicius Vasconcellos

    0

    0
  13. Alexandre Avelar

    Se o R2 no enuciado for o rotuer1, falta configurar um trunk no switch para que o rotuer1 possa fazer o roteamento entre as redes. No trunk será passado as vlans 2 e 3. É necessário configurar as sub-interfaces no router.

    0

    0
  14. alberto_villa

    Boa Noite,

    Para simular o exemplo, considerando que existe um erro de digitação no nome do router, utilizei a seguinte configuração(Comandos básicos e só linhas relevantes):

    Switch1#sh run
    Building configuration…
    interface FastEthernet0/1
    switchport mode trunk
    !
    interface FastEthernet0/2
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/3
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/13
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/14
    switchport access vlan 3
    switchport mode access
    !
    interface Vlan1
    ip address 192.168.1.2 255.255.255.0
    !
    ip default-gateway 192.168.1.1

    Router1#sh run
    Building configuration…
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.1
    encapsulation dot1Q 1 native
    ip address 192.168.1.1 255.255.255.0
    !
    interface FastEthernet0/1.2
    encapsulation dot1Q 2
    ip address 192.168.2.1 255.255.255.0
    !
    !
    !
    Router1#sh ip route
    C 192.168.1.0/24 is directly connected, FastEthernet0/1.1
    C 192.168.2.0/24 is directly connected, FastEthernet0/1.2

    O que falta, no router R1 é efetuar a configuração da sub-interface fa0/1.3 , conforme o padrão mínimo efetuado nas outras duas sub-interfaces:

    interface FastEthernet0/1.3
    encapsulation dot1Q 3
    ip address 192.168.3.1 255.255.255.0

    Router1#sh ip route
    C 192.168.1.0/24 is directly connected, FastEthernet0/0.1
    C 192.168.2.0/24 is directly connected, FastEthernet0/0.2
    C 192.168.3.0/24 is directly connected, FastEthernet0/0.3

    0

    0
  15. ferrugem

    Quando temos sub-redes logicamente separadas através de VLAN (Virtual LAN), para que ocorra comunicação inter-vlan, temos a necessidade de um elemento de camada 3 (roteador, switch..) para efetuar tal comunicação.

    Considerando que o switch e os hosts já estavam previamente e corretamente configurados, a questão pede para se observar a saída do comando sh ip route (e só o que temos), o que podemos perceber é que o router ainda não sabe como chegar até a sub-rede 192.168.3.0, esta rede ainda não consta em sua routing table.

    Pela saída do comando sh ip route, podemos perceber que as sub-interfaces F0/1.1 e F0/1.2 já estão devidamente configuradas.

    Para que a VLAN 2, constante na sub-rede 192.168.2.0 /24, consiga “enxergar” a sub-rede 192.168.3.0 /24, configurada na VLAN 3, temos que criar uma outra sub-interface no R1. Poderia ser algo assim:

    R1>enable >>>(comando para acessar o modo privilegiado do roteador)
    R1#configure terminal >>>(comando para acessar o modo de configuração do roteador)
    R1(config)#int fa0/1.3 >>>(comando para criar uma sub-interface, dentro da interface real FastEthernet 0/1)
    R1(config-subif)#encapsulation dot1Q 3 >>>(comando para definir o tipo de encapsulamento que será utilizado, por exemplo poderia ser dot1Q, e o número 3 no final é referente ao VLAN ID)
    R1(config-subif)#ip address 192.168.3.1 255.255.255.0 >>>(comando para definir um endereço ip para a interface virtual. Lembrando que este endereço tem de ser configurado nos host P4SCe P4SD como DEFAULT GATEWAY!)

    O comando “no shut” não é necessário, visto que este tem de ser dado na própria interface (fa 0/1) e como as outras 2 sub-redes estavam sendo mostradas no comando sh ip route, subentende-se que a interface já estava UP UP!

    Após efetuar esta configuração no router a comunicação ocorrerá normalmente e a saída do comando sh ip route no R1 seria assim:

    R1#sh ip route
    C 192.168.1.0/24 is directly connected, FastEthernet0/0.1
    C 192.168.2.0/24 is directly connected, FastEthernet0/0.2
    C 192.168.3.0/24 is directly connected, FastEthernet0/0.3

    Espero que tenha ficado clara minha sugestão de resposta! 😉

    Abraço e bacana o desafio Marco! 😀
    Felipe Ferrugem!

    “Juntos somos ainda melhores!!!”

    PS: Considerei que tenha ocorrido um erro de digitação quando foi dito R2, e não R1 como mostra no diagrama.. Não vejo outra opção!

    0

    0
  16. ferrugem

    Ahh, boas férias!!! rsrs 😀

    Aproveite-as!!!

    0

    0
  17. matrod05

    Complementado minha resposta,

    Resolvendo camada 2:

    Alem de fazer o que eu disse, tem de incluir no S1 o comando na porta F0/1 o “switchport mode TRUNK” apenas, o que já causaria a conectividade, ou alem desse comando incluir no trunk para o R1 a divulgação apenas das vlans que queremos passar com ” switchport trunk allowed vlan 2,3″ .

    Resolvendo camada 3:

    R1- Criar sub-interface 1.3 e seu ip

    0

    0
  18. Felipe

    – Acertar o HOSTNAME do Roteador R2 para R1;
    – Configurar a sub-interface Fas 0/1.3 conforme o diagrama;
    – Configurar a portas do Switch de Borda como trunk (ISL ou 802.1q), para que seja feito a marcação dos frames;

    0

    0
  19. ramonfontes

    Levando em conta que R2 não seja R2, mas sim R1, vamos lá:

    No Switch 1:

    #É necessário configurar a porta Fa0/1 de tal forma que ela possa transportar as informações das VLANs. O modo trunk realiza tal processo.

    interface FastEthernet0/1
    switchport mode trunk
    !

    #As interfaces Fa0/2, Fa0/3, Fa0/13 e Fa0/14 são adicionadas na VLAN 2 e VLAN 3 respectivamente.

    interface FastEthernet0/2
    switchport access vlan 2
    !
    interface FastEthernet0/3
    switchport access vlan 2
    !
    interface FastEthernet0/13
    switchport access vlan 3
    !
    interface FastEthernet0/14
    switchport access vlan 3
    !

    #Configuração de endereço na Vlan1.

    interface Vlan1
    ip address 192.168.1.2 255.255.255.0
    !

    No Router R1:

    # Criação das Subinterfaces e encapsulamento delas. Em R1, falta a criação e configuração da terceira subinterface – F0/1.3

    interface FastEthernet0/1.1
    encapsulation dot1Q 1 native
    ip address 192.168.1.254 255.255.255.0
    !
    interface FastEthernet0/1.2
    encapsulation dot1Q 2
    ip address 192.168.2.254 255.255.255.0
    !
    interface FastEthernet0/1.3
    encapsulation dot1Q 3
    ip address 192.168.3.254 255.255.255.0
    !

    Ao criar a VLAN3 e inserir os hosts P4SC e P4SD nela, é natural que o host P4SA consiga comunicar com o host P4SB e ao mesmo tempo não consiga comunicar com os hosts P4SC e P4SD, já que estão em VLANs distintas. A criação da terceira subinterface, a adoção do encapsulamento no router e a configuração “trunk” na porta F0/1 do Switch 1 resolvem o problema da comunicação.

    0

    0
  20. Edilson

    Falta configurar a subinterface referente a nova VLAN 3 no router e, colocar a porta fa0/1 do switch em trunk

    R1(config-if)#interface fastethernet 0/1.3
    R1(config-subif)#encapsulation dot1q 3
    R1(config-subif)#ip address 192.168.3.1 255.255.255.0
    R1(config-subif)#end

    Sw1(config)#interface fastethernet0/1
    Sw1(config-if)#switchport trunk encapsulation dot1q
    Sw1(config-if)#switchport mode trunk
    Sw1(config-if)#end

    0

    0
  21. Edson Siqueira

    Bom Pessoal, eu concordo com o Ferrugem, pela saída mostrada, falta a configuração da VLAN 3 no Router. Outro ítem muito importante que devemos levar em consideração, seria a configuração dos hosts. Neste problema, poderia estar faltando ou estar errada a configuração do gateway nos hosts. Mas pelo enunciado da questão, creio que esteja faltando somente a configuração para a nova VLAN no roteador. Abcs.

    0

    0
  22. André Santana

    Na minha opinião falta configurar no “R1” uma outra sub-interface fa0/1.3 com o encapsulamento dot1q 3, com o ip 192.168.3.1 255.255.255.0.
    E também adcionar a vlan 3 ao grupo de vlans que possuem permissão para comunicarem-se através do trunk, com o comando
    int fa 0/1
    switchport trunk allow vlan 3.

    Acho que é isso.

    0

    0
  23. halisonac

    Bom, olhando o desfio, no meu ponto de vista falta configurar a porta do sw para trunk e criar uma subinterface no router para a vlan3

    No Switch 1:
    Configurar a porta Fa0/1 para o modo trunk
    interface FastEthernet0/1
    switchport mode trunk

    No Router R1:
    Criar a subinterface para a vlan3
    De acordo com a saida do comando a subinterface FastEthernet0/1.1 e FastEthernet0/1.2 já estão criadas

    Já está criada
    interface FastEthernet0/1.1
    encapsulation dot1q 1
    ip address 192.168.1.1 255.255.255.0

    Já está criada
    interface FastEthernet0/1.2
    encapsulation dot1q 2
    ip address 192.168.2.1 255.255.255.0

    Essa subinterface foi criada para resolver o problema juntamente com a configuração da porta FastEthernet0/1 do sw para o modo trunk
    interface FastEthernet0/1.3
    encapsulation dot1q 3
    ip address 192.168.3.1 255.255.255.0

    0

    0
  24. Roberto Paiva

    Foi feito o Lab no Packet Tracer!!!
    Funcionado perfeitamente.

    ###########Router#################
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.1
    encapsulation dot1Q 1 native
    ip address 192.168.1.1 255.255.255.0
    !
    interface FastEthernet0/1.2
    encapsulation dot1Q 2
    ip address 192.168.2.1 255.255.255.0
    !
    interface FastEthernet0/1.3
    encapsulation dot1Q 3
    ip address 192.168.3.1 255.255.255.0
    !
    interface Vlan1
    no ip address
    shutdown
    !

    Router#sh ip route
    Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
    i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
    * – candidate default, U – per-user static route, o – ODR
    P – periodic downloaded static route

    Gateway of last resort is not set

    C 192.168.1.0/24 is directly connected, FastEthernet0/1.1
    C 192.168.2.0/24 is directly connected, FastEthernet0/1.2
    C 192.168.3.0/24 is directly connected, FastEthernet0/1.3

    —————————————-
    ######### Switch 2960 ###################

    interface FastEthernet0/1
    switchport mode trunk
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/5
    switchport access vlan 2
    switchport mode access
    !
    interface FastEthernet0/6
    switchport access vlan 3
    switchport mode access
    !
    interface FastEthernet0/7
    switchport access vlan 3
    switchport mode access
    !

    Switch#sh vlan

    VLAN Name Status Ports
    —- ——————————– ——— ——————————-
    1 default active Fa0/2, Fa0/3, Fa0/8, Fa0/9
    Fa0/10, Fa0/11, Fa0/12, Fa0/13
    Fa0/14, Fa0/15, Fa0/16, Fa0/17
    Fa0/18, Fa0/19, Fa0/20, Fa0/21
    Fa0/22, Fa0/23, Fa0/24, Gig1/1
    Gig1/2
    2 TI active Fa0/4, Fa0/5
    3 RH active Fa0/6, Fa0/7
    1002 fddi-default active
    1003 token-ring-default active
    1004 fddinet-default active
    1005 trnet-default active

    VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
    —- —– ———- —– —— —— ——– —- ——– —— ——
    1 enet 100001 1500 – – – – – 0 0
    2 enet 100002 1500 – – – – – 0 0
    3 enet 100003 1500 – – – – – 0 0
    1002 enet 101002 1500 – – – – – 0 0
    1003 enet 101003 1500 – – – – – 0 0
    1004 enet 101004 1500 – – – – – 0 0
    1005 enet 101005 1500 – – – – – 0 0

    0

    0
  25. Carlos Campos

    Marco.
    Primeiramente dar os parabens pelo blog e a todos os colaboradores que fazem parte desse blog e posso afirmar com convicção que nao vi algo parecido na area de TI no que se refere a certificações Microsoft da qual eu já possuo que tivesse essa riqueza de informação e discussoes sobre uma certificacao de TI como o CCNA.
    Bom como é o meu primeiro comentario no blog, vou tentar responder da melhor maneira possível.
    Devemos fazer duas configuracoes para que os hosts da VLAN2 possam se comunicar com os hosts da VLAN3
    1o – Configurar uma sub-interface lógica no R1 da interface fisica FA0/1, definir o tipo de encapsulamento que essa interface terá, no caso, DOT1Q e a VLAN que será transportada nesse encapsulamento, no nosso caso a VLAN 3.
    R1>enable (comando para entrar no modo de exec privilegiado)
    R1#configure terminal (comando para entrar em modo de configuração de terminal)
    R1(config)#configure interface Fa0/1.3 (comando para criar a sub-interface lógica FA0/1.3)
    R1(config-subif)#ip address 192.168.3.1 255.255.255.0 (comando para definir o endereço IP na interface, endereço IP que deve estar na mesma sub-rede das estacoes e as estacoes devem apontar o default gateway para esse endereço IP)
    R1(config-subif)#encapsulation dot1q 3 (comando que define o tipo de encapsulamento como DOT1Q e que irá transportar informacoes da VLAN3 nesse entroncamento)
    R1(config-subif)#exit (comando para sair do modo de configuracao de interface)
    R1(config)#exit (comando para voltar ao modo EXEC de usuário)
    R1#copy running-config startup-config (comando para salvar as configuracoes que foram feitas que estao na RAM para NVRAM)

    2o – Configurar a interface de entroncamento entre o switch1 e o R1 com a vlan nova a ser transportada, através do comando SW1(config-if)#encapsulation dot1q 3. Vale um comentario nesse 2o item, tal configuração poderá ou nao ser necessária, de acordo com o que está configurado atualmente na interface. Se o comando na interface FA0/1 está definido para transportar todas as VLAN’s (SW1(config-if)# switchport mode trunk), nao se faz necessária tal configuração no switch, ficando apenas a configuração da sub-interface lógica no R1. Porém caso o comando (SW1(config-if)#encapsulation dot1q 1) ou (SW1(config-if)#encapsulation dot1q 2) configurado será necessário fazer a configuracao para transportar a vlan 3, conforme abaixo

    SW1>en (comando para entrar em modo EXEC privilegiado)
    SW1#configure terminal (comando para entrar em modo de configuracao de terminal)
    SW1(config)#interface fa0/1 (comando para entrar em modo de configuração da interface FA0/1)
    SW1(config-if)#encapsulation dot1q 3 (comando que define o encapsulamento como DOT1Q e que será transportada a VLAN 3 nesse entroncamento)
    SW1(config-if)#exit (comando para sair do modo de configuracao da Interface)
    SW1(config)#exit (comando para sair do modo de configuraçao de terminal)
    SW1#copy running-config startup-config (comando que irá salvar a configuração na NVRAM para subir em caso de desligamento do switch ou comando reload)

    Espero ter sido claro na minha explicacao e ter acertado.
    Grande abraço
    Carlos

    0

    0
  26. Willian Guilherme

    Marco, Segue a configuração que deve estar presente em ambos os dispositivos.
    O problema descrito na pergunta de acordo o cenário apresentado, está no roteamento Intervlan. Alguns problemas podem estar ocorrendo para que ambas as VLAN’s não estejam se comunicando, são eles:

    1. Os PC’s P4SA e P4SB estarem sem o “Default Gateway” de sua VLAN2 (192.168.2.1) configurados adequadamente.
    2. A sub-interface f0/1.2 do router R1 estar em com protocolo “Down”
    3. Hosts da VLAN3 P4SC e P4SD não estão com o endereço de seu gateway configurado na Interface, portanto não sabem como retornar os pacotes para a VLAN2

    Das 3 opções acima eu fico com a “1”, pois os PC’s P4SA e P4SB sem o gateway da VLAN2 configurados conseguirão se falar entre si, porém não serão capazes de falar com dispositivos de outra VLAN.

    Configuração do Switch:
    1. Criando VLAN’s no switch S1
    S1#configure terminal
    S1(config)#vlan 2
    S1(config-vlan)#vlan3
    S1(config-vlan)#

    2. Ativando o trunk dot1q na interface f0/1 do switch S1
    S1# configure terminal
    S1# interface fastethernet 0/1
    S1# switchport trunk encapsulation dot1q
    S1# switchport mode trunk

    3. Alocando Interfaces a VLAN2
    S1# configure terminal
    S1(config)#interface f0/2
    S1(config-if)#switchport mode access
    S1(config-if)#switchport access vlan 2 –> Estação P4SA

    S1(config-if)#interface f0/3
    S1(config-if)#switchport mode access
    S1(config-if)#switchport access vlan 2 –> Estação P4SB

    3. Alocando Interfaces a VLAN3
    S1# configure terminal
    S1(config)#interface f0/13
    S1(config-if)#switchport mode access
    S1(config-if)#switchport access vlan 3 –> Estação P4SC

    S1(config-if)#interface f0/14
    S1(config-if)#switchport mode access
    S1(config-if)#switchport access vlan 3 –> Estação P4SD

    Configurando o R1 para realizar o roteamento Intervlan
    R1#vlan database
    R1(vlan)#vlan 2
    R1(vlan)#vlan 3
    R1(vlan)#apply

    R1# configure terminal
    R1(config)#interface f0/1
    R1(config-if)#no shutdown

    R1(config-if)#interface f0/1.1
    R1(config-subif)#encapsulation dot1q 2
    R1(config-subif)# ip address 192.168.2.1 255.255.255.0 –> Gateway VLAN2

    R1(config-if)#interface f0/1.2
    R1(config-subif)#encapsulation dot1q 3
    R1(config-subif)# ip address 192.168.3.1 255.255.255.0 –> Gateway VLAN3

    Abs

    Willian Guilherme
    NetIP-SEC.com.br

    0

    0
  27. nandojackalope

    Devemos configurar uma outra subinterface (fa 0/1.3), para a VLAN3, não esqueçamos de aplicar na subinterface o encapsulamento 802.1q e configurar todas as demais configurações referente a protocolos ip.

    Até logo pessoal
    Fernando Alves
    Técnico em Informática
    CREA/PE41071

    0

    0
  28. hatus

    Vamos la…

    Quando nos deparamos com esse cenário, sub-redes separadas entre VLANS, nessecitamos de um equipamento layer 3 ( router ou switch… ) para fazer o roteamento inter-VLANS.

    No nosso caso temos as seguinte informações 2 VLANS configuradas do Switch VLAN2 e VLAN3 e temos 2 sub-interfaces configuradas no router a sub-interface F0/1.1 com a rede 192.168.1.0 /24 configurada nela e a sub-interface F0/1.2 com a rede 192.168.2.0 configurada nela, temos 2 PCs por vlans no Switch e por fim temos a tabela de roteamento do router que nos mostra as 2 interface diretamente conectadas ao router.

    Temos então o seguinte problema VLAN 2 não se comunica com a VLAN 3.

    Levando em consideração de que todas configurações estão corretas no Switch e nos Pcs, temos que configurar mais uma sub-interface no router, sub-interface corresponde a VLAN3 com a rede 192.168.3.0 nela, ai sim a saida do comando show ip route incluirá a nova rede como diretamente conecta e ai sim a VLAN2 irá se comunicar com a VLAN3. Segue a configuração:

    R1>enable //acessar o modo privilegiado do roteador
    R1#configure terminal //acessar o modo de configuração
    R1(config)#int fa0/1.3 //criar uma sub-interface dentro da interface real FastEthernet 0/1
    R1(config-subif)#encapsulation dot1Q 3 //tipo de encapsulamento que será utilizado ISL ou dot1Q, no nosso caso dot1q e o número 3 é referente ao VLANID
    R1(config-subif)#ip address 192.168.3.1 255.255.255.0 //endereço ip para a interface virtual, esse vai ser o GATEWAY dos PCs.

    Teremos então a seguinte tabela de routeamento:

    R1#sh ip route
    C 192.168.1.0/24 is directly connected, FastEthernet0/0.1
    C 192.168.2.0/24 is directly connected, FastEthernet0/0.2
    C 192.168.3.0/24 is directly connected, FastEthernet0/0.3

    Acho que é só isso mesmo.

    Tenho 2 considerações a primeira acho que está clara, R2 ou R1? acho que aconteceu algum erro de digitação.
    A outra consideração é a seguinte: o que a rede 192.168.1.0 /24 está fazendo na história ? tentei achar alguma funcionalidade para ela, a única opção para ela seria esperar alguma outra VLAN estou certo ?

    Flw galera !!!!!

    FORZA PALESTRA

    0

    0
  29. Willian Guilherme

    Marco se me permite gostaria de fazer uma correção ao meu comentário.
    No roteador R1, já existe uma sub-Interface f0/1.1 com endereço IP na subnet 192.168.1.0/24, dessa forma a configuração das sub-interfaces deveria estar da seguinte maneira:

    R1(config-if)#interface f0/1.2
    R1(config-subif)#encapsulation dot1q 2
    R1(config-subif)# ip address 192.168.2.1 255.255.255.0 –> Gateway VLAN2

    R1(config-if)#interface f0/1.3
    R1(config-subif)#encapsulation dot1q 3
    R1(config-subif)# ip address 192.168.3.1 255.255.255.0 –> Gateway VLAN3

    O Problema neste cenário é que a sub-Interface f0/1.3 não existe ou pode estar “Down” o que faria a interface não ser listada com o comando “show ip route” e portanto esta interface deve estar configurada com endereço IP 192.168.3.1 para que os P4SC e P4SD, possam acessar os hosts da VLAN2

    abs

    Willian
    NetIP-SEC.com.br

    0

    0
  30. ricardoblass

    … Se a saída correta foi o R1….rs Acho que a pegadinha está naquele ip setado na interface fa0/1 no switch, ou seja, talvez esse switch seja um switch L3 e devamos retirar este ip e colocar o comando “switchport” para retornar a porta como apenas L2, após isto, o trunk deverá ser feito normalmente como muitos mensionaram acima….

    O desafio ta meio confuso…rs

    0

    0
  31. luisholtz

    Na situação acima, temos um ambiente onde duas vlans tem a necessidade de se comunicar. Em tese, existe a necessidade da implantação de um protocolo para tal capacidade. Portanto o vlan trunking Protocol (VTP) deverá ser utilizado e configurado no roteador especificamente na interface que o liga ao Switch. Com esta iniciativa, estamos viabilizando que pacotes que saiam de ambas vlans que desejam comunicar-se, que encontrem seu caminho através do roteador, nas sub-interfaces configuradas. um detalhe muito importante, é que a porta do switch que será ligada ao roteador, deverá ter sido configurada como porta tronco e não como porta de acesso assim como será utilizado nas portas onde se encontram os computadores constituintes das vlans.

    0

    0
  32. reisimoes

    Em relação ao Hostname , acho que foi um erro de digitação.
    Quando se cria uma Vlan, cria-se um novo dominio de Broadcast, sendo assim, para a comunicação com outras Vlans temos que criar uma nova sub-rede para indicar onde se localiza tal vlan, indicando também a esta vlan o seu Gateway,
    No caso do exemplo criaremos uma subinterface
    F0/1.3 com endereço de rede 192.168.3.0
    Essa sub-rede somente é criada em um Router, pois este equipamento fará o roteamento entre Vlans (sub-redes).
    Habilitamos o Protocolo de encapsulamento dot1q na subinterface, para suportar o roteamento das vlans.
    Assim teremos na saída do Router a rede 192.168.3.0 diretamente conectada, fazendo com que os Hosts P4SC e P4SD pertencentes a Vlan 3 se comuniquem com os hosts da Vlan 2.

    0

    0
  33. gudines

    O pessoal já matou a pau.
    Basicamente deverá ser criada a subinterface no Router com o IP da rede 192.168.3.0/24 (VLAN 3) e a Fast0/1 do Switch tem que estar habilitada para o trunk das VLANs 2 e 3.

    0

    0
  34. Mizael Andrade Reis

    É isso ai.Falta no router a configuração da subinterface correspondente a VLAN 3(192.168.3.0).Estando a porta F0/1 Switch habilitada como Trunk, não vejo o que faltaria para o sucesso da configuração.

    Mizael

    0

    0
  35. lrattes

    Ficou faltando configurar as portas F0/1.1 e F0/1.2 para propagar as VLANS 3 e 2, fazendo um Trunk. Sem propagar as vlans como poderiam se falar.

    0

    0
  36. Alisson

    Do modo em que o cenário está configurado, temos 2 (dois) domínios de broadcast (VLAN2 e VLAN3) e a intenção de comunicá-los através de um roteador. Porém, não há configuração neste roteador, para que os domínios se conheçam através da tabela de roteamento, havendo necessidade então de configurar uma sub-interface para cada um dos dois segmentos, com suas respectivas VLANs. Quanto ao switch, precisamos configurar a porta utilizada para comunicação com o roteador, em modo tronco e isso fará com que haja transporte das 2 (duas) VLANs entre o roteador e o switch. Feito isso, todos os hosts estarão aptos à se comunicarem.

    That’s all folks people!

    Um abraço à todos!

    0

    0
  37. Luiz Campos

    Necessário configurar a sub-interface do router R1. As saídas apresentadas são referentes ao router R2. Lembrando que, como são redes distintas (192.168.2.0 e 192.168.3.0), o router precisa da configuração para estabelecer a convergência entre as redes.

    0

    0
  38. tecvictor

    e necessario criar uma nova sub-interface no R-1 para que o mesmo
    possa está diretamente conectado a rede 192.168.3.0 /24 e
    possa fazer o roteamento adequadamente.
    apesar da vlan está configurada e aplicada nas portas
    corretas do switch , o roteador não conhece a nova rede
    e não está no mesmo dominio de broadcast da mesma (algo como conectividade layer 3).

    aplicando a seguinte configuração no R-1:
    router1(config)#interface fa 0/1.3
    router1(config-if)#encapsulation dot1q (se for um switch 2950 não tera o isl como opção pois o mesmo so suporta dot1q (802.1q).
    router1(config-if)#ip address 192.168.3.1 3 255.255.255.0 (3 se for seguir a logica de que a rede 192.168.1.0/24 está na vlan 1 e 192.168.2.0/24 está na vlan 2)

    Essas configurações resolveriam o problema.

    =)

    0

    0
  39. wagnerpa

    configurar a rota na fast

    0

    0
  40. wagnerpa

    Configurar uma sub-interface no router1

    router(config)#interface fastethernet 0/1.3
    router(config-if)# encapsulation dot1q 3
    router(config-if)#ip address 192.168.3.1 255.255.255.0

    0

    0
  41. João Victor

    Como visto na saída do comando show ip route, as subinterfaces das vlans 1/nativa e vlan 2 ja foram criadas, basta apenas criar a subinterface da vlan3, e escolher o encapsulatmento (isl ou dot1q, depende do modelo do switch) e adicionar um ip válido da rede 192.168.3.0 /24, que sirva de default gateway as máquina da vlan 3. Pode-se adicionar uma descrição a essa interface para melhor entendimento da rede. Salve as configurações, não é necessário ativar a interface pois a mesma está ativa. Vá ao switch S1 e verifique se o encapsulamento de interface fastethernet 0/1 é isl ou dot1q, aproveitando verifique se a interface está em modo trunk. Ambas as verificações podem ser vistas com o comando show interface fastethernet 0/1 swichtport. Caso não esteja configure com o encapsulamento que o switch aceita e configure a interface como trunk.

    Bom espero que esteja correto, fiquei um pouco em duvida com relação a saida do comando show ip route, é apontado o nome do router como R2, mas na figura o roteador é apontado como sendo R1. Espero que tenha sido um engano e isso seja relevante.

    Abraços

    0

    0
  42. Marco Filippetti

    Pessoal, peço desculpas pela falha! O router em questão seria o R1 e não o R2, como na saída. Perdão por isso… ms deixo aqui uma sugestão: Quando encontrarem problemas mais ou menos obvios, como este, ainda mais quando está valendo um prêmio, sugiro que postem a resposta ressaltando o erro, como muitos fizeram… o motivo disso é simples: Neste tipo de desafio, a melhor resposta leva, mas se houver mais de uma “melhor resposta”, leva quem respondeu antes. E foi o que ocorreu aqui. Muitas respostas boas e corretas, mas quem deu a melhor resposta, ANTES, foi Marcos Freire, no comment #11.

    Lembrando que a resposta correta deveria incluir a adição da subinterface em R1 e a ativação do trunking na mesma para a nova VLAN, assim como deveria mencionar que os hosts da nova VLAN deveriam ter o IP desta nova subinterface como seu default gateway.

    Por isso, o prêmio vai mesmo para o Marcos. Marcos, parabéns! Levou um livro CCNA 4.1!

    E a todos, agradeço a participação! E lembrem-se… na próxima, sejam rápidos!!!! 😀 !

    Um abraço,

    Marco Filippetti

    0

    0
  43. marcos-freire

    Olá pessoal…

    Quero agradecer a todos e dizer que estou muito feliz por ter ganhado o livro do Marco. Ter ganhado este livro é um grande incentivo para que eu continue o meu estudo para obter a certificação Cisco.

    Um abraço,

    Marcos Freire

    0

    0
  44. sadrachcosta

    Bom dia Pessoal,
    Está é a minha primeira participação num desafio da semana desde que me cadrastei neste blog. Quanto a solução para o desafio proposto, faço as minhas palavras as palavras do Willian, ele praticamente disse tudo bem claro e testei esse ambiente e funcionou normalmente, puxa o pessoal aqui é rapido nem sequer deixam sobra para os pobres.

    abraços,

    SCosta

    0

    0
  45. hatus

    Parabéns macos… iso que da não logar no blog todo dia rr

    0

    0
  46. André Santana

    Parabéns Marcos.
    Mas me ficou uma dúvida no post do Marcos e o
    S1#(config-if) int fa 0/1
    switchport mode trunk
    switchport trunk allowed vlan all
    ??????????????????

    0

    0
  47. Marco Filippetti

    quem não entendeu fui eu rsrsrs qual a dúvida, afinal?

    0

    0
  48. miovieira

    S1(config)#int fa0/1
    S1(config-if)#switchport mode trunk
    S1(config-if)#speed 100
    S1(config-if)#duplex full
    S1(config-if)#no shutdown

    qccna, por default todas as vlans passarão pelo trunk.
    Não obrigatoriamente precisa colocar o comando “switchport trunk allowed vlan all”

    Acho que é essa sua dúvida, certo?

    0

    0
  49. André Santana

    É isso mesmo Miovieira.
    Bom eu tinha essa dúvida porque no packet se eu não inserir esse comando o trunk não funciona, por isso achei que que deveria ser obrigatório.
    Valeu por responder Miovieira.
    Abraço

    0

    0
  50. fabio_candido

    faltou criar a sub interface no router R1 referente a rede 192.168.3.0. para haver comunicacao entre vlan diferentes tem que haver um equipamento de nivel 3, no caso o router, para rotear os pacotes afinal sao de redes diferentes

    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.1
    encapsulation dot1Q 1 native
    ip address 192.168.1.1 255.255.255.0
    !
    interface FastEthernet0/1.2
    encapsulation dot1Q 2
    ip address 192.168.2.1 255.255.255.0
    !
    interface FastEthernet0/1.3
    encapsulation dot1Q 3
    ip address 192.168.3.1 255.255.255.0
    !

    Router 1#sh ip route
    Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
    i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
    * – candidate default, U – per-user static route, o – ODR
    P – periodic downloaded static route

    Gateway of last resort is not set

    C 192.168.1.0/24 is directly connected, FastEthernet0/1.1
    C 192.168.2.0/24 is directly connected, FastEthernet0/1.2
    C 192.168.3.0/24 is directly connected, FastEthernet0/1.3
    Router 1#

    0

    0
  51. gabrielsouzafatec

    Falta a configuração no R1 para que a hosts de vlans diferentes possam se comunicar, incluindo a 192.168.3.0 na sub-interface fast0/1.3 do router R1.

    0

    0
  52. gustavo.ivo

    configurar a porta fa0/1 em modo trunk
    ativar encapsulamento dot1q no router r1

    confiurar gateway na maquinas com endereços das subinterfaces do router r1
    no shutdown na interface fisica f0/0

    0

    0
  53. lucaspedro1

    Falta configurar 2 subinterface na F0a/1 com o endereço 192.168.3.0 e outra para rede 192.168.2.0 para q o router possa rotear as duas redes
    um abraço…

    0

    0

Deixe uma resposta