«

»

set 29 2009

[CCNA/CCNP] Desafio 1 da Semana 5 – Setembro de 2009

Novamente, depois de um tempo, voltamos com os famosos desafios do blog! Este também vale um livro CCNA 4.1, dado o grau de dificuldade. O primeiro que responder E justificar sua resposta corretamente, leva. Tem que justificar, assim, não privilegio aqueles que apenas simulam e chegal ao resultado, mas também os que buscam entender o porquê do resultado.

Observe a figura abaixo com atenção, e responda:

Considerando que a rede abaixo encontra-se configurada com um protocolo de roteamento classful, quais as redes que constarão no update originado pelo Router “D”, na direção apresentada na figura?

desafio_290909.gif

Bom trabalho pessoal!

Abs,

Marco.

0
0

45 comentários

Pular para o formulário de comentário

  1. thejapa

    172.16.0.0/16
    10.0.0.0/8

    O Roteador A divulga 10/8, o B divulga 10/8 pro C.
    C divulga 10/8 pro D, e o D divulga 10/8 e 172.16/16 adiante.

    Vale lembrar que apesar do 172.16/12 ser RFC1918, o roteador não usa esse range como /12, e sim como /16.

    Não entendi exatamente o que precisa ser justificado, mas os roteadores vão trabalhar com rotas classfull já que provavelmente estão usando RIPv1 (ou o finado IGRP).

    Vão divulgar rotas que caso fosse usado um protocolo de roteamento classless, poderiam ser (até certo ponto) sumarizadas. Mas a princípio numa rede com protocolos de roteamento classfull, não irão se comportar como esperado.

    0

    0
  2. amarantes2001

    172.16.0.0/16 e 10.0.0.0/8 (apenas as classful)
    OBS: rede 10.1.1.0, 10.1.2.0 e 10.1.3.0 não será acessível para redes que recebem a propagação na direção indicada por D, visto que o router D irá apenas propagar sua rede 10.0.0.0 e não as anteriores

    0

    0
  3. Bruno Freixo

    Ola!

    utilizando RIP como exemplo!

    O update do Roteador D envia um broadcast onde estarão todas as redes que ele conhece a cada 30 segundos.

    Como e um protocolo classfull, ele não e capaz de entender redes classless, sub-redes, VLSM, então as redes que ele reconhece nesse caso será:

    10.0.0.0/8 e 172.16.0.0/16

    Portanto essas serão as redes divulgadas pelo roteador D utilizando protocolo classfull.

    Caso ao roteador D esteja conectado um outro roteador, por exemplo E, quando ocorrer uma indisponibilidade de alguma comunicação pode utilizar de dois artificios:

    Split Horizon: Nesse caso o update do roteador D para o rotador E não terá a rede que recebeu do update do roteador E.

    Poison Reverse: Nesse caso o update do roteador D informará que o link indisponível está a 16 saltos, ou seja, já que o RIP reconhece apenas até 15 saltos, este link será considerado inalcançável.

    Espero que de para entender e correto!

    De antemão, caso seja premiado pelo livro, deixo para outro participante, pois já possuo o livro!

    Abraços.

    Bruno

    0

    0
  4. lucio08

    Devido ser um protocolo classfull ele deverar reconhecer uma rede sem mascaras quebradas, então ela devera so anunciar a rede 10.1.0.0 devido estas estarem configuradas nas suas interfaces, os pacotes que chegarem para qualquer outra rede o router D devera encaminhar para alguma rota padrão se estiver configurada.

    0

    0
  5. gustavomastroianni

    As rotas divulgadas pelo Router D serão: 172.16.0.0/16 e 10.0.0.0/8.
    O Router A divulga a rede 10.0.0.0/8 para o Router B. Router B divulga para o Router C a rede 10.0.0.0/8. Router C divulga para o Router D a rede 10.0.0.0/8 e 172.16.0.0/16.
    O motivo da divulgação de rotas classful é que protocolos de roteamento classful (ex.: RIPv1 e IGRP) não enviam em seu update para outros Routers a máscara de sub-rede.
    Nesse caso, teremos problema de que o Router D não irá conseguir se comunicar com as redes 10.1.1.0/24 e 10.1.2.0/24, pois o Router não irá “entender” as sub-redes.
    Abraços

    0

    0
  6. brunoff

    As redes a serem divulgadas pelo Router D no update serão:

    172.16.0.0 que foi aprendida através do protocolo de roteamento enviada pelo Update de C para D;
    10.1.3.0 => apesar dele ser um protoclo classfull neste caso ele não divulgará a rede 10.0.0.0 e sim a rede diretamente conectada 10.1.3.0.

    O router D não inclui em sua tabela de roteamento uma rede 10.0.0.0 através do protocolo de roteamento dinâmico porque ele entende que já está diretamente conectado a mesma, sendo assim, ele também não divulgara está rede. Mas todo router divulga as redes diretamente conectadas desde que o ip da mesma esteja dentro das redes configuradas para divulgação pelo protocolo.

    0

    0
  7. asenci

    Como nossos roteadores estão executando um protocolo de roteamento classful, eles não utilizarão as mascaras de rede configuradas nas interfaces para calcular o anuncio das redes.

    O roteador “A” irá utilizar o endereço IP 10.1.1.0 para enviar o anúncio. Em binário temos 00001010.00000001.00000001.00000000, um endereço de rede classe “A” (o primeiro bit é “0”).
    O roteador irá utilizar então os 8 primeiros bits para construir o endereço de rede: 00001010
    A rede anunciada será a 00001010.00000000.00000000.00000000, em decimal: 10.0.0.0

    O roteador “B” também possui um endereço IP de classe “A”, portanto a mesma lógica se aplica e a rede anunciada será a rede 00001010.00000000.00000000.00000000 (10.0.0.0 novamente).

    O roteador “C” possui um endereço IP de classe “B” (os primeiros bits são “10”) em sua interface, 172.16.1.0. Em binário: 11000000.00010000.00000001.00000000.
    O roteador “C” irá utilizar então os 16 primeiros bits para construir o endereço de rede: 11000000.00010000
    A rede anunciada será a 11000000.00010000.00000000.00000000, em decimal: 172.16.0.0

    O roteador “D” também possui um endereço IP de classe “A”, portanto a mesma lógica se aplica e a rede anunciada será a rede 00001010.00000000.00000000.00000000 (10.0.0.0 novamente).

    Se considerarmos que os roteadores estão redistribuindo as rotas dinâmicas, as redes anunciadas serão:

    10.0.0.0
    172.16.0.0

    Em um sistema de roteamento classless, as mascaras seriam atribuidas de acordo com a classe das redes, já que o protocolo de roteamento não envia informações de mascara de rede. Portanto teriamos as seguintes redes anunciadas:

    10.0.0.0/8
    172.16.0.0/16

    A resposta da pergunta é:
    No update gerado pelo roteador “D”, constarão as seguintes redes: 10.0.0.0 e 172.16.0.0 .
    Não há mascara no update, pois o roteador “D” está gerando um update de protocolo de roteamento classful.

    0

    0
  8. Edson

    hehe, tá no cabeçalho CCNA/CCNP não é tao simples assim, to batendo aqui, vamos ver….

    0

    0
  9. Moisés

    Os protocolos de roteamento classfull (IGRP e RIPv1) distribui apenas o endereço de rede.
    Nesse caso, o roteador D vai divulgar as rotas para 10.0.0.0/8 e 172.16.0.0/16.
    Para ele divulgar as rotas corretamente teria que habilitar um protocolo classless (RIPv2, EIGRP ou OSPF)
    e caso a opção for RIPv2 ou EIGRP desabilitar a auto-sumarização de rota.

    0

    0
  10. Edson

    Ai ai, essa eu quero ver no que vai dar,,, to mto confuso ainda.

    ==
    Saída do ROUTER_D
    ====
    ROUTER_D#sh ip route
    *** (saída resumida)
    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 2 subnets
    C 10.1.3.0 is directly connected, Serial2/0
    C 10.1.4.0 is directly connected, Serial3/0
    R 172.16.0.0/16 [120/1] via 10.1.3.1, 00:00:24, Serial2/0
    ====
    CCNA 4.1 – Pag 260
    “…Note que as sub-redes a serem anunciadas não são informadas, apenas a rede em si (classfull). O Protocolo RIP identificará as sub-redes existentes através das máscaras configuradas nas interfaces do router…”
    # Saída do próximo Salto
    ==
    ROUTER_E#sh ip route
    (saída resumida)
    10.0.0.0/24 is subnetted, 2 subnets
    R 10.1.3.0 [120/1] via 10.1.4.1, 00:00:26, Serial3/0
    C 10.1.4.0 is directly connected, Serial3/0
    R 172.16.0.0/16 [120/2] via 10.1.4.1, 00:00:26, Serial3/0
    ==
    Ou seja, o Router D vai anunciar a rede 172.16.0.0/16 e 10.1.3.0/24.
    Sim, este ultimo passo (10.1.3.0/240 vai contra todos os conceitos que aprendemos de RIPv1 até agora, porém considere que o RIP observa na interface qual a mascara utilizada e todas as mascaras são /24
    É um tanto dificil de explicar, assim como de entender.)
    Para o RIP se todas as redes fossem 10.1.X.0/24 ele entederia como ClassFull ocorrendo redes diferentes no terceiro octeto e não como subredes da rede 10.0.0.0 pois a mascara não varia, porém com a entrada da rede 172.16.0.0, há uma quebra da rede 10.1.X.0/24 e ele não consegue aprender o que esta além do 172.16.0.0.
    O grande dilema esta no envio/recebimento de atualizações entre os router B e C
    Os roteadores enviam a atualização informando a “sub-rede”, por exemplo do C para o B a rede 10.1.4.0, porém quando chega no B ele entende 10.0.0.0 in 1 hop e vice-versa, por exemplo
    O roteador B envia update para o C como 10.1.1.0, porém quando o C recebe, entende como 10.0.0.0 in 1 hop.
    E aí é que está o X da questão, não consigo compreender isso. Sei que está confuso, mas façam no PT e coloquem “debug ip rip events” vão ver a magica acontecendo.

    ==

    se ajudar, dêm uma olhada.

    http://www.4shared.com/file/136386867/7b6383a4/Lab_RIPv1-2.html
    abço e valeu =]

    0

    0
  11. blamineiro

    O Arquivo está com problema não abre no PT

    0

    0
  12. DenisBarlati

    Bem, update originado pelo router D constam as redes 10.1.3.0/24 , 10.1.4.0/24 e 172.16.0.0/24, isto é o que um suposto “router E” receberia…

    Creio que as subnets da rede 10.1.x.0 são mostradas dessa forma (e não da forma classfull) pois a comunicação do router D com o suposto “route E” é feita justamente por uma das subredes diretamente conectadas a ele (10.1.4.0), por isso acho que não faria sentido divulgá-la de forma classfull (10.0.0.0)…

    Imaginei um novo “router F” conectado ao suposto “router E”, e uma rede diferente conectando-os (192.168.x.0), ao ver a route table no “router F” a rede 10.x.x.x era mostrada de forma classfull novamente…

    —————————————
    O suposto “router E” recebe:
    E#RIP: received v1 update from 10.1.4.1 on Serial0/0/0
    10.1.3.0 in 1 hops
    172.16.0.0 in 2 hops

    e monta:
    RIP: build update entries
    network 10.0.0.0 metric 1
    network 172.16.0.0 metric 3
    —————————————

    No “router E” tenho:
    E#sh ip rip database
    10.1.3.0/24
    [1] via 10.1.4.1, 00:00:14, Serial0/0/0
    10.1.4.0/24 directly connected, Serial0/0/0
    172.16.0.0/16
    [2] via 10.1.4.1, 00:00:14, Serial0/0/0
    192.168.1.0/24 directly connected, Serial0/0/1 (### rede entre routers E e F ###)

    Já no “router F”:
    F#sh ip rip database
    10.0.0.0/8 (### classfull ###)
    [1] via 192.168.1.1, 00:00:03, Serial0/0/1
    172.16.0.0/16
    [3] via 192.168.1.1, 00:00:03, Serial0/0/1
    192.168.1.0/24 directly connected, Serial0/0/1

    Abs.

    0

    0
  13. Fábio Conceição

    Resposta: O router D vai anunciar apenas a network 172.16.1.0 /24 pela interface em questão.

    Justificativa: A interface usada pelo router D, para enviar as atualizações de roteamento no sentido apresentado pela questão, está configurada com IP address dentro da rede 10.1.4.0 /24, e assim como as networks 10.1.1.0 /24, 10.1.2.0 /24 e 10.1.3.0 /24, também faz parte da network classfull 10.0.0.0 /8. Como o protocolo de roteamento usado é classfull, e os protocolos classfull, como por exemplo, o RIPv1 e o IGRP, usam a feature anti-loop Split Horizon, essa feature entende que o router D já tem uma entrada na tabela de roteamento tendo como interface de saída, a interface configurada com o IP dentro da network 10.1.4.0 /24, por esse motivo o router D não anuncia as redes 10.1.1.0 /24, 10.1.2.0 /24 e 10.1.3.0 /24, por meio da interface em questão, apenas anunciando a network 172.16.1.0 /24, a qual não é impedida de ser anunciada por nenhuma razão.

    0

    0
  14. Diogo Gaglioni

    Excelente desafio !!

    0

    0
  15. Edson

    “RIPv1 utiliza roteamento Classfull, ou seja, todos os dispositivos conectados devem estar sob a mesma máscara de rede” e essa máscara não necessáriamente precisa ser uma máscara padrão. /8, /16 e /24 mas apenas tem de ser iguais
    Acho que a charada está aí;;;

    0

    0
  16. Fábio Conceição

    Depois de ler vi que eu digitei a network 172.16.1.0 /24, ao invés de apenas 172.16.0.0 /16. A justificativa é a mesma. Se for considerado ainda, está abaixo a correção da resposta:

    Resposta: O router D vai anunciar apenas a network 172.16.0.0 /16 pela interface em questão.

    0

    0
  17. Fábio Conceição

    .

    0

    0
  18. Claudio Marcolino

    Penso que o Route D neste tipo de roteamento em questão “classfull” vai anunciar a rede 10.1.3.0/24 e 10.1.4.0/24.
    Justificativa:
    O Router D neste caso anuncia apenas as redes diretamente conectadas a suas interfaces.

    0

    0
  19. Rafael Isquierdo

    Bom….

    Já descobrimos que no pacote de atualizações de roteamento do Router D, constam somente as redes 172.16.0.0, 10.1.3.0 e 10.1.4.0.
    Agora, pq ele não conhece as redes 10.1.2.0 e a rede 10.1.1.0 ?
    Parece que ele não consegue conhecer o que está além da rede 172.16.0.0. A rede 172.16.0.0 parece um parede para o router D, ele não enxerga nada além dela.

    Por quê ?

    0

    0
  20. Daniel Melo

    marcos,

    Pelo que vejo nos comentarios, creio que nenhum estar correto.

    Na tabela de roteamento do router D, vai estar as redes diretamente conctadas que são as 10.1.3.0/24 e 10.1.4.0/24, ou seja, a rede classful 10.1.0.0/16

    O router d enviara tambem as redes 10.1.1.0/24, 10.1.2.0/24, rede classful 10.1.0.0/16, via a porta com o endereço 10.1.3.0/24.
    O router d enviara tambem a rede 172.16.1.0/24, rede classfull 172.16.0.0/16, via a porta com o endereço 10.1.3.0/24.

    o router d so envia no sentido descrito na questão por estar com o mecanismo Split Horizon, pois não envia updates de roteamento pela porta onde recebeu as atualizações. então o router D vai utilizar as redes 10.1.0.0/16 e as redes 172.16.0.0/16 como as redes classful.

    0

    0
  21. Edson Siqueira

    Resposta abaixo, ok!

    0

    0
  22. Edson Siqueira

    Pessoal, é o seguinte:

    Primeiro, respondendo a questão:
    As redes aprendidas pelo protocolo de roteamento classfull (neste exemplo, o RIP), serão as redes:

    R 172.16.0.0/16
    R 10.1.3.0

    e só isso!!!!
    A rede 10.1.4.0, não é aprendida via protocolo de roteamento, ela é uma rede diretamente conectada.

    Segundo, porque isso acontece:
    Como estamos usando um protocolo de roteamento classfull, ele não entende a rede 10.1.1.0/24 e sim entende como uma rede classfull A 10.0.0.0/8, ou seja, existe uma classfull do roteador B, e outra do roteador C D -> divididas por uma outra rede no meio, isso forma uma rede “descontígua”, o que não funcionaria com protocolo de roteamento classfull pelo fato de o mesmo não carregar uma máscara de sub-rede em seus anúncios.

    Espero ter explicado o mais claro possível e que todos possam ter compreendido.

    Att’s,
    Edson Siqueira

    0

    0
  23. Edson Siqueira

    pessoal, estou colocando o post e ele está “comendo” alguns caracteres que coloco e não consigo editar de jeito nenhum, alguém sabe como fazer?
    ******Consegui resolver, obrigado.
    OBS.: Só esqueci de citar que as redes serão aprendidas por um suposto roteador E, ok!!!!

    Att’s,
    Edson Siqueira

    0

    0
  24. Thiago Hübes

    O router D irá anunciar as rotas 10.1.3.0/24 e 172.16.0.0/16.

    A rede 10.1.3.0 será anunciada pois é a subnet configurada na sua interface. Como o protocolo de roteamento é Classfull o router D não consegue alcançar as redes 10.1.2.0 e 10.1.1.0.

    O comportamento classfull é nítido nos limites de rede, o router C por exemplo irá anunciar a rede 10.0.0.0/8 para o router B e a rede 172.16.0.0/16 para o router D.

    0

    0
  25. Rodrigo Farias

    Eu acho que seja 172.16.0.0/16 apenas. 😛

    O roteador C vai receber um update de 10.0.0.0/8 do router B, pois os protocolos classful sumarizam nas “boundaries”, assim router C vai notar que ele tem uma rota mais especifica para a rede 10 e nao vai aceitar o update do router B. O router C vai passar 172.16.0.0/16 pra o Router D, que assim é a única rota que ele vai enviar no seu update, acredito eu.

    0

    0
  26. halisonac

    Acredito que ele vai anunciar somente a rede 172.16.0.0/16 devido ao Split Horizon onde o mesmo é utilizado em protocolos class full, onde ele entende que o router D ja possui uma entrada na tabela de roteamento devido ter uma interface configurada com ip dentro da rede 10.1.4.0/24 sendo assim nao anuncia as redes 10.1.1.0/24 10.1.2/24 e 10.1.3.0./24 anunciando somente a rede 172.16.0.0/16

    0

    0
  27. felicior

    O router D enviara um update somente com a rede 172.16.0.0/16, a rede 10.0.0.0/8 não será enviada por estar conectada direto com o proximo router.

    0

    0
  28. Bruno Freixo

    Olá,

    Corrigindo minha reposta anterior.

    *Mar 1 00:03:24: RIP: sending v1 update to 255.255.255.255 via Serial1/1 (10.1.4.1)
    *Mar 1 00:03:24: RIP: build update entries
    *Mar 1 00:03:24: subnet 10.1.3.0 metric 1
    *Mar 1 00:03:24: network 172.16.0.0 metric 1

    Mostra que o update do roteador D segue a rede 172.16.0.0/16 e 10.1.3.0 que é a rede diretamente conectada.

    0

    0
  29. Rodrigo Farias

    Ups, esqueci de dizer, ele vai enviar 172.16.0.0/16 pelo motivo ja citado acima, mas vai enviar a rede que esta diretamente conectada tambem: 10.1.3.0

    0

    0
  30. Bruno Freixo

    Olá,

    Tá difícil de encontrar alguma coisa que de uma luz, mas acho que e isso:

    O RIPv1 não tem provisão para subrede (não tem campo de subrede na mensagem). Por conta disso, não há
    nenhuma máscara associada às subredes individuais na tabela de rotas.

    Se o roteador recebe um pacote com destino 10.1.3.0 não há como saber a fronteira entre Identificação de Rede
    e identificação de Host, ou mesmo se o endereço é subnetado.

    O único recurso do roteador é assumir que a máscara configurada em uma das suas interfaces ligadas à rede
    10.1.3.0 é usada na rede. Ele usará máscara localmente configurada para a rede 10.1.3.0
    (definida no exemplo como 255.255.255.0) para derivar a subrede do endereço destino. Como o RIP interpreta a
    subrede de uma major network se ele não tem nenhuma interface atachada àquela rede?

    Sem uma interface da classe A, B ou C do destino o rotedor não tem como saber a máscara de subrede correta a
    ser usada e, portanto, não tem como identificar a subrede.

    Solução: ele precisa ter apenas uma entrada apontando para um roteador que está diretamente conectado.
    Desta forma, as tabelas de rotas de roteadores dentro da rede 10.1.3.0 tem uma entrada que direciona pacotes
    para 10.0.0.0 para o roteador de borda.

    O roteador de borda tem uma interface diretamente ligada à rede 10.0.0.0 e, portanto, possui uma máscara de subrede
    com a qual deriva a subrede para onde rotear o pacote dentro da nuvem.

    espero que consigam entender!

    abraços,

    Bruno.

    0

    0
  31. mfloresta71

    Pessoal, é o seguinte:

    Os protocolos “classfull” são incapazes de transportar a máscara de sub-rede em seus “updates”. Em outras palavras, isso significa

    que não suportam o nosso velho conhecido VLSM. No entanto, é possível o uso dos protocolos “classfull” com subredes, desde que

    cada subrede mantenha a mesma máscara em toda a rede. Para garantir que a máscara fosse constante em toda a rede, os projetistas

    dos protocolos “classful” foram obrigados a implementar algumas verificações obrigatórias cada vez que um roteador rodando um

    desses protocolos envia e recebe um “update”.

    Para não me alongar mais que o necessário, vamos analisar sem demora as verificações que o roteador “B” faz ao enviar seu “update”

    ao roteador “C”(que é aquele caso das redes descontíguas que o edsonsiqueira citou no “post” 22):

    Tomemos como exemplo a subrede 10.1.2.0/24. O roteador “C” faz a seguinte pergunta:

    A subrede 10.1.2.0/24 faz parte da mesma rede “clasfull” que a subrede atribuída à interface de origem do update? Ou seja, 10.0.0.0/8 é igual a 172.16.0.0/16?

    Não – O roteador “B” então sumariza a subrede 10.1.2.0/24 e anuncia a rede 10.0.0.0/8 ao roteador “C”
    Sim – Embora não seja o caso do desafio, se a resposta tivesse sido sim, a subrede não seria sumarizada e seria anunciada como 10.1.2.0/24

    Vejamos agora o que o roteador “C” faz ao receber o “update” com a rede do 10.0.0.0/8 roteador “B”:

    As seguintes perguntas são feitas:

    A rede 10.0.0.0/8 faz parte da mesma rede “classfull” que a subrede atribuída à interface que recebe o “update”? Ou seja, 10.0.0.0/8 é igual a 172.16.0.0/16?

    Não – Passar para a próxima pergunta.
    Sim – Não é o caso do desafio, mas se fosse, o roteador “C” aplicaria a mesma máscara do “update” (que seria aquela máscara constante em toda a rede de que falamos)

    Próxima pergunta: Alguma subrede dessa rede “classfull” já existe na tabela de roteamento do roteador “c”? Ou seja Existe alguma subrede de 10.0.0.0/8 na tabela de roteamento do roteador “C”?

    Sim – O “update” é descartado. Esse é o caso do nosso desafio!
    Não – O roteador “c” aplica a máscara “classfull” da rede.

    Deste modo, na tabela de roteamento do roteador “c” teríamos as seguintes subredes: 172.16.1.0/24 e 10.1.3.0/24.

    Seguindo raciocínio análogo, vejamos o que aconteceria com os updates do roteador “c” ao roteador “D”. Desta vez, vamos responder apenas as perguntas relacionadas com o desafio:

    Roteador “C” enviando update para a subrede 10.1.3.0/24:

    10.0.0.0/8 é igual a 10.0.0.0/8?
    Sim – A subrede não é sumarizada e é anunciada como 10.1.3.0/24

    Roteador “C” enviando update para a subrede 172.16.1.0/24:

    10.0.0.0/8 é igual a 172.16.0.0/16?
    Não – O roteador “C” então sumariza a subrede 172.16.1.0/24 e anuncia a rede 172.16.0.0/16 ao roteador “D”

    Roteador “D” recebendo update para a subrede 10.1.3.0/24 (nesse caso exemplo mantido apenas para maior clareza, visto que a subrede 10.1.3.0/24 está diretamente conectada ao roteador “D” e já faria parte de sua tabela de roteamento de qualquer maneira)

    10.0.0.0/8 é igual a 10.0.0.0/8?
    Sim – A rede é recebida como 10.1.3.0/24, mantendo a máscara constante na rede

    Roteador “D” recebendo update para a rede 172.16.0.0/16:

    172.16.0.0/16 é igual a 10.0.0.0/8?
    Não.
    Existe alguma subrede de 172.16.0.0/16 na tabela de roteamento do roteador “D”?
    Não – A rede é recebida como 172.16.0.0/16.

    Ufa! Finalmente, a tabela de roteamento do roteador “D” possui então as seguintes redes/subredes:
    10.1.3.0/24
    10.1.4.0/24
    172.16.0.0/16

    Mas a pergunta não foi qual seria a tabela de roteamento do roteador “D”, e sim quais as redes que constarão no update originado

    pelo Router “D”, na direção apresentada na figura. Nesse caso, como os protocolos “classfull” são do tipo “distance vector” (pelo

    menos os que eu conheço), eles enviam em seu “update” sua tabela de roteamento completa. Portanto, o “update” será composto pelas

    redes/subredes acima.

    Acho que é isso!

    Quem tem facilidade com o inglês pode consultar:
    http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080093fd6.shtml

    0

    0
  32. Daniel Melo

    Marcos,

    quando vc vai colocar a resposta certa ou quem respondeu corretamente ?
    tou querento tirar minha duvida sobre esta questão !

    abraço

    0

    0
  33. ihelena

    Oi,

    No roteador D a tabela de roteamento indica as redes direatamente conectadas 10.1.3.0 e 10.1.4.0 e mais as que recebe através do RIP que é apenas a rede 172.16.0.0.

    Isso ocorre , acho eu, devido a como o RIP processa as atualizações de roteamento recebidas:

    – se a atualização recebida e a interface que a recebe estão na mesma rede -> é aplicada a mascara de subrede da interface
    – se a atualização recebida e a interface que a recebe estão em redes diferentes -> é aplicada a mascara classful

    Desta forma as redes 10.1.2.0 e 10.1.1.0 não chegam ao roteador D pois na interface de C já são bloqueadas passando como 10.0.0.0.

    Acho que é isso.
    []’s

    0

    0
  34. ihelena

    Oi,

    Respondendo a pergunta (que esqueci de colocar na explicação no item 32) o roteador D só anunciará :

    172.16.1.0 (recebida via RIP), 10.1.3.0 e 10.1.4.0 (Diretamente conectadas)

    []’s
    Iracy

    0

    0
  35. gabrielsouzafatec

    Boa noite pessoal, segue a configuração do router d, show ip route e os ping feitos para as redes do desafio. Fiz a topologia com rip v1 sem o comando “no auto-summary”, encontrei as seguintes redes propagadas que estão na tabela de roteamento. Um abraço a todos.

    d#show running-config
    Building configuration…

    Current configuration : 543 bytes
    !
    version 12.2
    no service password-encryption
    !
    hostname d
    !
    !
    !
    !
    !
    ip ssh version 1
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/0
    ip address 10.1.3.1 255.255.255.0
    encapsulation ppp
    clock rate 56000
    !
    interface Serial0/1
    ip address 172.16.1.2 255.255.255.0
    encapsulation ppp
    !
    router rip
    version 1
    network 10.0.0.0
    network 172.16.0.0
    !
    ip classless
    !
    !
    !
    !
    !
    line con 0
    line vty 0 4
    login
    !
    !
    end

    d#show ip route
    Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
    D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
    N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
    E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
    i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
    * – candidate default, U – per-user static route, o – ODR
    P – periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 2 subnets
    C 10.1.3.0 is directly connected, Serial0/0
    R 10.1.4.0 [120/1] via 10.1.3.2, 00:00:14, Serial0/0
    172.16.0.0/24 is subnetted, 1 subnets
    C 172.16.1.0 is directly connected, Serial0/1

    d#ping 10.1.1.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
    …..
    Success rate is 0 percent (0/5)

    d#ping 10.1.2.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
    …..
    Success rate is 0 percent (0/5)

    d#ping 10.1.3.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.3.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 47/59/63 ms

    d#ping 10.1.4.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.4.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 31/31/32 ms

    d#ping 172.16.1.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 31/31/32 ms

    d#ping 172.16.1.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 62/62/63 ms

    d#ping 10.1.1.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
    …..
    Success rate is 0 percent (0/5)

    d#ping 10.2.1.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.2.1.2, timeout is 2 seconds:
    …..
    Success rate is 0 percent (0/5)

    d#ping 10.1.3.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.3.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 31/31/32 ms

    d#ping 10.1.4.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.4.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 47/59/63 ms

    0

    0
  36. Fábio Conceição

    Não se trata das networks que o router D tem alcançabilidade, mas sim da(s) network(s) que ele vai anunciar pela interface em questão.

    0

    0
  37. ecarli

    O router D somente anunciará, na direção questionada, a rede 172.16.0.0/16. A grande pegadinha desta pergunta é o fato de ambos os roteadores B e C serem o que se chama de “edge routers”, quando se trata de roteamento classful. Se considerados os protocolos de roteamento clássicos classful, RIPv1, RIPv2 ou IGRP, deve-se ter em mente o conceito de split-horizon: um router NAO anuncia uma rota por uma interface se esta mesma rota é APRENDIDA pela mesma interface.

    Essa questão deve levar em consideração o sentido OPOSTO ao colocado no desenho. Lembrem-se que os roteadores também divulgam suas redes no sentido oposto.

    Assim, o router B e C, por serem router edge, ou seja, são a fronteira entre 2 major networks, irão divulgar a rede 10.0.0.0/8 (no caso B -> C e C -> B) e TAMBÉM recebem a rede 10.0.0.0/8 anunciadas pelo seu peer. O split-horizon neste momento faz com que tanto B quanto C deixem de anunciar a rede 10.0.0.0/8.

    Desta maneira, na direção questionada, o router C somente anuncia a rede 172.16.0.0./16 para o router D, e será isso que o router D colocará em seu update na direção mostrada pelo desenho.

    P.S: Estou vendo esse desafio somente agora… Não sei se alguem antes respondeu corretamente essa pergunta com essa justificativa.

    Grande abraço a todos,
    Emerson

    0

    0
  38. ecarli

    Esqueci da rede 10.1.3.0/24. Na realidade para o update gerado no router D no sentido em questão, este router também anunciará a rede 10.1.3.0/24 pois é uma rede diretamente conectada e faz parte da mesma rede classful. Como ambas as interfaces do router D estão na mesma major network, 10.0.0.0/8, não haverá a auto-sumarização neste caso.

    Portanto, a resposta correta de anúncio para o ROUTER D no sentido em questão são:

    Redes 172.16.0.0/16 E 10.1.3.0/24.

    Abraços,
    Emerson

    0

    0
  39. Thiago Moreira

    Senhores,

    A resposta para este caso é :

    R 10.0.0.0/8 [120/1] via 192.168.254.1, FastEthernet0/0
    R 172.16.0.0/16 [120/3] via 192.168.254.1, FastEthernet0/0

    A justificativa para esta resposta, se obtem da seguinte forma.

    Foi utilizado 6 roteadores operando com o protocolo de roteamento RIP versão 1 (protocolo no qual opera com roteamento baseado em classes de rede).

    O primeiro roteador A possui uma rede de entrada com o enderamento 10.1.1.0/24, logo para simular esta rede foi criada uma Loopback0 (rede diretamente conectada) e seu enderamento para redistruição no protocolo RIPv1.

    A segunda rede diretamente conectada ao roteador A com enderaçamento 10.1.2.0/24 no qual faz interconexão com o roteador B, também foram divulgadas no processo de redistribuição do protocolo RIPv1, logo a configuração do protocolo RIP será:

    router rip
    version 1 (versão que opera em classfull)
    network 10.0.0.0 (as duas sub-redes /24 pertencem a este endereçamento de Classe A)

    No segundo roteador B, as sub-redes 10.1.2.0/24 e 172.16.1.0/24 no qual são redes diretamente conectadas ao roteadores A e C, também foram divulgadas no processo de redistribuição do protocolo RIPv1, logo a configuração do protocolo RIP será:

    router rip
    version 1
    network 10.0.0.0
    network 172.16.0.0 (devido o protocolo RIPv1 operar com roteamento baseado em classes, a sub-rede 172.16.1.0/24 pertence a classe B, logo a mascara /16 na divulgacao da rede no protocolo).

    No terceiro roteador C, as sub-redes 10.1.3.0/24 e 172.16.1.0/24 no qual são redes diretamente conectadas ao roteadores B e D, também foram divulgadas no processo de redistribuição do protocolo RIP V1, logo a configuração do protocolo RIP será:

    router rip
    version 1
    network 10.0.0.0 (enderamento da sub-rede 10.1.3.0/24 pertence a classe A, logo a utilização da máscara /8 na divulgacao da rede no protocolo RIPv1)
    network 172.16.0.0

    No quarto roteador D, existem duas sub-redes diretamente conectadas. Uma petence a sub-rede 10.1.3.0/24 no qual faz interconexão ao roteador C e uma segunda sub-rede 10.1.4.0/24 no qual foi configurado um quinto roteador denominado E que estara recebendo a divulgação da redes através do protocolo RIPv1 dos outros enderamentos já informados anteriormente que estão fazendo parte da tabela de roteamento do protocolo RIP.

    Obs:. Foi criado uma sub-rede 192.168.254.0/30 fora do LAB somente para realizar a interconexão entre os roteadores E e F. Em si, esta rede será capaz de realizar a continuidade do processo de divulgação das redes já redistribuidas no protocolo RIPv1.

    A B C D E

    Logo a configuração do protocolo RIP do roteador E será:

    router rip
    version 1
    network 10.0.0.0
    network 192.168.254.0

    Enfim, no roteador F haverá todas as redes divulgas pelo roteadores A B C D excluindo a rede diretamente conectada entre os roteadores E e F.

    Logo saída da tabela de roteamento de F será:

    Router_F#show ip route rip
    R 10.0.0.0/8 [120/1] via 192.168.254.1, FastEthernet0/0
    R 172.16.0.0/16 [120/3] via 192.168.254.1, FastEthernet0/0

    Obs: Apesar da sub-rede 192.168.254.0/30 fazer parte do processo de redistribuição para o protocolo RIP, ela não ira para tabela de roteamento devido a distância administrativa de uma rede diretamente conectada ser 0 melhor que uma rede conhecida pelo protocolo RIP no qual é 120.

    Porém na tabela do protocolo RIP ele existira como pode ser visto abaixo:

    Router_F#show ip rip database
    10.0.0.0/8
    [1] via 192.168.254.1, 00:00:21, FastEthernet0/0
    172.16.0.0/16
    [3] via 192.168.254.1, 00:00:21, FastEthernet0/0
    192.168.254.0/30 directly connected, FastEthernet0/0

    Espero ter sido o mais claro possível e objetivo sobre este caso.

    0

    0
  40. Marco Filippetti

    Pessoal, por incrivel que pareça, identifiquei poucas respostas corretas até o momento. 😉 Mais adiante posto a resposta e o vencedor!

    Abs!

    Marco.

    0

    0
  41. rrios

    De acrodo com a pergunta: Quais as redes que constarão no update originado pelo Router “D”, na direção apresentada na figura?
    Resposta:
    10.1.3.0
    172.16.0.0

    Concorme dito pelo Emerson anteriormente, “A regra de split horizon baseia-se na teoria segundo ao qual não é útil enviar de volta informações sobre uma rede na direção de sua origem” Portanto segundo a pergunta o as redes que serão anunciadas no Update originado pelo router “D” na direção representada na figura, são as já citadas.

    A rede 10.1.4.0 não será anunciada nesta direção devido a regra split horizon.

    0

    0
  42. NOC

    Apenas a 10.1.3.0/24

    Trata – se de uma rede não-contígua, pois os pares de sub-redes (10.0.0.0/8)devem passar por uma sub-rede de uma rede classful diferente (172.16.0.0/16).

    A sumarização automática impede que uma rede com uma rede não-contígua funcione de forma correta e protocolos de roteamento classful não permitem sumarização manual, ou seja, não há como setar a não utilização de sumarização automática

    Pacotes enviados da sub-rede 10.0.0.0 da esquerda para a direita tem que passar através da sub-rede 172.16.0.0, o que não ocorre neste caso. Então o Router D anuncia apenas a sub-rede de sua enlace com o Router C (10.1.3.0/24)

    O ideal seria utilizar um protocolo de roteamento classless sem sumarização automática

    0

    0
  43. Marco Filippetti

    Pessoal, o vencedor deste desafio e ganhador do Livro CCNA 4.1 é o EDSONESF (aprendiz)! Seu comment (#10) foi o mais correto e melhor explicado dentre os primeiros e, portanto, ele sagrou-se o grande vencedor. Parabéns Edson! Depois entro em contato!

    Para quem quiser saber mais sobre esta característica dos protocolos CLASSFUL, aconselho o link abaixo:

    http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080093fd6.shtml

    Abs!

    0

    0
  44. Edson

    🙂

    0

    0
  45. humbertorps

    Segundo o Marco o Post 10 teria a resposta correta. Neste post o Edson fala que a resposta seria:

    “Ou seja, o Router D vai anunciar a rede 172.16.0.0/16 e 10.1.3.0/24.”

    Fiz na mão e a resposta deu diferente. Fui então confirmar no PT. Acho que o erro foi basear a resposta em um suposto router E e no comando show ip route. A pergunta é o que conteria o pacote de update do Router D para a rede 10.1.4.0/24.

    Configurei uma interface loopback no roteador D com o endereço 10.1.4.1/24

    Depois dei o comando router ip rip

    A resposta correta pode ser visualizada na saída do comando abaixo:

    RIP: sending v1 update to 255.255.255.255 via Loopback0 (10.1.4.1)
    RIP: build update entries
    network 10.0.0.0 metric 3
    network 10.1.3.0 metric 1
    network 172.16.0.0 metric 2

    Logo ele envia como UPDATE D> em direção a rede 10.4.1.0/24 as seguintes redes: 10.0.0.0/8, 10.1.3.0/24 e 172.16.0.0/16

    Um abraço!

    0

    0

Deixe uma resposta