«

»

jun 20 2011

Lab OSPF Troubleshooting

Pessoal, temos hoje um Lab para prática de Troubleshooting sobre OSPF. O cenário é bem simples com apenas dois roteadores e dois hosts.
O objetivo é fazer com que as duas maquinas cliente, host A e host B, em redes distintas se comuniquem.

O primeiro arquivo mostra a rede funcionando, com a comunicação ocorrendo entre os hosts, servindo de base para a resolução dos outros dois cenarios que seguem com a mesma topologia mas sem comunicação entre os hosts.

Não trataremos a teoria por trás do funcionamento do protocolo, já temos um ótimo tutorial em 6 partes sobre OSPF aqui no blog, então mãos a obra. Lembrando que no OSPF estamos trabalhando apenas com área 0, e todas as senhas para acesso aos equipamentos é cisco.

Bem galera, por hoje é só e divirtam-se.

Lab OSPF Ok

Lab OSPF TSHOOT 1

Lab OSPF TSHOOT 2

Ramon Lauro



Comente usando o Facebook!
0
0

20 comentários

Pular para o formulário de comentário

  1. Marco Filippetti

    Pessoal, este é o primeiro post do Ramon. O Ramon me perguntou se poderia ajudar escrevendo posts de TS para o blog, e achei interessante a idéia. Vejam o que acham e se ele passa no teste 🙂

    Obrigado Ramon!

    Marco.

    0

    0
  2. rpedrosa1979

    Parabens pela iniciativa do Ramon.

    0

    0
  3. lyon

    Parabéns pela iniciativa!!!
    O link do – Lab OSPF TSHOOT 1 – com problema, apenas o admin que pode acessar o link.

    Abs!

    0

    0
  4. lyon

    Resolução do Lab OSPF TSHOOT 2

    1º Passo:
    Verificação de endereçamento ip dos routers (FastEthernet), pcs e comunicação com o gateway, tudo ok.
    Verificação de endereçamento ip dos routers (serial) e a comunicação entre eles:
    IP errado:
    SPO serial s0/0/0 172.16.0.5/30
    RJO serial s0/0/0 172.16.0.1/30
    Configurado:
    SPO serial0/0/0 172.16.0.2/30
    Agora a comunicação esta ok.
    Aqui também podemos chegar a conclusão, já que a houve comunicação, que o protocolo WAN (PPP nesse caso) e o clock rate estão configurados corretamente.
    Uma observação aqui, é que no router SP0 o bandwidth esta configurado com 128000. Na comunicação não deve ocorrer problemas, mas o OSPF irá calcular o custo errado, pois não é essa banda disponível no link.
    RJ0 – clock rate 128000 (bits por segundo).
    SP0 – bandwidth 128000 (kilobits por segundo).
    Alterado o bandwidth do SP0 para 128.

    2º Passo:
    Verificação das configurações do OSPF:
    Anúncio na área errada do RJ0
    network 192.168.0.0 0.0.0.255 area 100
    network 172.16.0.0 0.0.0.3 area 100
    Configurado:
    no network 192.168.0.0 0.0.0.255 area 100
    no network 172.16.0.0 0.0.0.3 area 100
    network 192.168.0.0 0.0.0.255 area 0
    network 172.16.0.0 0.0.0.3 area 0

    Adiconado na configuração do OSPF do SP0.
    network 10.0.0.0 0.0.0.255 area 0

    As máquinas estão se comunicando.
    Bom, foi isso que consegui encontrar.

    0

    0
  5. Fernando Avelino

    Valeu pelo lab, em casa vou abrir. abs

    0

    0
  6. Sérgio F.S

    lyon,

    Observe as configurações TCP/IP do host B. Há uma inconsistência lá, e isso impedirá a comunicação entre os hosts 😉

    Abraços.

    0

    0
  7. lyon

    Sérgio,

    Realmente, não tinha notado isso. Não me preocupei com isso pois quando testei a comunicação com ping, deu ok.
    Vamos ver se aparece mais coisas… hehehe

    Abs!

    0

    0
  8. Marcos

    Ramon, só tem que tomar cuidado com os detalhes, vi os detalhes que o lyon comentou e verifiquei o erro também parte do IP errado, aqui foi usado o segundo intervalo (172.16.0.5/30) para SPO serial s0/0/0 e o primeiro intervalo (s0/0/0 172.16.0.1/30) RJO serial , fazendo que os routers não se comuniquem. Só lembrando o Marco faz um comentário no seu livro (OSPF pode causar dor de cabeça se não for bem implementado).

    Take care. Meus parabéns pela iniciativa também.

    0

    0
  9. lyon

    Resolução do Lab OSPF TSHOOT 1

    Verificação de endereçamento ip dos routers (FastEthernet), pcs e comunicação com o gateway.
    HOST A – Não estava configurado o gateway.
    Configurado 192.168.0.1.

    HOST B – Cabo de rede estava conectado na porta f0/1 do router.
    Colocado o cabo na f0/0 do router.

    SP0 – Estava com o cabo serial na int s0/1/0.
    Colocado na s0/0/0

    Retirado bandwidth 128000 da s0/0/0 do RJ0 (DCE).
    Alterado bandwidth de 128000 para 128 da s0/0/0 do SP0 (DTE).

    Agora a comunicação esta ocorrendo.

    Abs!

    0

    0
  10. ferrugem

    Marcos Vieira, a intenção realmente foi postar com erros. Não entendi o seu comentário. 😉

    O objetivo é que seja feito o Troubleshooting dos cenários propostos, identificando o que está errado.

    Abs e valeu pela colaboração Ramon!
    Felipe Ferrugem

    “Juntos somos ainda melhores!!!”

    0

    0
  11. Marcos

    Valeu ferrugem, li muito rapido, más mesmo assim parabéns para o Ramon, como você comenta “Juntos somos ainda melhores!!!”

    0

    0
  12. Sérgio F.S

    Esqueci de agradecer pelos Labs e iniciativa. Valeu Ramon. E claro, o espaço disponibilizado pelo Marco.

    Afinal de contas, dificilmente alguém para um pouco para montar um lab de testes, normalmente só fazemos isso quando estamos estudando para alguma certificação ou testes para implementação.

    Abraços.

    0

    0
  13. vmosconi

    Gostei… acho q deveria ter mais Tshoot… adoro esta area

    0

    0
  14. KimRondon

    Show Lyon… Galera, se esse desafio foi mais tranquilo, acho que o próximo será mais casca grossa hehehehe

    0

    0
  15. vmosconi

    podia ter um com varios protocolos, dhcp, vlan, e subnets a vontade.

    0

    0
  16. Eliseu

    Bom post… pode colocar mais TS para nós!

    0

    0
  17. rpedrosa1979

    Já passei para o pessoal aki no banco que está começando agora….
    Parabens pela iniciativa ..

    0

    0
  18. roboxtz

    Bom,Lab OSPF Tshoot 2 resolvido,vou para o 1,somente funcionou o LAB depois que eu removi o processo OSPF não bastou ter trocado os mismatch de areas.

    0

    0
  19. roboxtz

    Lab 1 também resolvido

    0

    0
  20. fssantana

    Pessoal fiz os labs somente hj, gostei sim.
    Não vi a necessidade de criar mais de uma area !

    abraços

    0

    0

Deixe uma resposta