«

»

dez 12 2012

Uma verdadeira rede doméstica – estudo de caso

Olá pessoal, não é novidade que eu seja um apaixonado por redes e tecnologia. E como tal, sempre arrumo uma forma de complicar algo para torná-lo simples 🙂 Explico: Até recentemente, a banda larga que eu usava em casa era provida pelo meu condomínio. Um acesso NET Virtua de 10 Mbps condominial, compartilhado com os outros moradores do meu prédio. No meu apartamento tem uma tomada RJ-45 onde eu ligava meu roteadorzinho WiFi e pronto. Tinha BL para todos os aparelhos aqui em casa. A velocidade – mesmo sendo compartilhada – era muito boa.

Algumas vezes a banda chega a alcançar seu limite. Mas, na média, fica em torno de 2,5 Mbps. Não é péssimo, mas o sofrível mesmo é o UP, e não o DOWN. Fica na casa dos 150 Kbps – muito ruim para quem, como eu trabalha na contra-mão dos dados (mais envio que recebo) E, além disso, o serviço é compartilhado, ou seja, o SLA não é dos melhores. Abaixo, o teste que fiz agora com o serviço, usando a rede da Oi como destino.

virtua.jpg

Como tenho trabalhado MUITO de casa, precisava de algo mais confiável. A ideia era contratar um serviço de BL e manter o do condomínio como backup. E assim o fiz. A TIM veio oferecer o serviço “Live” no meu prédio, com uma oferta de 50 Mbps por apenas R$50/mês (sem multa, taxa de adesão ou fidelidade). Este preço é válido até Junho de 2014, quando deve sofrer um ajuste. Não pensei duas vezes, fechei com eles. Na semana seguinte, instalaram, e a qualidade me surpreendeu muito. Abaixo, os resultados colhidos (observem que o teste parte da rede da Intelig, com destino à rede da Oi)

timlive.jpg

Muito bom, não? Problema resolvido… em parte! A questão agora é: Como deixar o link condominial como o backup? Se eu fosse uma pessoa normal ( 🙂 ), simplesmente deixaria o cabo Ethernet do link do prédio ao lado do roteadorzinho WiFi que uso e, em caso de “pane” no link da TIM, desconecto o cabo de um e conecto o de outro. Mas… eu não sou um cara normal 🙂 ! Fazendo uma pequena análise, concluí que esta técnica até funcionaria, mas com algumas implicações:

  1. O tempo de recuperação do serviço (sim, sou neurótico) seria muito maior neste cenário “manual”
  2. Fazer desta forma não tem graça nenhuma (sim, sou MESMO louco!)!

Meu objetivo, então, era estruturar uma rede doméstica com os seguintes requisitos:

  • Ambas as redes devem ser conectadas simultaneamente, sendo que a BL TIM seria usada como link primário, e o NET Virtua do condomínio como link backup
  • Deve ser possível selecionar algumas redes destino para usarem um link específico (ex: Todo o tráfego Facebook iria pelo link NET Virtua)
  • Os elementos domésticos devem continuar acessíveis entre si (ex: Tenho um WDTV Live Hub na sala ligado à rede WiFi, e eu gostaria de seguir enxergando-o do meu tablet / smart TV / notebook / desktop)
  • O chaveamento entre os links deve ser feito de forma totalmente automatizada (sem mesmo que eu ou outro usuário da rede – meu cão, por exemplo – notasse)
  • A solução deve suportar endereçamento dinâmico (DHCP) nas portas com as operadoras do serviço BL, e ser capaz de fazer NAT para ambos os links

Estava claro que eu precisaria comprar um roteador para fazer tudo isso. Um roteador decente, profissional. Eu tinha ouvido falar que uma tal de Cisco fabricava alguns destes ( 😉 ), e saí para procurar. Encontrei no Mercado Livre – claro, onde mais? – um Cisco 1841 por uma merreca de R$370. Comprei-o. Mas ainda estava com um problema. Este Cisco tinha apenas 2 portas Ethernet. Eu precisava de pelo menos 3 para a minha solução mirabolante (1 para cada link BL e 1 para a minha LAN). Bom, procurei no ML e encontrei um módulo HWIC-4ESW por R$350. Comprei-o também (a solução não saiu muito barata, como podem ver). Então, eu tinha o roteador Cisco, o roteador WiFi, as conexões e a vontade de fazer.

Abaixo, os elementos envolvidos:

1841setup.jpg

O diagrama da solução ficou assim:

homelab.jpg

Faltava agora por a massa cinzenta para funcionar e ver como eu faria para resolver todos os problemas colocados. Para identificar a queda do link primário, não bastava olhar a interface no roteador, pois o link da TIM poderia cair antes e a porta Fast Ethernet do meu roteador continuaria UP/UP. Eu precisava monitorar um IP que estivesse na Internet. Quando este não estivesse acessível via link da TIM, a condição de acessibilidade seria alterada e uma ação tomada. Para implementar algo assim, usamos IP SLA (veja um post sobre o assunto aqui). O IP escolhido foi 4.2.2.1.

Havia também a questão do NAT. Haveria uma interface NAT INSIDE (VLAN 10), mas DUAS NAT OUTSIDE. A questão, então, era como fazer o roteador entender que, mesmo que a interface primária estivesse UP, isso não significaria que o tráfego deveria ser nateado para ela (caso do link da TIM cair e a porta Fast seguir UP). Isso foi resolvido com o artifício de route-maps.

Assim, a rede ficou desta forma: Para a LAN (cabeada ou WiFi)  foi alocada a subrede 192.168.100.0 /25, que é servida via DHCP no Linksys E2500 para os elementos cabeados ou sem-fio. A conexão entre o Linksys e o 1841 foi feita via endereçamento estático ponto-a-ponto (192.168.100.129 no linksys e 192.168.100.254 no 1841). Alguns vão perguntar “mas por que não usou um /30 aí?”. A resposta é: “Porque não!” 🙂

Abaixo, as configs usadas no 1841.

version 15.1
!
hostname maf0001.rtr.spo
!
interface FastEthernet0/0
 description TIM LIVE 50M
 ip dhcp client default-router distance 100
 ip address dhcp
 ip nat outside
!
interface FastEthernet0/1
 description NET VIRTUA 10M
 ip dhcp client default-router distance 50
 ip address dhcp
 ip nat outside
!
interface FastEthernet0/0/0
 description INTERFACE LINKSYS E2500
 switchport access vlan 10
 no ip address
!
interface Vlan10
 description VLAN P2P ROUTER WIFI
 ip address 192.168.100.254 255.255.255.128
 ip nat inside
!
ip nat inside source route-map NET interface FastEthernet0/1 overload
ip nat inside source route-map TIM interface FastEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 192.168.200.1 track 1
ip route 0.0.0.0 0.0.0.0 172.16.1.1 50
ip route 0.0.0.0 0.0.0.0 192.168.200.1 100
ip route 4.2.2.1 255.255.255.255 FastEthernet0/0 192.168.200.1
ip route 192.168.100.0 255.255.255.128 192.168.100.129
!
ip sla 1
 icmp-echo 4.2.2.1 source-interface FastEthernet0/0
 threshold 1000
 timeout 1000
 frequency 2
ip sla schedule 1 life forever start-time now
!
track 1 ip sla 1 reachability
!
access-list 1 permit 192.168.100.0 0.0.0.127
!
route-map TIM permit 10
 match ip address 1
 match interface FastEthernet0/0
!
route-map NET permit 10
 match ip address 1
 match interface FastEthernet0/1
!
end

E aqui, um exemplo operacional:

Rotas quando o link principal está ativo. Default gateway via 192.168.200.1 (interface F0/0 – conexão TIM Live 50M)

maf0001.rtr.spo#sh ip route

Gateway of last resort is 192.168.200.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.200.1, FastEthernet0/0
      4.0.0.0/32 is subnetted, 1 subnets
S        4.2.2.1 [1/0] via 192.168.200.1, FastEthernet0/0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/1
L        172.16.1.113/32 is directly connected, FastEthernet0/1
      192.168.100.0/24 is variably subnetted, 3 subnets, 2 masks
S        192.168.100.0/25 [1/0] via 192.168.100.129
C        192.168.100.128/25 is directly connected, Vlan10
L        192.168.100.254/32 is directly connected, Vlan10
      192.168.200.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.200.0/24 is directly connected, FastEthernet0/0
L        192.168.200.105/32 is directly connected, FastEthernet0/0

Aqui, o que acontece quando eu retiro a linha telefônica do modem VDSL. A condição de conectividade é alterada (router não consegue mais acessar o IP 4.2.2.1 via interface F0/0).

maf0001.rtr.spo#
*Dec 12 12:52:20.417: %TRACKING-5-STATE: 1 ip sla 1 reachability Up->Down

Assim, a rota default via link TIM Live é retirada da tabela e entra a rota via NET Virtua (172.16.1.1) automaticamente:

maf0001.rtr.spo#sh ip route

Gateway of last resort is 172.16.1.1 to network 0.0.0.0

S*    0.0.0.0/0 [50/0] via 172.16.1.1
      4.0.0.0/32 is subnetted, 1 subnets
S        4.2.2.1 [1/0] via 192.168.200.1, FastEthernet0/0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/1
L        172.16.1.113/32 is directly connected, FastEthernet0/1
      192.168.100.0/24 is variably subnetted, 3 subnets, 2 masks
S        192.168.100.0/25 [1/0] via 192.168.100.129
C        192.168.100.128/25 is directly connected, Vlan10
L        192.168.100.254/32 is directly connected, Vlan10
      192.168.200.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.200.0/24 is directly connected, FastEthernet0/0
L        192.168.200.105/32 is directly connected, FastEthernet0/0

Quando restauro a conexão com a linha telefônica, a condição de conectividade é reestabelecida:

maf0001.rtr.spo#
*Dec 12 12:54:00.425: %TRACKING-5-STATE: 1 ip sla 1 reachability Down->Up

E o link primário (TIM Live) volta a ser usado (default gateway volta a ser 192.168.200.1)

maf0001.rtr.spo#sh ip route

Gateway of last resort is 192.168.200.1 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.200.1, FastEthernet0/0
      4.0.0.0/32 is subnetted, 1 subnets
S        4.2.2.1 [1/0] via 192.168.200.1, FastEthernet0/0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, FastEthernet0/1
L        172.16.1.113/32 is directly connected, FastEthernet0/1
      192.168.100.0/24 is variably subnetted, 3 subnets, 2 masks
S        192.168.100.0/25 [1/0] via 192.168.100.129
C        192.168.100.128/25 is directly connected, Vlan10
L        192.168.100.254/32 is directly connected, Vlan10
      192.168.200.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.200.0/24 is directly connected, FastEthernet0/0
L        192.168.200.105/32 is directly connected, FastEthernet0/0

Para fechar, a foto final (sim, o cabeamento ainda está zoneado, mas prometo que vou arrumar depois!!!).

final.jpg

Ah, e podem me chamar de NERD, mas sou um NERD com uma verdadeira rede doméstica, agora 🙂

Espero que tenham curtido!

Marco.



Comente usando o Facebook!
0
0

40 comentários

Pular para o formulário de comentário

  1. nelsonjr

    Esse é o mau de ficar longe desse mundo =\.
    Saudades++

    Marco uma pergunta, as linhas abaixo foram duplicadas de proposito mesmo?
    Qual o motivo?

    ip route 0.0.0.0 0.0.0.0 172.16.1.1 50
    ip route 0.0.0.0 0.0.0.0 172.16.1.1 50
    ip route 0.0.0.0 0.0.0.0 192.168.200.1 100
    ip route 0.0.0.0 0.0.0.0 192.168.200.1 100

    Gostei da solução.

    0

    0
  2. Marcelo Melo

    Massa Marco, fiquei com a mesma dúvida do nelsonjr.

    0

    0
  3. Bruno Felipe

    Show de bola Marco!!

    0

    0
  4. Marco Filippetti

    Nelson / Marcelo,

    Estas entradas são automaticamente colocadas pelo DHCP. São os default-gateways enviados pelo DHCP por cada uma das interfaces. Observem que eu alterei a métrica deles para que o default gateway da NET seja o preferido (50) sobre o da TIM (100) em caso de uso exclusivo das rotas aprendidas pelo DHCP, ou seja, se o IP SLA acusar falha, a rota primária para a TIM (ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 192.168.200.1 track 1) sairá da tabela e entrará a da TIM com peso 50.

    0

    0
  5. Marco Filippetti

    A questão de estarem duplicadas as rotas, foi um erro de copy & paste, acabei de corrigir 🙂

    0

    0
  6. Marcelo Conterato

    Poderia chamar de Alta Disponibilidade Residencial hehehe. Ótimo post!

    0

    0
  7. Gustavo Ruas Naves

    Ótimo post e solução.

    0

    0
  8. KimRondon

    achei mt foda.. hehehe

    0

    0
  9. Karl Frederick

    Achei bacana a vitrola ali do lado.rsrsrs

    0

    0
  10. Gustavo Ruas Naves

    Pelo que vi é uma Technics MKII. Curti.

    0

    0
  11. Marco Filippetti

    Sim, é uma MKII mesmo 🙂

    0

    0
  12. Rodrigo C. Soave

    AS | IP | AS Name
    3356 | 4.2.2.1 | LEVEL3 Level 3 Communications

    0

    0
  13. r_hama

    Boaaa Marco,
    Pode ter certeza que com as Lan to Lans, esta solução de ip sla está sendo muito usada nas corporações. rsrsrsrs.
    abçs.

    0

    0
  14. vmosconi

    eu pensei em fazer o mesmoem casa…

    e estava de olho em um cisco 831 . custa 200 reais e nao tem nenhum ruido.

    MArco Seria possivel fazer em vez de IP Sla usar VRRP ou HSRP monitorando via icmp um ip externo como um dns publico? (8.8.8.8)?

    0

    0
  15. Marco Filippetti

    Mosconi, o problema de HSRP ou VRRP é que você vai ter que encontrar um router DSL E um Cable Modem que suportem isso (se a rede for igual a minha). As chances disso acontecer são ZERO ;-). Já comprei o 1841 porque sabia que roteadores menores não dariam suporte a IP SLA da forma como eu precisava. E ainda assim, tive de fazer upgrade do IOS dele para enterprise para funcionar.

    0

    0
  16. Otavio.Prado

    Muito bom ficou, não és só você um nerd feliz.

    parabéns

    0

    0
  17. diego.dias

    Marco, muito bacana a solução (e o post) … tenho o mesmo problema da alta (falta) disponibilidade de trabalhar remoto !!! Seguirei o seu desenho para melhorar os serviços aqui em casa! ;P

    Parabéns pelo Blog!

    0

    0
  18. Alexandre Lima

    Como diz o ditado: em casa de ferreiro o espeto é de pau…opss… Mas não com o Marco.
    Show de bola. Otimo post e otima solução!!
    Mas com tudo isso, será que é interessante monitorar os links e ver se vai ocorrer a comutação do trafego, quando existir tal queda de algum link… ou é complicar a situação ?

    0

    0
  19. charlesrocha

    Vamos montar uma comunidade NERDS MANIACOS kkkkkkk show de bola marco na miinha queria house tenho o mesmo to correndo atras de router 1841 para ampliar.

    0

    0
  20. Edson Siqueira

    Marco,

    Muito bom o post, sei que fez isso com o desafio de usar um ‘roteador’ e aplicar configurações que serão úteis em vários ambientes profissionais. Se quisesse uma coisa mais simples e que atingisse o mesmo resultado de maneira satisfatória poderia usar um cisco RV-042, certo?

    Parabéns!!!

    Abcs,

    0

    0
  21. jorge.ff

    Pootz eu uso essa solução na empresa , o Marco usa em casa rss

    Abs

    0

    0
  22. jonas

    Bem bacana a solução !

    0

    0
  23. pablo

    Ola Marco,

    Gostaria de solicitar que o teste de velocidade fosse realizado pelo SIMET http://simet.nic.br para comparar o resultado com uma entidade aferidora neutra.

    Obrigado,
    Pablo

    0

    0
  24. lincolnboav

    Marco, não pude deixar de notar os livros perto do equipamento, o livro rede de computadores, o autor dele é o Andrew S. Tanembaum? esse livro é bom?

    Abraços!

    0

    0
  25. Marco Filippetti

    Lincoln, diria que é a bíblia das redes de computadores :-))

    0

    0
  26. Rodrigo Alves

    Marcão,

    Não sei qual a versão da IOS que você está utilizando, mas se for uma que suporte o uso de IP SLA com testes de URL da para melhorar sua solução testando um site confíavel, por exemplo o Google (acredito que seja mais confiavel do que o IP q vc esta testando). Exemplo abaixo.

    confi t
    ip name-server x.x.x.x ! primario
    ip name-server y.y.y.y ! secundario

    no ip sla 1
    ip sla 1
    http get http://www.google.com
    timeout 5000
    !
    ip sla schedule 1 life forever start-time now

    ip access-list extended HTTP_ROUTER
    permit tcp any any eq www
    !

    ! Route-map do tipo local para forçar o trafego oriundo do router a sair apenas pelo link da NET (primario)

    route-map LOCAL_POLICY permit 10
    match ip address HTTP_ROUTER
    set ip next-hop GW_NET
    !
    ip local policy route-map LOCAL_POLICY

    0

    0
  27. santos_ligeiro

    Excelente trabalho…. muito bom !!!

    0

    0
  28. rafaelcn

    Também uso essa solução na empresa

    0

    0
  29. Rafael

    Habilidade total. Show de bola.

    0

    0
  30. Flávio

    Marcão…você chegou a analisar o consumo de energia desse router?

    0

    0
  31. Marco Filippetti

    Máximo de 50W (isso com todos os módulos e portas sendo usados, o que não é meu caso). Está tudo aqui: http://www.cisco.com/en/US/prod/collateral/routers/ps5853/product_data_sheet0900aecd8016a59b.html

    0

    0
  32. lincolnboav

    Opa! então preciso de um livro desses hehe, valeu Marco! Abraços!

    0

    0
  33. claudiocjs

    Olá Marco, bom dia!
    Cara, após uma longa hora e quarenta minutos, consegui logar no seu blog. Isso mesmo, 1:40 min.!!! Bom, talvez esse não seja o espaço mais adequado para eu fazer esse “desabafo”, porém, já que o tema é rede doméstica, vou tentar…. Acredito que muitas pessoas vivam a situação que eu vivo, mas para nós do mundo TI isso é uma vergonha! Marco, eu estudo redes à 4 anos, já passei por escolas que enganam o aluno (não vou citar nome) até escolas sérias como o SENAC, onde fiz o netacademy semi-presencial, hoje estou no 2º semestre de redes na Estácio que é uma faculdade séria, mas voltando ao assunto, rede doméstica, cara vc não tem noção…. eu fiz um CCNA netacademy de 1 ano com uma net de 56kbps (DISCADA) isso mesmo 56kbps, por falta de opção, na região em que moro, pois bem, hoje uso o 3G da TIM, o qual também, é pouco funcional na minha área, porém, o único que funciona mais ou menos aqui (já testei todos), pra vc ter uma idéia dessa situação, o que vou te contar seria cômico se não fosse trágico, tenho um amigo que mora em Mauá (próximo daqui) e o cara trabalha no prédio da CISCO aqui em São Paulo e também não tem opção de internet em casa e usa o 3G e reclama das mesmas coisas que eu reclamo. Aí, já a essa altura se vc teve a paciência de ler até aqui, deve estar se perguntando, porque esse cara está escrevendo tudo isso??? Te respondo agora:
    Porque o seu blog é muito bem visto por todos da área de redes, porque não me conformo com essa situação das áreas mais pobres (bairros classe C/D) não terem acesso à uma banda larga e porque gostaria da sua ajuda nessa!
    Será que existe alguma forma de resolver esse problema??? Vejo por exemplo a possibilidade da rede à rádio, será que é viável, é muito caro? Será que se eu conseguisse um grupo de pessoas nessa situação conseguiria construir uma rede à radio “legalizada”, será que fica muito caro??? Qual seria o caminho para resolver esse problema que ao meu ver é muito mais do que técnico, é social!!!
    Peço desculpas, por ter exposto isso nesse espaço dedicado para dúvidas técnicas, mas o fato de estar esperando em alguns dias quase 2h para entrar na internet, acabou me motivando, fico no aguardo e desde já agradeço!

    0

    0
  34. Clayton Coelho

    Marco muito bom mesmo.

    0

    0
  35. Ronaldo Echevenguá

    Fala Marcão !!!

    Qual o meio de acesso a TIM utilizou para entregar o link para você?

    Abraço.

    0

    0
  36. mvtica

    Gostei da technics do lado! eu tenho um par tambem 🙂

    0

    0
  37. mvtica

    Muito legal a solução, eu nem imaginava que dava para fazer esse tipo de roteamento com router cisco.
    A uma outra duvida, eu ja trabalhei com esse tipo de balanceamento mas via ip route/linux, é possivel fazer um balanceamento estatistico, exemplo 80% ir por um link e 20 por outro, e caso um deles caia o outro assuma tudo? tem como fazer via estatistica mesmo (como no linux eu consigo verificar o estado da conexão eu consigo colocar para sortear com 80% de chances para ir por um link e o resto ir por outro, sendo que mesmo acessado um mesmo site, sessões podem ir por links diferentes).
    e outra duvida, se no roteador fosse entregue direto o ip valido de internet, tem como fazer ele tratar isso, que neste caso o default gateway pode mudar dai as rotas default estaticas não funcionariam.

    Att!

    0

    0
  38. mcamocardi

    Marco, uma pergunta, estou quase contratando um link desses. Como o Tim LIVE é entregue? ADSL? Seria possível ligar o link do LIVE direto no 1841 com uma interface adsl wic para ter IP público direto no router? Vc configura “DMZ” no “router” da TIM para poder ter acesso externo?

    0

    0
  39. Marco Filippetti

    O acesso é via modem HDSL (ou seja, uma porta Ethernet do seu lado).

    Abs

    Marco.

    0

    0

Deixe uma resposta