«

»

mar 28 2018

Pergunta no fórum: Alta disponibilidade com HSRP

Me deparei ontem com uma questão postada recentemente no fórum do blog (link: http://blog.ccna.com.br/forum/topico/configuracao-hsrp-ou-vrrp/#post-189214), na qual um usuário questionava como configurar alta disponibilidade dada determinada topologia, conforme ilustro abaixo:

Como fazia algum tempo que eu não configurava um cenário destes, decidi tirar a poeira do meu Packet Tracer e colocar as mãos a obra… baseado na topologia do usuário, criei minha própria, que usei para configurar e validar o cenário:

Procurei colocar descrições suficientes no diagrama, mas vou explicar os detalhes a seguir. O objetivo final era que os PCs representados fossem capazes de acessar o endereço IP 1.1.1.1, configurado na interface Loopback0 do roteador R2. O usuário no fórum não deu muitos detalhes sobre os requerimentos. Eu completei os que faltavam. Seguem:

  1. Os usuários encontram-se todos na mesma VLAN (e, portanto, na mesma subrede). No caso, eu usei a rede 192.168.100.0/24 para acomodar todos os PCs da topologia.
  2. O tráfego deveria ser balanceado entre os dois roteadores. Para isso, eu configurei dois grupos HSRP distintos e dividi os PCs em 2 grupos (esquerda e direita). O grupo da esquerda usa o IP do grupo HSRP 1 (vip1) como default gateway. O grupo da direita usa o IP do grupo HSRP 2 (vip2) como default gateway. Desta forma, 50% do tráfego atravessa cada router.
  3. 100% do tráfego deveria sair pelo roteador remanescente em caso de uma falha com um dos routers. Esta é a premissa básica ao se utilizar mecanismos FHRP como HSRP, VRRP ou GLBP. Ou seja, se o roteador R0 sair do ar, todos os PCs deve ser capazes de acessar o IP 1.1.1.1 via R1. E vice-versa.

NOTA: Eu optei por usar HSRP pois este é o protocolo adotado pela Cisco no exame CCNA (a Cisco parou de cobrar VRRP e GLBP neste exame). Eu também utilizei OSPF para propagar as rotas dinamicamente neste lab – para tornar minha vida mais fácil e o lab mais interessante.

Não há qualquer configuração nos 2 switches, já que existe apenas 1 VLAN na topologia e eu optei por usar a VLAN default (VLAN 1) em ambos os lados. Assim, nada a ser mostrado com relação aos switches.

Configuração dos Routers R0 e R1:

R0:

interface GigabitEthernet0/0
 ip address 192.168.0.201 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 192.168.100.201 255.255.255.0
 standby 1 ip 192.168.100.253
 standby 1 priority 105
 standby 1 preempt
 standby 1 track GigabitEthernet0/0
 standby 2 ip 192.168.100.254
 standby 2 preempt
!
router ospf 2
 network 192.168.0.0 0.0.255.255 area 0
!

Observem que temos dois grupos HSRP (1 e 2). O grupo 1 tem prioridade maior (105) no router 0 que no router 1 (100), e o grupo 2 tem prioridade default de 100 no router 0 e 105 no router R1. O recurso preempt foi ativado o que significa que cada router deve ser o primário para o grupo com maior prioridade configurada, sempre que estiver disponível. Assim, o IP 192.168.100.253 encontra-se ativo neste router e standby no outro. O IP 192.168.100.254, por sua vez, encontra-se em standby neste router e ativo no outro. Outra configuração que adicionei aqui é o rastreamento da interface G0/0 (conexão upstream com o router2, que possui a rede 1.1.1.1 atrás dele). Se esta interface cair, a prioridade do grupo 1 é penalizada em 10 pontos, resultando em um valor de 95 – que é MENOR que o valor de prioridade definido para o grupo HSRP 1 no router R1 (100), tornando o grupo 1 ativo no router R1, neste caso.

R1:

interface GigabitEthernet0/0
 ip address 192.168.100.202 255.255.255.0
 standby 1 ip 192.168.100.253
 standby 1 preempt
 standby 2 ip 192.168.100.254
 standby 2 priority 105
 standby 2 preempt
 standby 2 track GigabitEthernet0/1
!
interface GigabitEthernet0/1
 ip address 192.168.1.202 255.255.255.0
!
router ospf 2
 network 192.168.0.0 0.0.255.255 area 0
!

Se vocês entenderam as configs do router R0, acredito que as do R1 sejam auto-explicativas… 🙂 Basta pensar que é o inverso do que foi feito em R0.

Para finalizar, temos R2 e os PCs. Em R2, apenas configurei a Loopback e ativei OSPF:

R2:

!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
 ip address 192.168.0.203 255.255.255.0
!
interface GigabitEthernet0/1
 ip address 192.168.1.204 255.255.255.0
!
router ospf 2
 network 192.168.0.0 0.0.255.255 area 0
 network 1.1.1.1 0.0.0.0 area 0
!

Quanto aos PCs, apenas configurei um endereço IP estático em cada um e configurei o default gateway conforme explicado anteriormente (esquerda com o DGW 192.168.100.253 e direita com o DGW 192.168.100.254). Colocando tudo em prática, o resultado é exatamente o esperado. Quando ambos os routers R0 e R1 estão OK, 50% do tráfego escoa por R0 e 50% por R1. Se eu vou em R2 e dou um SHUT na interface que o conecta com R0, a configuração HSRP detecta o problema (configuração de rastreamento) e reduz a prioridade do grupo 1 para 95, o que torna o grupo 2 o primário para este cenário, desviando 100% do tráfego para R1. Assim que a conexão upstream com R2 é re-estabelecida, o Grupo 1 HSRP no router R0 volta a ter prioridade 105 e metade do tráfego volta a atravessar R0.

Vocês podem testar baixando o arquivo para o PT que usei no link que passei, no fórum.

Gostou? Comente! Comentários me animam a escrever mais posts como este 🙂

Abs

Marco

 

2
0

4 comentários

Pular para o formulário de comentário

  1. zekkerj

    Olá Marco,

    Cof!! Cof!!! Ainda tem muita poeira por aqui… 😀

    Um ponto importante aí é observar que, nesse cenário, você está distribuindo manualmente as configurações para as estações de trabalho. Ou seja, IPs fixos, sem DHCP. Adicionar DHCP, até onde eu consigo ver, torna obrigatório usar algum tipo de segmentação no domínio de broadcast, seja por VLANs, seja por separação física dos switches.

    0

    0
    1. Marco Filippetti

      Certeza meu amigo. Usei configuração manual, mas DHCP seria sem dúvida a melhor opção. Segmentação por VLANs também seria uma ótima idéia. Me atentei apenas aos requisitos passados pelo colega no fórum. Mas dá pra melhorar muito mais, sem dúvida.

      Abs!

      0

      0
  2. zekkerj

    @Marco, você notou que seu lab está fazendo roteamento assimétrico?

    0

    0
    1. Marco Filippetti

      Sim, mas o objetivo não era roteamento de qualquer forma. Era mais resolver o problema do HSRP. Como eu disse, tem muita coisa para melhorar, mas convenhamos… nosso amigo no fórum não foi muito específico kkk

      Abs!

      0

      0

Deixe uma resposta