↑ Retornar para Problemas do mundo real

Problemas Topologia em Anel

Home Fórum Problemas do mundo real Problemas Topologia em Anel

Este tópico contém 13 respostas, possui 5 vozes e foi atualizado pela última vez por  Junior Bourguignon 11 anos, 11 meses atrás.

Visualizando 14 posts - 1 até 14 (de 14 do total)
  • Autor
    Posts
  • #42441

    Junior Bourguignon
    Participante

    Pessoal,

    Alguém poderia me ajudar com o seguinte problema:

    Tenho que criar um anel com dois Switch Cisco 2960 como segue em desenho esquematico abaixo:

    Problemas que estou encontrando, toda vez em que o enlace entre o switch da "U.S Praia do Suá" e "CIAC" cai, o switch da "U.S Praia do Suá" fica fora, o mesmo problema enfrento se o enlace entre "Emef Edna Mattos" e "Palacio" cair o Switch da Emef Edna Mattos fica forá. Todas as portas entre os 2960 e os 6500 estão configuradas como trunk, execeto o enlace entre os 6500s que possui roteamento. Alguém tem idéia do que pode está acontecendo?

    Obs.: Os switch estão em Vlans diferentes, não estão na mesma rede.

    0

    0
    #53099

    Junior, se a conexão entre os 2 6500 é em L3 (roteamento), sua topologia não faz muito sentido… vc está conectando ambos os 6500 via L3 e tb via L2 (por intermédio dos 2 2960). Você pode prover mais detalhes? Quais as redes e vlans de um lado, e quais as que estão do outro? Como esta configurado o roteamento nos 2 6500? As interfaces VLAN nos 6500 estão em L3?

    Abs

    Marco.

    0

    0
    #53100

    Junior Bourguignon
    Participante

    Ok Marco,

    Lembrando que a minha principal intenção não é construir uma redundancia para os 6500s e sim para os 2960s, por exemplo se o enlace entre "Emef Edna Mattos" e "Palacio" parar de funcionar, quero que a "Emef Edna Mattos" continue funcionando utilizando do outro enlace que liga ela com "U.S Praia do Sua". Para os 6500s já tenho outras redundancias que não estão sendo mostradas no desenho, este desenho só é parte da minha rede, acima dos 6500s tenho outros links, porém segue abaixo mais detalhes do esquema:

    *Emef Edna Mattos

    Todas as portas que fazem Up link estão configuradas em Trunk conforme segue:

    interface GigabitEthernet0/1

     switchport mode trunk

     service-policy input POLITICA_QOS_2960

     media-type sfp

     srr-queue bandwidth share 10 50 25 15

     srr-queue bandwidth shape  0  0  0  0

     udld port aggressive

    interface GigabitEthernet0/2

     switchport mode trunk

     service-policy input POLITICA_QOS_2960

     media-type sfp

     srr-queue bandwidth share 10 50 25 15

     srr-queue bandwidth shape  0  0  0  0

     udld port aggressive

    Configurações da Vlan Local Emef Edna Mattos

    Vlan 2

    name VLAN_LOCAL_EMEF_EDNA_MATTOS

    interface Vlan2

     description VLAN_LOCAL_EMEF_EDNA_MATTOS

     ip address 10.65.74.12 255.255.255.0

     ip helper-address 10.1.4.48

     ip helper-address 10.1.4.50

     no ip route-cache

     default-gateway = 10.65.74.11 (Endereço IP da Interface VLan 3 configurada no 6500 Palacio)

    *U.S Praia do Sua

     

    Todas as portas que fazem Up link estão configuradas em Trunk conforme segue:

    interface GigabitEthernet0/1

     switchport mode trunk

     service-policy input POLITICA_QOS_2960

     media-type sfp

     srr-queue bandwidth share 10 50 25 15

     srr-queue bandwidth shape  0  0  0  0

     udld port aggressive

    interface GigabitEthernet0/2

     switchport mode trunk

     service-policy input POLITICA_QOS_2960

     media-type sfp

     srr-queue bandwidth share 10 50 25 15

     srr-queue bandwidth shape  0  0  0  0

     udld port aggressive

    Configurações da Vlan Local Praia do Sua

    Vlan 4

    name VLAN_LOCAL_PRAIA_DO_SUA

    interface Vlan4

     ip address 10.64.51.12 255.255.255.0

     ip helper-address 10.1.4.48

     ip helper-address 10.1.4.50

     no ip route-cache

    default-gateway = 10.64.51.11 (Endereço IP da Interface VLan 4 configurada no 6500 CIAC)

    *PALACIO

    Configuração da Vlan que vai ser o default-gateway da Emef Edna de Mattos

    Vlan 2

    name VLAN_LOCAL_EMEF_EDNA_MATTOS

    interface Vlan2

     description Gateway EMEF Edna Mattos

     ip address 10.65.74.11 255.255.255.0

     ip helper-address 10.1.4.48

     ip helper-address 10.1.4.50

    Configuração da Porta que faz UP link com Emef Edna Mattos

    interface GigabitEthernet1/48

     description UPLINK_EMEF_EDNA_MATTOS

     no ip address

     udld port aggressive

     switchport

     switchport trunk encapsulation dot1q

     switchport mode trunk

    Configuração da Porta que faz Up link com CIAC

    interface GigabitEthernet1/17

     no ip address

     channel-group 1 mode on

    Configuração do Port-channel1

    interface Port-channel1

     description === conexao PALACIO – CIAC (AI)

     ip address 172.29.1.9 255.255.255.252

     ip ospf message-digest-key 10 md5 7 083141585B49554032041F142C

    Configuração de Roteamento

    router ospf 20077

     router-id 172.28.1.1

     log-adjacency-changes

     area 0 authentication message-digest

     area 1 range 172.28.0.0 255.252.0.0

     redistribute static metric-type 1 subnets route-map permite_gerencia

     network 10.0.0.0 0.255.255.255 area 1

     network 172.28.0.0 0.3.255.255 area 0

     default-information originate always

    !

    router rip

     version 2

     redistribute ospf 20077 metric transparent

     network 10.0.0.0

     no auto-summary

    !

    ip local policy route-map interno

    ip classless

    ip route 0.0.0.0 0.0.0.0 10.1.4.60 200

    ip route 10.253.254.0 255.255.255.0 10.1.4.60

    no ip http server

    *CIAC

    Configuração de Vlan que vai ser o default-gateway da U.S Praia do Sua

    Vlan 4

    name VLAN_LOCAL_US_PRAIA_DO_SUA

    interface Vlan4

     ip address 10.64.51.11 255.255.255.0

     ip helper-address 10.1.4.48

     ip helper-address 10.1.4.50

    Configuração da Porta que faz Up link com U.S Praia do Sua

    interface GigabitEthernet1/24

     description UPLINK_US_PRAIA_SUA

     no ip address

     udld port aggressive

     switchport

     switchport trunk encapsulation dot1q

     switchport mode trunk

    Configuração da Porta que faz up link com Palacio

    interface GigabitEthernet1/1

     no ip address

     channel-group 1 mode on

    Configuração do Port-channel1

    interface Port-channel1

     description === conexao CIAC – PALACIO (AI)

     ip address 172.29.1.10 255.255.255.252

     ip ospf message-digest-key 10 md5 7 1502061A567A7B73083C263215

    Configuração de Roteamento

    router ospf 20077

     router-id 172.28.1.4

     log-adjacency-changes

     area 0 authentication message-digest

     area 4 range 172.28.0.0 255.252.0.0

     redistribute static metric-type 1 subnets route-map permite_gerencia

     network 10.0.0.0 0.255.255.255 area 4

     network 172.28.0.0 0.3.255.255 area 0

    !

    ip classless

    ip route 10.254.254.0 255.255.255.0 10.2.4.20

    no ip http server

    ip http access-class 10

    Acho que agora as informações são suficientes..rsrsrsrsrsrs

    Vlw fico na espera Marco, pow se voce puder me ajudar mais rapido possivel to com uma certa urgencia para resolver este problema, mas desde já agradeço.

     

    0

    0
    #53101

    Junior, diria com 90% de certeza que seu problema esta aqui:

    name VLAN_LOCAL_EMEF_EDNA_MATTOS

    interface Vlan2

     description VLAN_LOCAL_EMEF_EDNA_MATTOS

     ip address 10.65.74.12 255.255.255.0

     ip helper-address 10.1.4.48

     ip helper-address 10.1.4.50

     no ip route-cache

     default-gateway = 10.65.74.11 (Endereço IP da Interface VLan 3 configurada no 6500 Palacio)

    Como o default-gateway da VLAN2 aponta para uma interface no switch Palacio configurada na VLAN3??? Altere a VLAN 2 para 3, ou vice-versa e a coisa deve funcionar.

    Só um detalhe: o modelo 2960 não é L3, mas apenas L2. Os IPs que estão configurados em ambos servem APENAS para gerência. Imagino que vc saiba disso… abs!

    Marco.

    0

    0
    #53102

    Junior Bourguignon
    Participante

    Desculpa Marcos foi uma falha minha, é um erro de digitação no comentário "Vlan 3" seria "Vlan 2", repare que até o endereço IP já está mesma rede que a Vlan 2, o 6500 não deixaria eu criar duas Vlans com a mesma rede, por tanto mais um vez desculpas pode considerar que no lugar da Vlan3 seria Vlan 2.

    Repare nas configurações que enviei não existe Vlan3, somente Vlan2 e Vlan4 foi somente um erro de digitação. Da uma olhada nas configurações:

    Palacio (6500)

    Vlan 2

    name VLAN_LOCAL_EMEF_EDNA_MATTOS

    interface Vlan2

     description Gateway EMEF Edna Mattos

     ip address 10.65.74.11 255.255.255.0

     ip helper-address 10.1.4.48

     ip helper-address 10.1.4.50

    Emef Edna Mattos (2960)

     Vlan 2

    name VLAN_LOCAL_EMEF_EDNA_MATTOS

    interface Vlan2

     description VLAN_LOCAL_EMEF_EDNA_MATTOS

     ip address 10.65.74.12 255.255.255.0

     ip helper-address 10.1.4.48

     ip helper-address 10.1.4.50

     no ip route-cache

     default-gateway = 10.65.74.11 (Endereço IP da Interface VLan 2 configurada no 6500 Palacio)

    Eu andei analisando outra coisa, voce já notou que as areas de OSPF para rede 10.0.0.0 são diferentes nos dois 6500, porém acho que mesmo sendo em areas diferentes elas deviam se comunicar, não sei, o que voce acha disso?

    Configuração a qual estou me referindo:

    CIAC (6500)

    router ospf 20077

     router-id 172.28.1.4

     log-adjacency-changes

     area 0 authentication message-digest

     area 4 range 172.28.0.0 255.252.0.0

     redistribute static metric-type 1 subnets route-map permite_gerencia

     network 10.0.0.0 0.255.255.255 area 4

     network 172.28.0.0 0.3.255.255 area 0

    !

    ip classless

    ip route 10.254.254.0 255.255.255.0 10.2.4.20

    no ip http server

    ip http access-class 10

    Palacio (6500)

    router ospf 20077

     router-id 172.28.1.1

     log-adjacency-changes

     area 0 authentication message-digest

     area 1 range 172.28.0.0 255.252.0.0

     redistribute static metric-type 1 subnets route-map permite_gerencia

     network 10.0.0.0 0.255.255.255 area 1

     network 172.28.0.0 0.3.255.255 area 0

     default-information originate always

    !

    router rip

     version 2

     redistribute ospf 20077 metric transparent

     network 10.0.0.0

     no auto-summary

    Quanto a interface IP no 2960, tranquilo eu sei que ele é sw que só trabalha com L2.

    Vlw, fico na espera!

    AE GALERA ME AJUDEM TAMBÉM, QUANTO MAIS OPNIÕES SOBRE O PROBLEMA MELHOR É…….

    AE GALERA ME AJUDEM TAMBÉM, QUANTO MAIS OPNIÕES SOBRE O PROBLEMA MELHOR É…….

     

    0

    0
    #53103

    Junior, então… para entender o problema… só estando ai! Teria de ser feito um troubleshooting na rede para entender o que se passa. Apenas olhando as configs, não tenho como lhe dizer mais do que eu já disse. Não sei se mais alguém pode lhe ajudar…

    Abs!

    Marco.

    0

    0
    #53104

    ferrugem
    Participante

    Junior Bourguignon , infelizmente eu não sei como te ajudar cara.

    Mas como o Marco disse, vamos ver se aparece mais alguém aqui e consegue perceber algo que possa te ajudar a resolver este problema. E certamente aparecerá!

    Abraços, Ferrugem!

    0

    0
    #53105

    Junior Bourguignon
    Participante

    Tranquilo gente, vlw pela força, mais estou achando este problema meio que impossível, achei meio difícil utilizar dois 2960 para fazer esta redundância o ideal mesmo já falei com o pessoal lá na empresa era utilizar dois 3560 que já trabalham com L3, dai mataria o problema de uma vez, mas se tiver solução utilizando 2960 atualizou o post, para enriquecer este blog cada dia mais…Vlw Marco e Ferrugem um forte abraço.

    0

    0
    #53106

    Eduardo R.
    Participante

    Junior…

    “Eu andei analisando outra coisa, voce já notou que as areas de OSPF para rede 10.0.0.0 são diferentes nos dois 6500, porém acho que mesmo sendo em areas diferentes elas deviam se comunicar, não sei, o que voce acha disso?”

    Elas nao devem se comunicar nao…voce tera um “mismatch” de LSAs…pois um switch estara esta anunciando area 4 e recebendo area 1. Tente usar um “debug ip ospf hello” e veja se o switch envia e recebe hellos nas interfaces conectadas.

    Quanto ao seu problema, eu checaria em primeiro lugar o spanning-tree. Se vc puder colar a config de spanning-tree junto com um “show spanning-tree” em cada switch ajudaria muito.

    Abracos.

    0

    0
    #53107

    Eduardo R.
    Participante

    Outra coisa que acabei de notar…voce esta anunciando a rede 10.x.x.x no RIP e no OSPF no switch Palacio.

    De um “show ip ospf interfaces” para ter certeza de que a VLAN 2 esta sendo anunciada pelo OSPF e nao pelo RIP

    =)

    0

    0
    #53108

    Junior Bourguignon
    Participante

    Eduardo,

    Vou verificar tudo isso pela manhã, e vou postar aqui durante o dia, mas seguinte vamos lá:

    Quanto ao RIP acho que não tenho problema, pois o DA do RIP é 120 e a do OSPF 110 tem quase certeza absoluta que a rota está sendo destribuida por OSPF, mas como diria Heisenberg "não podemos ter 100% de certeza em nada", vou verificar amanha.

    Quanto ao spanning-tree, temos que lembrar que os dois 6500 são switches L3, por tanto acho que ele não propagaria um Loop ou um Broadcast, e toda as vezes que eu fazia os testes e não funcionava verificava logo em seguida os logs de todos os equipamentos em questão e não existia nenhum log critico de Span ou coisa parecida, porém vou fazer o que voce me pediu e postar um "show spanning-tree" e "show spanning-tree root" para agente analisar juntos.

    Vlw Eduardo, pela moral!! Se alguém precisar de mim também estou a disposição da Galera do Blog.

    0

    0
    #53109

    Eduardo R.
    Participante

    Junior,

    Nao sei o que vc quer exatamente dizer com “toda vez em que o enlace entre o switch da “U.S Praia do Suá” e “CIAC” cai, o switch da “U.S Praia do Suá” fica fora”.

    Se vc esta falando sobre conectividade de camada 3, esse e’ o comportamento correto pela configuracao que voce nos passou. Pois os switches 2960 esta com o seus default-gateways apontando respectivamente para os 6500 diretamente conectados a eles. Se eles perdem esta conexao direta, eles nao conseguem rotear para o GW e assim nao podem ser acessados pelas redes remotas.

    0

    0
    #53110

    Italo Amaral
    Participante

    Olá Junior,

    Primeiramente, seria mais apropriado substituir as 2960… por algum modelo L3, a 3750 por exemplo. Comentário: suponho que você saiba que o traffic shape é unidecional de somente saída, assim, tem que ver como fica a situação uma vez acessado por outro dfl-GW.

    Perguntas:
    – Há mesmo a necessidade da usabilidade do RIPv2? Hoje em dia tem recursos bem melhores… Já avaliou uma possibilidade de melhoria?
    – Você notou se alguma das portas passa para o estado de errDisable quando ocorre a falta de conectividade entre os links? Tem como nos fornecer mais informações sobre o STP…
    – Teria como colar as saídas dos comandos (quando cai o link):
    # show ip ospf data network
    # show ip ospf data external ! pra checar se há problema com redistr…

    Abraço,

    0

    0
    #53111

    Junior Bourguignon
    Participante

    Galera me desculpa por não postar as configurações que voces me pediram, mas a minha justificativa é que a mãe de um amigo meu morreu dai foi tenso tive que dá uma assistencia ae camarada, mais assim que possivel posto as configurações solicitada ou seu eu já tiver uma solução para o problema e coloco aqui também, obrigado a todo um abraço.

    0

    0
Visualizando 14 posts - 1 até 14 (de 14 do total)

Você deve fazer login para responder a este tópico.