↑ Retornar para Problemas do mundo real

QoS de Entrada

Home Fórum Problemas do mundo real QoS de Entrada

Este tópico contém 5 respostas, possui 3 vozes e foi atualizado pela última vez por  Edson 5 anos, 8 meses atrás.

Visualizando 6 posts - 1 até 6 (de 6 do total)
  • Autor
    Posts
  • #43970

    Heitor2
    Participante

    Em um link ADSL digamos de 1MB. É possível de alguma forma limitar a banda de entrada, para priorizar tipos de tráfego?

    Por exemplo, não quero que os downloads ocupem toda a banda e atrapalhem o VOIP. Existe forma de implementar isso na entrada, sei lá, atrasando os ACKs ou outra forma?

    abs

    Heitor

    0

    0
    #66744

    rodolphotdai
    Participante

    Sim vc pode. Porem, alguns dispositivos não te deixam aplicar o policiamento de banda no sentido de Input(ENTRADA ou Download) na interface WAN(ex: serial), pois alguns mecanismos de congestionamento de Qos como LLQ, CBWFQ não são suportados no sentindo de entrada de tráfego em alguns tipos de interfaces. Contudo, vc pode aplicar uma politica no sentido de saída de sua interface FastEthernet para sua LAN(Input WAN para OutputLAN), assim suportando LLQ, CBWFQ, etc. Isso daria no mesmo que aplicar no input da interface Serial.

    Abaixo segue um template que fiz para vc para sua linha de 1Mbps. Alguns valores como os match’s dos protocolos e a banda das aplicações vc pode altera a sua politica. Não vou entrar muito em detalhes do funcionamento dos mecanismos, vou tentar ser mais prático para a sua necessidade.

    class-map match-any CBULK (Classe CBULK engloba smtp, nntp, exchange, etc. O match-any significa que qualquer uma dos protocolos pode ser escolhido)
    match protocol smtp
    match protocol nntp
    match protocol exchange
    match protocol ftp
    match protocol tftp
    match protocol secure-pop3
    !
    class-map match-any CMANAGEMENT
    match protocol imap
    match protocol dns
    match protocol snmp
    match protocol ldap
    match protocol socks
    match protocol dhcp
    match protocol kerberos
    match protocol secure-imap
    match protocol secure-ldap
    match protocol snmp
    match protocol syslog
    !
    class-map match-any CTRANSACTIONAL
    match protocol citrix
    match protocol finger
    match protocol notes
    match protocol novadigm
    match protocol pcanywhere
    match protocol secure-telnet
    match protocol sqlnet
    match protocol sqlserver
    match protocol ssh
    match protocol telnet
    match protocol xwindows
    !
    class-map match-any CVOIP
    match protocol rtp
    !
    class-map match-any CSIGNALING-VOIP
    match protocol h323
    match protocol rtcp
    match protocol sip
    !
    class-map match-any CVPN
    match protocol ipsec
    match protocol gre
    !
    !
    !
    !
    policy-map CMAP (Politica que chama as CLasses acima e aplica o policiamento de Banda para elas)
    class CBULK (Chama a classe Bulk acima que engloba smtp, nntp, exchange e aplica um policiamento de banda a classe)
    bandwidth 300 (Usa o mecanismo CBWFQ)
    class CMANAGEMENT
    bandwidth 100
    class CTRANSACTIONAL
    bandwidth 100
    class CVOIP
    priority 256 (Usa o mecanismo LLQ)
    class CSIGNALING-VOIP
    priority 60
    class CVPN
    bandwidth 180
    class class-default
    fair-queue (Mecanismo usado para priorizar aplicações sensiveis dentro do escopo que não foi classificado com Classes, ou seja, o tráfego restante).
    !
    !
    !
    !
    policy-map PMAP (Politica que chama a Politica CMAP.Será aplicado aqui todo o policiamento de banda do Policy-Map CMAP
    class class-default
    shape average 1000000 (Quando o PMAP Aplicado na interface, sua interface será modelada para 1Mbps (1000000)
    service-policy QMAP (Chama o politica QMAP)
    !
    !
    !

    router(config)# int f0/0 (exemplo de interface)
    router(config-if)## service-policy output PMAP (Aplica-se a politica que engloba todo escopo acima no sentido de saída do tráfego que vem pela WAN e vai para a LAN. Sua interface Fastethernet irá ter apenas 1 mbps de Download, não irá ter problemas se vc apenas usalá para o tráfego vindo da internet.

    Você poderá aplicar este mesmo modelos de politica para o sentido de output para sua interface serial. O tráfego de sua rede para a internet poderá ser policiado sem problemas pela interface serial no sentido de output ou upload.

    0

    0
    #66745

    rodolphotdai
    Participante

    Espero ter ajudado de alguma maneira.

    Abraço
    Rodolpho

    0

    0
    #66746

    Heitor2
    Participante

    cara ajudar mais que isso só se você viesse configurar ele pessoalmente pra mim haha.

    Lembrei de outra coisa, digamos que o UP é de 256Kbps, existe forma de fazer um shape com valores diferentes de up e down? Como é a forma correta de fazer?

    Eu pensava, que já que os dados já tinham chegado do provedor, não adiantaria aplicar da mesma forma para dentro. É possível dar uma explicação resumida de como isso funciona?

    Já me ajudou muito Rodolpho, obrigado por compartilhar seu tempo e conhecimento.

    abs

    Heitor

     

    0

    0
    #66747

    rodolphotdai
    Participante

    Bom, a respeito do shape de Down(Internet para LAN) seria esta conf que te passei na interface FastEthernet(1mbps Down), para o shape de UP vc aplicaria o mesmo modelo de conf so que em sua interface serial no sentido de Output tambem(em Out funciona). No policy map vc vai dizer o shape(Que para 256kbps seria o comando shape average 256000). Então, um exemplo ficaria assim:

    policy-map UPMAP (exemplo)
    class class-default
    shape average 256000
    service-policy C-UP-MAP (Chama o politica das classes para UP-Load, lá inclui a banda para as aplicações, mesmo esquema que o exemplo que te passei anteriormente)

    router(config)# int s0/0 (exemplo de interface Serial)
    router(config-if)# service-policy output UPMAP

    Bom heitor, repondendo a pergunta – O tráfego que chega do provedor chega limitado a 1mbps de download, assim, vc recebe este tráfego que ja está limitado. O que vc faz é apenas classificar e priorizar as aplicações que são de sua prioridade(Isto dentro do 1Mbps) em sentido a sua LAN. Haveria outras maneiras de se implementar o Qos na rede que seria atráves de marcações dos pacotes, vc atribuiria uma marcação a cada pacote(Com DSCP para Pacotes IP e para Quadros COS), assim é muito mais facil o gerenciamento
    em ambientes maiores, uma vez que você não se precisa ta classificando os protocolos em uma classe, porque está classe vai estar identificada por uma nomenclatura tagueada nos pacotes. Assim, em qualquer priorização de tráfego, não seria necessário ficar dando match toda vida em todos os protocolos, apenas em uma classe que seria DSCP EF. Um exemplo prático:

    Em vez disso:

    class-map match-any CMANAGEMENT
    match protocol imap
    match protocol dns
    match protocol snmp
    match protocol ldap
    match protocol socks
    match protocol dhcp
    match protocol kerberos
    match protocol secure-imap
    match protocol secure-ldap
    match protocol snmp
    match protocol syslog

    Você faria assim:

    class-map match-any CMANAGEMENT
    match ip dscp cs2 (se refere a um fluxo que os pacotes já vem identificados com a marcação CS2 e que engloba todos os protocolos acima)

    Creio que não se adeque muito a seu ambiente, pois o tráfego que vem da internet não vem marcado(Best-Effort). Você pode instalar em seu roteador depois o SDM para visualizar a estátisticas de protocolos e banda. Espero ter lhe ajudado e não te confundido. Posta ai depois pra dizer se funcionou!

    Abraço

    0

    0
    #66748

    Edson
    Participante

    Ressucitando o tópico, rsrs

    Tenho uma dúvida e gostaria de uma opinião.

    Matriz — ISP MPLS — Filiais
    Problema: Servidores localizados na Matriz estão consumindo mais banda do que o reservado.

    O roteador de uma filial possui uma conexão serial de 2 Mbps com o provedor e a interface Giga conectada à LAN.
    No modo que o QoS está aplicado atualmente, o tráfego é marcado em uma policy no sentido INPUT da Gig0/0 e aplica códigos DSCP para diferentes classes.
    Na interface serial há uma policy no sentido OUTPUT que distribui a banda de acordo com as marcações DSCP, basicamente é CBWFQ (LLQ).

    Imagine que hoje uma classe SERVIDORES possui reserva de 512 Kbps na saída da Serial 0/0/0 e o tráfego excedente é descartado.
    Quando alguns dos servidores localizados na Matriz enviam dados para a Filial consomem mais do que a banda reservada e outras aplicações estão apresentando lentidão.

    Estou pensando em uma criar uma nova policy e aplicar no sentido INPUT da Serial, nessa cadeia pretendo fazer “police” para 512 e descartar o tráfego excedente.

    Ex: Filial:
    – LAN 172.16.30.0/24
    – VOZ 172.16.31.0/24

    ip access-list extended TELEFONES
    permit ip 172.16.31.0 0.0.0.255 any
    !
    ip access-list extended CTX
    permit ip 172.16.30.0 0.0.0.255 172.16.4.0 0.0.0.255
    !
    ip access-list extended SERVIDORES
    permit ip 172.16.30.0 0.0.0.255 172.16.6.0 0.0.0.255
    !
    class-map match-any VOZ
    match acess-group name TELEFONES
    match protocol rtp-audio
    class-map match-any SINAL
    match protocol sip
    match protocol sccp
    match protocol h323
    match protocol rtcp
    match protocol tftp
    !
    class-map match-any CTX
    match acess-group name CTX
    match protocol citrix
    !
    class-map match-any SERVIDORES
    match acess-group name SERVIDORES
    !
    policy-map INPUT_LAN_MARCACAO
    class VOZ
    set dscp ef
    class SINAL
    set dscp cs3
    class CTX
    set dscp af31
    class SERVIDORES
    set dscp af21
    class class-default
    set dscp default
    !
    policy-map OUTPUT_WAN
    class VOZ
    match ip dscp ef
    priority 256
    class SINAL
    match ip dscp cs3
    bandwidth 32
    class CTX
    match ip dscp af31
    shape average 1000000
    class SERVIDORES
    match ip dscp af21
    shape average 512000
    class class-default
    fair-queue
    !

    Bom, até aqui tudo bem, analisando o tráfego de saída da filial a banda está sendo distribuída adequadamente e não há problemas, porém no tráfego entrante os SERVIDORES estão comendo a banda com farinha…
    A saída para nuvem MPLS na Matriz faz vizinhança com múltiplas filiais, então não queria fazer mudanças nesse ponto.

    Estou pensando na seguinte alternativa: Police na entrada da Serial (Matriz direção Filial)


    policy-map INPUT_WAN
    class VOZ
    match ip dscp ef
    police 256000 conform-action transmit exceed-action drop
    class SINAL
    match ip dscp cs3
    police 32000 conform-action transmit exceed-action drop
    class CTX
    match ip dscp af31
    police 1000000 conform-action transmit exceed-action drop
    class SERVIDORES
    match ip dscp af21
    police 512000 conform-action transmit exceed-action drop
    class class-default
    police 176000 conform-action transmit exceed-action drop

    Porém estou preocupado que essa police aumente muito a latência e impacte as ligações via VoIP.

    Bom, qualquer sugestão é bem vinda.

    Obrigado pela atenção.

    Valew

    0

    0
Visualizando 6 posts - 1 até 6 (de 6 do total)

Você deve fazer login para responder a este tópico.