↑ Retornar para Problemas do mundo real

Redirecionamento de porta.

Home Fórum Problemas do mundo real Redirecionamento de porta.

Este tópico contém 6 respostas, possui 3 vozes e foi atualizado pela última vez por  jorge.ff 3 anos, 3 meses atrás.

Visualizando 7 posts - 1 até 7 (de 7 do total)
  • Autor
    Posts
  • #188516

    brunolino
    Participante

    Pessoal, já procurei muito na internet e não vi nenhuma solução para meu problema, espero que possam me ajudar. Vamos lá.

    Tenho um cisco 1900, que disca pppoe e recebe um ip publico, estou tentando fazer o redirecionamento da porta 80 para um servidor apache com a seguinte regra: ip nat inside source static tcp 10.20.0.2 80 ip-publico 80, e não está funcionando ele abre a porta mas não encaminha para o ip local.

    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    !
    interface GigabitEthernet0/0
    description Link
    no ip address
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    !
    interface GigabitEthernet0/1
    ip address 10.20.0.1 255.255.255.248
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    no ip address
    shutdown
    no fair-queue
    clock rate 2000000
    !
    interface Dialer1
    mtu 1492
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    dialer pool 1
    ppp authentication chap callin
    ppp chap hostname bruno
    ppp chap password 0 blino
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    !
    ip nat inside source list 1 interface Dialer1 overload
    ip nat inside source static tcp 10.20.0.2 80 ip-publico 80 extendable
    ip route 0.0.0.0 0.0.0.0 Dialer1
    !
    access-list 1 permit any

    0

    0
    #188517

    zekkerj
    Participante

    Faça o teste de redirecionar outra porta na faixa das portas registradas (acima de 1024), veja se assim funciona.
    Muitas operadoras bloqueiam a porta 80/tcp na entrada das conexões não-empresariais.

    0

    0

    -----------------------------------------------------------------------------
    Receba Johrei e purifique seu Espírito.
    http://www.messianica.org.br/o-johrei.jsp

    #188527

    brunolino
    Participante

    Não é isso, como falei acima ele libera a porta, mas não redireciona para o servidor local. Eu já usava este IP publico com um roteador mikrotik e funcionava sem problemas.

    0

    0
    #188531

    zekkerj
    Participante

    O NAT de saída funciona corretamente?

    0

    0

    -----------------------------------------------------------------------------
    Receba Johrei e purifique seu Espírito.
    http://www.messianica.org.br/o-johrei.jsp

    #188539

    brunolino
    Participante

    O NAT de saída funciona corretamente?

    <input type=”hidden” value=”188531″>

    <span class=”vortex-p-like-counter 188531″>0</span>
    <input type=”hidden” value=”188531″>

    <span class=”vortex-p-dislike-counter 188531″>0</span>

    Sim, funciona.

    0

    0
    #188575

    jorge.ff
    Participante

    qual a saida do comando show ip nat translation quando vc tenta acessar o servidor de fora ?

    Jorge

    0

    0
    #188576

    jorge.ff
    Participante

    ip nat inside source static tcp10.20.0.2 80 interface Dialer1 80 , tenta usando a interface tb , como pppoe o ip muda as vezes

    0

    0
Visualizando 7 posts - 1 até 7 (de 7 do total)

Você deve fazer login para responder a este tópico.