↑ Retornar para CCNP

Stub Area

Home Fórum CCNP Stub Area

Este tópico contém 6 respostas, possui 3 vozes e foi atualizado pela última vez por  isaacferreira_santos 5 anos, 6 meses atrás.

Visualizando 7 posts - 1 até 7 (de 7 do total)
  • Autor
    Posts
  • #48580

    isaacferreira_santos
    Participante

    Bom dia pessoal !

    Estou estudando pro ccnp route e estou com uma dificuldade rss .
    http://imageshack.com/a/img845/9521/crbv.jpg
    Estou simulando uma area stub no ospf , entretanto porque a rota default está inserida somente no meu ASBR e não aparece no meu ABR ?

    CONFIG R2
    R2#show running-config | begin interface
    interface FastEthernet0/0
    ip address 192.168.0.5 255.255.255.252
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 192.168.0.2 255.255.255.252
    duplex auto
    speed auto
    !
    router ospf 1
    log-adjacency-changes
    area 1 stub
    network 192.168.0.0 0.0.0.3 area 0
    network 192.168.0.4 0.0.0.3 area 1
    !
    R2#show ip route ospf

    R2#


    R3#show running-config | begin interface
    interface FastEthernet0/0
    ip address 192.168.0.9 255.255.255.252
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 192.168.0.6 255.255.255.252
    duplex auto
    speed auto
    !
    router ospf 1
    log-adjacency-changes
    area 1 stub
    redistribute rip subnets
    network 192.168.0.4 0.0.0.3 area 1
    !
    router rip
    version 2
    redistribute ospf 1 metric 6
    network 192.168.0.0
    !
    R3#show ip route ospf
    192.168.0.0/30 is subnetted, 3 subnets
    O IA 192.168.0.0 [110/2] via 192.168.0.5, 00:05:11, FastEthernet0/1
    O*IA 0.0.0.0/0 [110/2] via 192.168.0.5, 00:05:11, FastEthernet0/1

    Pelo que eu havia entendido , a rota default deveria ser criada no ABR e não no ASBR , o que eu fiz de errado ?
    Desde ja agradeço

    0

    0
    #113968

    zekkerj
    Participante

    A área Stub não aceita rotas externas. Se você precisa redistribuir rotas, você tem que usar uma área NSSA (Not So Stubby Area).

    0

    0

    -----------------------------------------------------------------------------
    Receba Johrei e purifique seu Espírito.
    http://www.messianica.org.br/o-johrei.jsp

    #113969

    isaacferreira_santos
    Participante

    zekkerj , talvez eu esteja falando bestera , mas… Uma area stub é uma área que não aceita lsa do tipo 5 … Ela cria uma rota default para tudo que for externo .. Logo qual o objetivo de criar uma área stub sem o ASBR ? Já que é ele que manda essas rotas externas pela rede ?
    Falei muita besteira xD?
    Abraço

    0

    0
    #113970

    roboxtz
    Participante

    Para que um ASBR seja aceito em uma area stub é usado o tipo de área nssa só dessa forma conseguirá anunciar a rota default originida pelo asbr devido ao anúncio ser como lsa 7 e não 5 sendo este por natureza barrado na area stub.

    0

    0
    #113971

    roboxtz
    Participante

    O objetivo primordial de se criar uma área stub é diminuir o uso derecursos em roteadores de tal área entao a sua lógica de existência não depende da existencia de um ASBR dentro dela.

    0

    0
    #113972

    zekkerj
    Participante

    @isaacferreira_santos: Uma area stub é uma área que não aceita lsa do tipo 5 … Ela cria uma rota default para tudo que for externo .. Logo qual o objetivo de criar uma área stub sem o ASBR ? Já que é ele que manda essas rotas externas pela rede ?

    Imagine que você tem uma área que tem 2 entradas para a área 0. Imagine também que você tem várias rotas externas que são injetadas em pontos diferentes da área 0. Então podemos querer que algumas dessas rotas externas sejam distribuídas por um ABR e outras por outro, de forma que o caminho dessa área para cada uma das origens dessas rotas externas seja diferente, conforme vc tenha configurado seu OSPF pra trabalhar (e pelo Amor de Deus, não vamos entrar no detalhe de como fazer isso senão todos nós vamos pirar aqui. Apenas vamos aceitar que funciona, certo? :D). Nesse cenário, é importante que a área receba e diferencie cada uma das rotas externas.

    Agora, se ao invés da área ter 2 ou mais entradas para a área 0, ela agora tem apenas uma, e ainda assim você tem várias e várias rotas externas vindas da área 0, o que vai acontecer? Você vai ter várias rotas em todos os roteadores da área, e todas vão apontar pro mesmo lugar, que é o ABR. Porque não trocá-las logo por uma rota default? É isso que a área Stub faz.

    0

    0

    -----------------------------------------------------------------------------
    Receba Johrei e purifique seu Espírito.
    http://www.messianica.org.br/o-johrei.jsp

    #113973

    isaacferreira_santos
    Participante

    Valeu pela ajuda roboxtz e zekkerj .. Muito obrigado mesmo , fez o lab aqui no gns3 e percebi a diferença da qual vocês disseram 😀 !
    zekkerj obrigado principalmente pela explicação dos cenários , ainda não tenho muita experiência , então explicando dessa forma fica muito mais simples de entender !!

    0

    0
Visualizando 7 posts - 1 até 7 (de 7 do total)

Você deve fazer login para responder a este tópico.