Voltar para Labs

PACOTE NÃO CHEGA AO DESTINO REDE 100.110.102.1/24

Home Fórum Labs PACOTE NÃO CHEGA AO DESTINO REDE 100.110.102.1/24

Visualizando 4 respostas da discussão
  • Autor
    Posts
    • #190447
      wanderp
      Participante

      Boa tarde. Construí um lab com parte da topologia em anexo. Estou com o seguinte problema.

      Tenho uma rede corporativa: 172.21.1.0/24 com SVI/L3 vlan 701 no Switch. Que estou fazendo NAT.

      PC–>SWitch–>R17–>R1

      No R1, criei uma Loopback 102/100.110.102.1/24 para simular uma rede atras do R1.

      O R1 esta mandando OSPF information da REDE para o R17.
      R17#sh ip route

      Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
      C 10.22.212.0/24 is directly connected, FastEthernet0/0
      L 10.22.212.1/32 is directly connected, FastEthernet0/0
      100.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
      O 100.110.102.1/32
      [110/2] via 100.126.198.238, 01:12:17, FastEthernet1/0
      C 100.126.198.236/30 is directly connected, FastEthernet1/0
      L 100.126.198.237/32 is directly connected, FastEthernet1/0
      126.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
      C 126.1.1.0/24 is directly connected, Loopback3
      L 126.1.1.1/32 is directly connected, Loopback3
      130.100.0.0/16 is variably subnetted, 2 subnets, 2 masks
      C 130.100.200.0/24 is directly connected, Loopback2
      L 130.100.200.1/32 is directly connected, Loopback2

      No R17 tem o NAT da rede corporativa:
      router ospf 100
      network 10.22.212.0 0.0.0.255 area 100
      network 100.126.198.0 0.0.0.255 area 100
      network 172.21.1.0 0.0.0.255 area 100
      neighbor 100.126.198.238
      !
      ip nat pool servers 172.21.1.6 172.21.1.253 netmask 255.255.255.0
      ip nat inside source list 10 pool servers
      ip forward-protocol nd

      O troubleshooting:

      PC–> Lo102.

      C:\Documents and Settings\user>tracert 100.110.102.1
      1 2 ms 2 ms 2 ms 172.21.1.1
      2 18 ms 17ms 16 ms 10.22.212.1 <<–R17-INTERFACE F0/0
      3 * * * Request timed out.

      Quando eu removo no R17 ip route 172.21.1.0 255.255.255.0 10.22.212.2. O pacote com destino IP address 100.110.102.1 não chega no R17-INTERFACE F0/0.

      C:\Documents and Settings\user>tracert 100.110.102.1
      1 2 ms 2 ms 2 ms 172.21.1.1
      2 * * * Request timed out.

      The packet with destination interface Lo102 100.110.102.1
      R17#ping 100.110.102.1
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 100.110.102.1, timeout is 2 seconds:
      !!!!!

      R1#ping 10.22.212.1 <<–R17 interface f0/0 inside
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.22.212.1, timeout is 2 seconds:
      !!!!!

      O problema pode estar no NAT??

      Attachments:
      You must be logged in to view attached files.
    • #190451
      lrattes
      Participante

      Boa tarde Wander.

      Eu percebi que não há teste do SW até a loopback 102. É importante que todo teste para descobrir onde está morrendo o pacote até o target.

    • #190452
      wanderp
      Participante

      Obrigado Rattes.

      O pacote chega na Loopback 102.

      Switch#ping 100.110.102.1
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 100.110.102.1, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 10/20/37 ms
      Switch#

      PQ será que o PC não pinga a interface? O Firewall esta desabilitado no pc.

      Segue parte da running do switch.

      interface GigabitEthernet0/2
      description servidor windows
      switchport access vlan 701
      switchport mode access

      media-type rj45
      negotiation auto
      !
      interface Vlan10
      ip address 172.21.10.1 255.255.255.0
      !
      interface Vlan100
      description Rede Prod
      ip address 172.21.31.254 255.255.255.0
      !
      interface Vlan701
      description SERVIDORES_WINDOWS
      ip address 172.21.1.1 255.255.255.0

      !
      interface Vlan709
      description VLAN NATIVA
      ip address 172.21.9.1 255.255.255.0
      !
      ip default-gateway 10.22.212.1
      ip forward-protocol nd
      !
      no ip http server
      no ip http secure-server
      !
      ip route 0.0.0.0 0.0.0.0 10.22.212.1
      !

    • #190461
      lrattes
      Participante

      Boa tarde,Wander.

      Remove isso no switch, pois já possui uma rota default
      no ip default-gateway 10.22.212.1

      No R17 perceba que vc tem uma rota estática para a rede 172.21.1.0. Vc precisa reditribuir essa rede no OSPF para que o R1 aprenda essa rede via ospf. Aproveita e adiciona tb um router-id para como melhores práticas.

      router ospf 100
      router-id 17.17.17.17
      redistribute static subnets

      Me diz se funcionou?

    • #190462
      wanderp
      Participante

      Obrigado Rattes.

      Funcionou. Muito obrigado pela ajuda.

Visualizando 4 respostas da discussão
  • Você deve fazer login para responder a este tópico.