↑ Retornar para Cisco

NAT Router Cisco 1750

Home Fórum Cisco NAT Router Cisco 1750

Este tópico contém respostas, possui 4 vozes e foi atualizado pela última vez por  zekkerj 3 anos, 1 mês atrás.

Visualizando 12 posts - 1 até 12 (de 12 do total)
  • Autor
    Posts
  • #48999

    suporte_lemon
    Participante

    Olá!

    Estou com uma dúvida, estou configurando o Router 1750 numa rede em que esta instalada uma internet da NET, Internet compartilhada. Já efetuei uma rota de IP nada não consigo colocar a internet para funcionar.

    No caso estou com duas interface uma Fast Ethernet e outra Ethernet.
    Na fast esta lincada o Modem da NET no IP 10.10.10.1
    Na Ethernet esta a LAN no IP 192.168.0.1 e já esta configurado o DHCP Pool nela.
    Segue abaixo a configuração.Current configuration : 2027 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Lemon
    !
    boot system flash
    boot system flash c1700-y7-mz.122-2.xj.tar
    enable secret 5 $1$Ma.f$Ri7jCweLwwwijklPNBbgb1
    !
    username lemon password 0 L3m0nIT
    memory-size iomem 25
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    ip dhcp ping packets 10
    !
    ip dhcp pool Redelemon
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1
    dns-server 10.10.10.1
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    half-duplex
    !
    interface FastEthernet0
    ip address 10.10.10.2 255.255.255.0
    ip nat outside
    speed auto
    !
    ip nat pool INTERNET 10.10.10.120 10.10.10.253 prefix-length 24
    ip nat inside source list NAT pool INTERNET overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 FastEthernet0
    ip route 0.0.0.0 0.0.0.0 Ethernet0
    no ip http server
    !
    !
    ip access-list standard NAT
    permit 0.0.0.0
    permit 10.10.10.0
    permit 192.168.0.0
    tftp-server flash:
    tftp-server flash:c1700-sv3y-mz.122-26a.bin

    0

    0
    #117221

    zekkerj
    Participante

    Mas que raio é isso?

    ip route 0.0.0.0 0.0.0.0 FastEthernet0

    ip route 0.0.0.0 0.0.0.0 Ethernet0

    0

    0

    -----------------------------------------------------------------------------
    Receba Johrei e purifique seu Espírito.
    http://www.messianica.org.br/colunas-da-salvacao

    #117222

    zekkerj
    Participante

    Outra coisa… aceita algumas sugestões?

     

    1. "ip nat inside source list NAT interface Fa0/0 overload"

    2. "no ip nat pool INTERNET"

    3. "interface FastEthernet0/0

    ip address dhcp"

    4. "no ip route 0.0.0.0 0.0.0.0 Fa0/0

    no ip route 0.0.0.0 0.0.0.0 E0/0"

    5. "ip dhcp pool Redelemon

    dns-server 8.8.8.8 8.8.4.4"

     

    Testa e e vê se melhora.

    0

    0

    -----------------------------------------------------------------------------
    Receba Johrei e purifique seu Espírito.
    http://www.messianica.org.br/colunas-da-salvacao

    #117223

    suporte_lemon
    Participante

    Olá

    Fiz a configuração conforme encaminhado, porem sem acesso a internet, lembrando que estou em uma rede que a internet é liberada pela NET, internet compartilhada.

    Configuração abaixo,

    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Lemon
    !
    boot system flash
    boot system flash c1700-y7-mz.122-2.xj.tar
    enable secret 5 $1$Ma.f$Ri7jCweLwwwijklPNBbgb1
    !
    username lemon password 0 L3m0nIT
    memory-size iomem 25
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    ip dhcp ping packets 10
    !
    ip dhcp pool Redelemon
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1
    dns-server 8.8.8.8 8.8.4.4
    !
    !
    !
    !
    interface Ethernet0
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    half-duplex
    !
    interface FastEthernet0
    ip address 10.10.10.2 255.255.255.0
    ip nat outside
    speed auto
    !
    ip nat inside source list NAT interface FastEthernet0 overload
    ip classless
    no ip http server
    !
    !
    ip access-list standard NAT
    permit 0.0.0.0
    permit 10.10.10.0
    permit 192.168.0.0
    tftp-server flash:
    tftp-server flash:c1700-sv3y-mz.122-26a.bin

    Obrigado!

    0

    0
    #117224

    zekkerj
    Participante

    1. Você ainda não está recebendo o IP da interface FastEthernet via dhcp.

    2. Vamos por partes… primeiro, confirme que vc consegue acessar a internet a partir do roteador. Tente pingar os endereços do google.

    3. A lista de acesso "NAT" me parece errada. O que vc pretendia fazer ali?

    0

    0

    -----------------------------------------------------------------------------
    Receba Johrei e purifique seu Espírito.
    http://www.messianica.org.br/colunas-da-salvacao

    #117225

    zekkerj
    Participante

    Uma coisa que esqueci de perguntar… esse 1750 é físico, ou está sendo virtualizado no GNS3?

    0

    0

    -----------------------------------------------------------------------------
    Receba Johrei e purifique seu Espírito.
    http://www.messianica.org.br/colunas-da-salvacao

    #117226

    suporte_lemon
    Participante

    Olá

    Ainda não estou recebendo o ip via dhcp, não consigo acessar a internet a partir deste roteador.
    Na lista do nat estava querendo criar uma rota de uma interface á outra.
    Esse roteador é físico.
    Conforme informei acima tenho duas interfaces;
    1 – FastEthernet – onde está conectado o link ip 10.10.10.1 (link) ip 10.10.10.2 (interface do roteador).
    2 – Ethernet – onde está o meu dhcp pool no ip 192.168.0.0
    Como deveria configurar?

    0

    0
    #117227

    Daniel.Matozinhos
    Participante

    Posso até estar enganado na minha sugestão, mas: A ACL usada em NAT tem que ser numerada. Além disso, as linhas da ACL não estão usando Wildcard Mask. Nesse caso, ele está liberando somente estes IPs.

    0

    0
    #117228

    zekkerj
    Participante

    @daniel.Matozinhos: Posso até estar enganado na minha sugestão, mas: A ACL usada em NAT tem que ser numerada.

    Temque não. 😉

    @daniel.Matozinhos: Além disso, as linhas da ACL não estão usando Wildcard Mask. Nesse caso, ele está liberando somente estes IPs.

    Aí sim, foi exatamente o problema que eu vi na ACL. Ela está pegando apenas os endereços exatamente listados. Minha sugestão sobre a ACL: apaga e faz de novo. Mostre como pretende refazê-la, @suporte_lemon.

    0

    0

    -----------------------------------------------------------------------------
    Receba Johrei e purifique seu Espírito.
    http://www.messianica.org.br/colunas-da-salvacao

    #117229

    suporte_lemon
    Participante

    Olá!

    Efetuei conforme informado.

    Segue abaio a configuração.

    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Lemon
    !
    boot system flash
    boot system flash c1700-y7-mz.122-2.xj.tar
    enable secret 5 $1$Ma.f$Ri7jCweLwwwijklPNBbgb1
    !
    username lemon password 0 L3m0nIT
    memory-size iomem 25
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    ip dhcp excluded-address 192.168.0.1 192.168.0.20
    ip dhcp ping packets 10
    !
    ip dhcp pool Redelemon
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1
    dns-server 8.8.8.8 8.8.4.4
    !
    !
    !
    !
    interface Ethernet0
    description PORTA LAN DA REDE LEMON
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    half-duplex
    !
    interface FastEthernet0
    description PORTA WAN LINK NET
    ip address 10.10.10.2 255.255.255.0
    ip nat outside
    speed auto
    !
    ip nat inside source list NAT interface FastEthernet0 overload
    ip classless
    no ip http server
    !
    !
    ip access-list standard NAT
    permit 0.0.0.0 127.255.255.255 – IP inserido 10.10.10.0
    permit 128.0.0.0 127.255.255.255 – IP Inserido 192.168.0.0
    tftp-server flash:
    tftp-server flash:c1700-sv3y-mz.122-26a.bin

    0

    0
    #117230

    jorge.ff
    Participante

    Cara ,

    Eu tenho o mesmo cenario em alguns escritorios remotos , utilizo a seguinte configuração

    ip access-list extended NAT-ACL
    permit ip x.x.x.x x.x.x.x any
    permit ip x.x.x.x x.x.x.x any
    permit ip x.x.x.x x.x.x.x any

    route-map NAT-NETVIRTUA-MAP permit 10
    match ip address NAT-ACL
    match interface xxxxxxxxxx

    ip nat inside source route-map NAT-NETVIRTUA-MAP interface xxxxxxxxxxx overload

    Na access lista tem que ser a rede com mascara curinga invertida , exemplo 10.10.10.0/24 = 10.10.10.0 0.0.0.255 .

    Att
    Jorge

    0

    0
    #117231

    zekkerj
    Participante

    @suporte_lemon:

    "ip access-list standard NAT

    permit 0.0.0.0 127.255.255.255 – IP inserido 10.10.10.0

    permit 128.0.0.0 127.255.255.255 – IP Inserido 192.168.0.0"

    Você não tem muita experiência em configurar ACLs, né?… Seria muito mais adequado fazer assim:

    "ip access-list standard NAT / permit 192.168.0.0 0.0.0.255"

    Não há necessidade em autorizar NAT pra rede 10.10.10.0/24, pq esses já são os endereços da rede interna.

    0

    0

    -----------------------------------------------------------------------------
    Receba Johrei e purifique seu Espírito.
    http://www.messianica.org.br/colunas-da-salvacao

Visualizando 12 posts - 1 até 12 (de 12 do total)

Você deve fazer login para responder a este tópico.