«

»

dez 16 2008

[P&R] VRRP x HSRP x GLBP

Este tema tende a ser bastante interessante, já que muitos têm me perguntado algo sobre ao menos um deles, e no fórum do blog “pipocam” discussões sobre o assunto de tempos em tempos. A questão enviada para a seção “P&R” e selecionada para a montagem deste post segue abaixo:

“Eu estou começando a estudar mais a fundo as opções e protocolos de balance, até porque aqui onde estou trabalhando roda GLBP com HSRP, dependendo da localidade da filial. É muito interessante, e tende a cada vez mais se tornar necessário nos ambientes de hoje. Poste lá no site sua visão sobre isso por favor, e o que vc pode filtrar, como explicação do funcionamento. Ajudará a todos.”

Lembrando que o assunto deve ser de interesse especial aos candidatos ao CCNP, já que é assunto cobrado pela certificação. Vamos então ao post sobre o assunto, visando elucidar a questão acima descrita. Quando falamos de alta disponibilidade de roteadores, atualmente, temos 3 protocolos que se destacam, tornando isso possível de uma forma, ou de outra. Vejam bem que não estou dizendo que temos APENAS estes 3 protocolos. Outros fabricantes também possuem protocolos proprietários que podem operar de forma semelhante (como o SMLT, da Nortel). Como o blog foca em Cisco, vamos falar dos protocolos mais aplicados em nosso “mundinho”. Dos três protocolos, dois são proprietários Cisco (HSRP e GLBP), e outro é independente de fabricantes (VRRP, criado e mantido pelo IETF).

VRRP e HSRP

O protocolo Cisco Hot-Standby Routing Protocol (HSRP) e o IETF Virtual Routing Redundancy Protocol (VRRP) são particamente idênticos, em termos de funcionalidades e configuração. O HSRP, por ser proprietário Cisco, apenas roda em elementos Cisco. O VRRP, por sua vez, roda em qualquer elemento que suporte a RFC 3768.

A idéia por trás de ambos os protocolos é relativamente simples: Chavear o tráfego de um roteador para outro, em caso de queda no link, ou do próprio roteador. O diagrama abaixo ilustra a situação:

vrrp.gif

Neste diagrama, temos 2 routers (A e B), ambos conectados aos respectivos provedores e ao switch da LAN. Tanto o HSRP quanto o VRRP possibilitam que a rede local (LAN) “enxergue” ambos os routers via um único endereço IP (192.168.10.3, no exemplo), conhecido como “Virtual IP”, ou “VIP”, já que este seria o endereço IP de um roteador virtual. Ou seja, nas máquinas da rede local, o default gateway à ser configurado seria apenas um: 192.168.10.3. Entretanto, os protocolos HSRP e VRRP não fazem o balanceamento do tráfego entre os 2 roteadores, por default. Ao invés disso, um dos dois routers é configurado como “ACTIVE” (ou “MASTER”, no caso do VRRP), e o outro, como “STANDBY” (ou BACKUP, no caso do VRRP). Desta forma, o tráfego gerado pela LAN sempre atravessará o mesmo router (o que se encontra como ACTIVE, na rede). O outro router apenas será usado caso o router ACTIVE venha a ter problemas. Tanto o HSRP quanto o VRRP permitem que se monitore interfaces ou mesmo entradas na tabela de roteamento. É possível, portanto, informar aos routers participantes do grupo HSRP ou VRRP o que deve ser observado para que o tráfego cheveie automaticamente para o router STANDBY. Por exemplo, se uma entrada na tabela de roteamento “sumir”, ou se a interface serial “cair”, por algum motivo, no router que se encontrava como ACTIVE na rede, este pode ter sua prioridade decrescida e o router que antes era o STANDBY automaticamente – e rapidamente – passaria a ser o ACTIVE, e todo o tráfego passaria a ser desviado para ele.

Em termos de configuração básica, ambas são semelhantes. O router com maior prioridade será o ACTIVE no HSRP ou o MASTER, no VRRP. Existem, entretanto, algumas diferenças entre o HSRP e o VRRP:

  • Apesar de ambos suportarem o modo de preempção, ou seja, um router STANDBY assume automaticamente a função de ACTIVE se sua prioridade – em um dado momento – for maior que a do antigo router que se encontrava como ACTIVE na rede. Se posteriormente, a falha for solucionada, o router ACTIVE original retoma suas funções automaticamente. O VRRP, entretanto, tem este modo ativo por default no router MASTER. No HSRP este modo deve ser manualmente ativado.
  • O VRRP possui timers ligeiramente mais curtos, ou seja, em caso de falha no MASTER, o BACKUP assume de modo relativamente mais rápido que se comparado à operação do HSRP.
  • No VRRP, o endereço ip do grupo VRRP (o VIP) é o mesmo endereço IP de um dos roteadores. No HSRP, o endereço VIP do grupo HSRP é um endereço exclusivo.
  • VRRP é independente de fabricante, enquanto o HSRP é proprietário Cisco
  • Existem outras diferenças mínimas (como o endereço IP de multicast utilizado por um, e por outro), mas não vêm ao caso para este post…

Abaixo, alguns exemplos de configurações de ambos os protocolos, usando como modelo o mesmo diagrama ilustrado mais acima:

VRRP:

Router A (MASTER)

interface F1/0
 ip address 192.168.10.1 255.255.255.0
 vrrp 1 description GRUPO_VRRP_1
 vrrp 1 ip 192.168.10.1 !Endereço IP do MASTER
 vrrp 1 priority 120 !(default é 100)
 vrrp 1 preempt
 no shutdown

Router B (BACKUP)

interface F1/0
 ip address 192.168.10.2 255.255.255.0
 vrrp 1 description GRUPO_VRRP_1
 vrrp 1 ip 192.168.10.1 !Endereço IP do MASTER
 vrrp 1 priority 110 !Default é 100
 vrrp 1 preempt
 no shutdown

Para realizar o monitoramento de elementos, é preciso antes definir o que será monitorado, no modo global de configuração:

RouterA(config)# track 2 interface serial 1/0 line-protocol

Uma vez definido o objeto à ser monitorado, podemos incluí-lo na configuração do VRRP:

Router A (MASTER)

interface F1/0 vrrp 1 track 2 decrement 20

O resultado disso é que, se a interface Serial1/0 do router A (que é o MASTER) cair, sua prioridade terá um decréscimo de 20 (120-20=100), ficando mais baixa que a prioridade do Router B (110), que consequentemente assumirá como MASTER já que o modo de preempção está ativo.

HSRP:

Como foi dito, as configs do HSRP são semelhantes às do VRRP:

Router A (ACTIVE)

interface F1/0
 ip address 192.168.10.1 255.255.255.0
 standby 1 description GRUPO_HSRP_1
 standby 1 ip 192.168.10.3 !Endereço IP do Grupo HSRP
 standby 1 priority 120 !(default é 100)
 standby 1 preempt
 no shutdown

Router B (STANDBY)

interface F1/0
 ip address 192.168.10.2 255.255.255.0
 standby 1 description GRUPO_HSRP_1
 standby 1 ip 192.168.10.3 !Endereço IP do Grupo HSRP
 standby 1 priority 110 !Default é 100
 standby 1 preempt
 no shutdown

Quanto ao monitoramente dos elementos, o processo é idêntico ao descrito para o VRRP:

RouterA(config)# track 2 interface serial 1/0 line-protocol

Uma vez definido o objeto à ser monitorado, podemos incluí-lo na configuração do HSRP:

Router A (MASTER)

interface F1/0 standby 1 track 2 decrement 20

Como podemos observar, as configurações para ambos os protocolos são relativamente simples.

Mas… e o GLBP? O GLBP (Gateway Load Balance Protocolo) é um protocolo proprietário Cisco, criado em 2005. Portanto, é um protocolo relativamente recente. A idéia por trás do GLBP era prover algo que nem o HSRP nem o VRRP conseguiam fazer de modo descomplicado: Balanceamento de carga entre os gateways. Como vimos, tanto o VRRP quanto o HSRP adotam o modo de operação “ACTIVE”/ “STANDBY”, ou seja, enquanto um router está sendo usado (“ACTIVE”), o outro permanece parado. Isso pode não ser muito interessante, especialmente quando temos links com as operadoras (ISPs) sendo subutilizados. O GLBP implementa o balanceamento de carga de forma relativamente simples, para contornar estas limitações.

PS: É importante mencionar que tanto o HSRP quanto o VRRP também suportam designs que possibilitem balanceamento de carga, por meio da criação de múltiplos grupos virtuais (MHSRP e MVRRP). Este método não é tão simples e não será abordado por este post, entretanto 😉 .

O modo como o GLBP implementa o balanceamento de carga é via implementação de múltiplos endereços MAC associados à um mesmo endereço IP. Ou seja, em uma rede local (LAN), você tem seus hosts apontando para um mesmo IP como default gateway, entretanto, os MACs associados à este IP, de host para host, pode ser diferente. Ou seja, o que o GLBP faz, na verdade, é um balanceamento de MACs, se pensarmos bem… 😉 . À cada solicitação ARP, o GLBP ativo nos routers responde com um MAC virtual diferente, resolvendo o mesmo endereço IP para o MAC address de um roteador diferente.

A figura abaixo procura ilustrar o que foi mencionado.

glbp.jpg

Apesar de comprir seu papel relativamente bem, o GLBP não faz um balanceamento de carga homogêneo. Isso porque o balanceamento não ocorre pacote por pacote.

Em termos de configuração, segue em linha com o que foi apresentado para o VRRP e para o HSRP:

Router A:

interface F0/0
 ip address 192.168.10.1 255.255.255.0
 glbp 1 ip 192.168.10.3
 glbp 1 priority 150

Router B:

interface F0/0
 ip address 192.168.10.2 255.255.255.0
 glbp 1 ip 192.168.10.3
 glbp 1 priority 140

É isso pessoal! Espero que tenham gostado, e o mais importante… entendido 😀 ! É possível praticar tudo o que foi colocado aqui no Dynamips / Dynagen. Não sei se o PT suporta estas features. Talvez valha a pena testar 😉

Fontes pesquisadas:

VRRP: http://www.ietf.org/rfc/rfc3768.txt
HSRP: http://www.cisco.com/en/US/tech/tk648/tk362/tk321/tsd_technology_support_sub-protocol_home.html
GLBP: http://www.cisco.com/en/US/docs/ios/12_2t/12_2t15/feature/guide/ft_glbp.html



Comente usando o Facebook!
0
0

61 comentários

Pular para o formulário de comentário

  1. Michel Perez

    Ótimo tópico Marco, quando estudei pra BCMSN me bati bastante não sabia nada disso, é algo muito utilizado em redes de médio a grande porte. Abraço.

    0

    0
  2. Minu

    Olha só!! Uma das maiores dúvidas que eu tinha, esclarecidas aqui!!
    Muito bom!.
    Abraçoo

    0

    0
  3. Érik

    Mto bom!!! Obrigado Marco….

    Foi de grande ajuda esse post…e mto esclarecedor!!!!

    Show esse topico de P&R!

    Abraço.

    0

    0
  4. Éder Marcelo

    Belo post…… esclareceu bastante!!!!

    []’s
    Éder Marcelo

    0

    0
  5. Leandro Nogueira

    Um ótimo esclarecimento para meus estudos do CCNP !

    Abraços

    0

    0
  6. Rodrigo Falcão

    Esse certamente vai para os favoritos…será muito útil para o CCNP!!

    Excelente Marco!

    0

    0
  7. TiaguinhoCCNA

    Marco tenho um LAB feito no Dynamips de HSRP e queria postar no grupo, cmo faco, pois sou novo no blog

    0

    0
  8. gunner

    Parabéns pelo post !!
    Excelente !!

    0

    0
  9. Marco Filippetti

    Thiaguinho, use o Fórum para postar seu Lab…!

    0

    0
  10. Fera

    Marco, qual o sentido do priority na configuração do GLBP!??

    Abs

    0

    0
  11. Marco Filippetti

    Fera, seria a definição do AVG (vide diagrama no post)…! Abs!

    0

    0
  12. llacampos

    Pessoal..sou novo na área portanto se eu falar algo errado me corrijam.
    Isso só funciona em rede Local…ou se eu tiver na WAN e tiver que usar esse balanceamento para “autenticar” minha conexão no Router B quando o Router A “cair” isso funcionaria tb ? Trabalho com VoIP e a duvida á para autenticar o ATA do cliente sem precisar alterar o IP ou DNS no ATA.

    0

    0
  13. Marco Filippetti

    Estes são protocolos desenhados para redes locais, e com o único objetivo de aumentar a disponibilidade dos gateways na LAN.

    0

    0
  14. llacampos

    OK..entendido e Obrigado Marco…e Parabéns pelo livro…adquiri a pouco e estou devorando para aprender.
    Alguma dica sua sobre minha duvida ?
    Abraços a todos.

    0

    0
  15. Pedro

    Legal o post. Onde trabalho o HSRP é muito utilizado em conexões críticas para se fazer redundância. Mas uma dúvida que tenho é sobre o tipo de implementação. Vejo vários clientes que utilizam um cabo ethernet (que chamamos back-to-back) para ligar os dois routers, além disso existe outra interface ethernet que vai pra LAN do cliente. Seria este cabo back-to-back para dar uma tolerância maior (já que para funcionar corretamente deve haver comunicação entre os dois routers ) ?

    0

    0
  16. Zzz

    Parabéns pelo POST e pela iniciativa de acrescentar ao BLOG a seção de respostas para as duvidas que lhe enviam por email em forma de excelentes POSTs como este. No meu trabalho, implementamos o VRRP (equipamentos não cisco :-/ ).

    0

    0
  17. L.C.F.N

    Muito bom, porém tenho a mesma dúvida que a postada acima pelo Pedro.

    0

    0
  18. Marco Filippetti

    O cabo crossover (back-to-back) entre routers pode ser usado para fazer o balanceamento de carga entre os routers ACTIVE e STANDBY, por exemplo. Obviamente isso envolve configurações de roteamento entre ambos os routers.

    0

    0
  19. Alexander Willians

    Marco, excelente post!

    Uma dúvida: na configuração do VRRP, onde diz que o VIP será 192.168.10.3?

    Grato,
    Alexander

    0

    0
  20. Marco Filippetti

    Grande Alex! No VRRP, o VIP usado é o IP de um dos routers. No caso, estamos usando o 192.168.10.1. O IP 192.168.10.3 apenas é usado no exemplo para o HSRP, que precisa de um IP dedicado para atuar como VIP. No diagrama ficou confuso, pois uso o mesmo para ambos 😉

    Espero ter esclarecido…

    Bom te rever no churras 😉

    Abs!

    0

    0
  21. Mollo

    Marco,ao configurar GLBP devo colocar um principal e um backup?
    Impossível balancear o tráfego de volta (WAN para LAN)?

    0

    0
  22. Marco Filippetti

    Sim, vc precisa definir qual router será o AVG. O tráfego de volta não depende de você, ou seja, o balanceamento na volta depende de como os roteadores dos ISPs (ou quaisquer outros) estejam configurados.

    Abs!

    0

    0
  23. Rafael Servo

    Obrigado Marco.
    Único ponto que não encontro explicação técnica detalhada é como fazer a criação e a eleição dos múltiplos grupos virtuais, usando HSRP.
    Pelo que estudei até agora não é muito utilizado, já que temos o GLBP.
    Mas provavelmente pode aparecer em algum exame.
    Abraço a todos.

    0

    0
  24. Mollo

    Obrigado,Marco!Acabei de comprar seu livro.Entrega em 2 dias úteis.Apartir daí,várias dúvidas surgirão e este Blog é muito importante!Meta:2009=CCNA

    0

    0
  25. Alexander Willians

    Esclareceu sim! Perfeito.

    Bom te rever tbm Marcão!!! A dúvida é: teremos que esperar uma nova noite de autógrafos ou a confraternização de 2009 para bater outro papo? Huahuahua… Quando estiver por aqui dá um alô.

    []’s

    0

    0
  26. jeduardo

    Boa tarde Marco parabéns pelo tópico claro e objetivo.
    No caso do HSRP e VRRP tenhoa seguinte dúvida…imagine que um dos links fique oscilando mas não fique totalmente inoperante.

    Serei obrigado a colocar a interface que está oscilando em shutdown?
    Igualando o priority as insterfaces se tornam Balanceadas?

    Existe alguma maneira de se uma das interfaces estar com sua confiabilidade bem abaixo da média, a outra interface assumir devido sua estar melhor?

    0

    0
  27. Marcelo Melo

    Muito bom o post.
    Vlw.

    0

    0
  28. Marco Filippetti

    Jeduardo, eu diria que… sim! Se a interface está oscilando, certamente está com problemas. Assim sendo – e também para não afetar o processo de eleição do HSRP – eu a colocaria em SHUT. Uma observação… é possível “tunar” os timers de qualquer um destes protocolos para que se adequem as características de determinadas redes. Por exemplo, você pode aumentar o timer para que a preempção não ocorra instantaneamente. Em redes com problemas como o que vc mencionou, pode ser uma boa. O contra disso é que o router BKP levaria mais tempo para entrar.

    Abs!

    0

    0
  29. Marco Filippetti

    Rafael, aconselho a dar uma lida nos docs que menciono no post como referência (no fim). Lá vc encontra o que está procurando! Uma obs… a vantagem de se utilizar o balanceamento via MHSRP em detrimento ao GLBP é que, com MHSRP, é possível fazer um balanceamento mais simétrico. Mas dá mais trabalho, já que mais de um grupo tem que ser definido em ambos os routers e metade dos PCs na rede teriam um default gw, e a outra metade, teria outro.

    Muito legal, estou adorando ver os vários comments neste post 😀 !

    Abs!

    0

    0
  30. Cledir Justo

    Muito bom o Tópico, to Vendo que esse assunto interessa muita gente rsrsrs.
    Achei legal o pessoal falar de back-to-back, com ele vc pode fazer uma rota default jogando para o ISP e outra para o router stand by, assim fazendo balanceamento, ou até mesmo com uma rota com métrica maior para fazer a contingência, e para quem trabalha em operadoras, é bom para ter gerencia do outro roteador, exemplo, o cliente possui 2 roteadores com back-to-back, porém cai o link serial de um dos routers e eles ainda não estão extendidos para a rede interna do cliente, é só você entrar no router que vc possui gerencia e dele você entrar no que esta diretamente conectado. (Ja fiz muito isso).
    Vlw!

    0

    0
  31. Giovani

    Olá Marco.

    Como vc bem explica no seu post: “À cada solicitação ARP, o GLBP ativo nos routers responde com um MAC virtual diferente, resolvendo o mesmo endereço IP para o MAC address de um roteador diferente.”

    Analisando a utilização do GLBP numa LAN, se minhas estações/servidores estiverem na mesma rede – elas estaram gravando o MAC na tabela, com isso estaram encaminhando sempre para o mesmo roteador.

    Assim, eu ainda não consigo enxergar um cenário em que tenha que utilizar do GLPB na minha rede interna – (Fique sendo a melhor solução).

    Mas, para o router ligado para Internet, vejo que pode ser muito útil.

    Gostaria de saber se meu pensamento esta correto. Abraço.

    0

    0
  32. Cledir Justo

    Giovani: Seu pensamento não está correto, suas estações/servidores vão conhecer o MAC do router “active” digamos, porém em uma outra solicitação, o GLBP vai responder com um MAC diferente, assim, atualizando a tabela ARP da sua rede, estes 3 protocolos são usados em LAN. Não sei se eu fui claro vou tentar explicar:

    1- Seu Servidor envia uma solicitação para o gateway.
    2- O Gateway responde a solicitação com o MAC FFFF.FFFF.FFFF.FFFF.
    3- Pouco tempo depois, Seu Servidor envia novamente outra solicitação, porém o gateway responde com o MAC 0000.0000.0000.0000
    4- Seu Servidor Atualiza a sua tabela ARP.

    0

    0
  33. Marco Filippetti

    Giovani, o Cledir está correto. A não ser que você “trave” a associação do MAC em suas estações, o balanceamento vai ocorrer normalmente. A resolução ocorre de tempos em tempos.

    0

    0
  34. Alison

    Marco, ótimo tópico !

    Tenho uma pequena topologia de estudo no Packet Tracer que eu utilizo pra fazer alguns testes…
    Tentei implementar o HSRP nela mas pelo jeito ele não dá suporte ao HSRP, né ?

    Abraços !

    0

    0
  35. Rafael Servo

    Beleza Marco.
    Vou dar uma estudada pelos links de referência da CISCO que vc colocou.
    E vou preparar mais cenários interessantes e perguntas capciosas pra enxer de comentários e despertar o interesses dos leitores ! kkkkk
    Abraço a todos.

    0

    0
  36. robfilho

    Muito bom o assunto.
    Eu tambem já implementei uma solução com HSRP e Spanning Tree atuando juntos para balanceamento de carga.
    Em uma rede com varias pilhas de 3560 e 2 4506 como switches Core.
    O primeiro switch de pilha de 3560 se conecta ao primeiro 4506 e o ultimo ao segundo 4506.
    Defini as prioridades de spanning tree por vlan, e naquelas que são prioritarias em um switch, o HSRP é configurado como ATIVO para as VLANs.
    Então, o processamento nos dois switchs 4506 estão equilibrados, além de haver redundancia no ambiente.
    Ah… e também para completar o ambiente, os dois 4506 estão conectados entre si, sendo sincronizados e também transferindo dados da rede.

    Abraços

    0

    0
  37. santos_ligeiro

    Marco,

    Esse Post foi show de bola finalizei semana passada a leitura do livro BCMSN estou praticando simulados para fazer a prova , com essa explicação ficou tudo bem mais claro , Muito Obrigado!!!!!
    Sei que estamos tratando de HSRP, VRRP e GLBP , mas gostaria de saber se já foi postado nessa lista alguma coisa sobre Switches Storage??

    Abraços

    Att,
    ASS: Santos

    0

    0
  38. cfeitosa

    Parabéns Marco post muito claro e objetivo.

    Vlw

    0

    0
  39. George

    Marco, obrigado pelo post.
    No final, não entendi o que você quis dizer com “Não sei se o PT suporta estas features”.

    Abraços a todos.

    0

    0
  40. Marco Filippetti

    George, PT = Packet Tracer, o simulador da Cisco 😉

    0

    0
  41. TiaguinhoCCNA

    Postei no Forum um LAB de HSRP no Dynamips, para esclarcer muitas duvidas desse belo post

    0

    0
  42. NewNeo

    Valeu pelo esclarecimento Marco. Parabéns!!

    0

    0
  43. eraldo.britto

    Caro Marco, excelente material. Me ajudou a implementar uma solução com VRRP. Gostaria de acrescentar a solução para um problema que enfrentei em um cenário idêntico ao apresentado. Acontece que configurei o OSPF para divulgar as rotas, como elas estavam sendo divulgadas por padrão com o mesmo custo, quando eu simulava a queda e o retorno do link master, o tráfego não comutava de volta para o master. A solução foi configurar para que as interfaces do link master divulgassem as rotas com um custo menor que do link de backp. Assim foi resolvido.

    Obrigado pela contribuição que está dando para minha formação.

    0

    0
  44. dud

    Grande Marcola,

    Já utilizo muito VRRP e HSRP, mas ainda não utilizei o GLBP.

    Quando surgir a oportunidade vou utilizar.

    Abração,

    Dud.

    0

    0
  45. eupenetos

    Olá Marcos, belo post!

    Estou com uma dúvida, não consigo colocar os comandos do GLBP nos routers no Dynagen! Tentei nos modelos 3620 e 7200, com dois IOS diferentes mas não há a opção do comando GLBP dentro das interfaces Fastethernet. Acredito que seja a versão dos IOS que eu estou utilizando, se for esse o problema poderia me indicar um que funcione?

    Abraço.

    0

    0
  46. João Victor

    Gostaria de saber mais sobre o comando preempt, o que seria preempção… Não entendi a sua função ao configurar o hsrp e vrrp… É uma pena que esse protocolo não pode ser simulado no PT!!!

    0

    0
  47. Rodrigo Ribaz

    Alguem ja conseguiu fazer funcionar GLBP quando se tem nat pq ele fica perdido achando que tem que devolver o pacote sempre pro mesmo MAC. Devido o Nat. Ai fica sempre pelo mesmo circuito nao balanceia.

    Se alguem souber favor me ajude.

    0

    0
  48. x86dx2

    Marcos,
    Tenho uma duvida em relação ao GLBP!
    Entendi como se aplica o GLBP e o metodo do balancemanto, mas no caso em que o Router A fique com a WAN down, todos os clientes que estiverem apontando para o MAC do Router A irão comutar automaticamente para o Router B ou perderão acesso o acesso externo?

    talves eu esteja um pouco atrasado, mas apreciaria muito uma resposta..
    Grato.

    0

    0
  49. bvieira

    Marcos, Primeiramente, excelente o post.
    Tive uma aula ontem exatamente sobre VRRP x HSRP x GLBP, estou pensando em utilizar o GLBP em meu projeto da faculdade, gostaria de saber se é possível utilizar o EtherChannel para ligação dos Routers sendo que os mesmos estarão utilizando o GLBP para balanceamento.
    Isso é possível?

    Obrigado.

    0

    0
  50. Jose Leandro

    Caro amigo Marco, quero lhe diser que este post me ajudou muito no meu trabalho, e graças a pessoas como vc, que compartilham a informação.
    Por esse motivo, a tendêndcia de pessoas como vc é crescer cada vez mais em tudo oque pretende investir, muito obrigado.

    0

    0
  51. Alisson Carvalho

    Marco,

    Na configuração do VRRP você criou o track baseado na interface fastethernet 1/0 do Router A, mas simulando este mesmo ambiente percebi que não é possível fazer o track como mencionado no exemplo. O router retorna a seguinte mensagem “tracking not supported on IP address owner”. Ou seja, a configuração vrrp 1 track só funcionou quando eu utilizei o VIP diferente do endereço da interface fa1/0. Neste caso, o VRRP funcionou igual ao HSRP. Coloquei o GW como 192.168.0.3 e o RouterA como 192.168.0.1 e o RouterB como 192.168.0.2. Fiz todos os testes e o VRRP funcionou idêntico ao HSRP.

    Pode me esclarecer o porquê deste empecilho? Achei estranho pois o VRRP não utiliza um endereço virtual, e sim o endereço de um roteador. Não sei se alguém se deparou com isso, mas do jeito que você mencionou o meu track não funcionou.

    Desde já grato e fico muito agradecido pelo post! Excelente!

    0

    0
  52. rafael.libanio

    Galera,

    sabem dizer se posso realizar configuração de duas subnets diferentes em um mesma interface VLAN com HSRP? Segue exemplo:

    interface Vlan602
    ip address 172.23.18.2 255.255.255.0
    ip address 172.23.19.2 255.255.255.0 secondary
    ip helper-address 172.23.72.57
    no ip redirects
    no ip proxy-arp
    standby 101 ip 172.23.18.1
    standby 101 priority 110
    standby 101 preempt
    standby 101 authentication md5 key-string 7 xxxxxxxxxxx
    standby 102 ip 172.23.19.1
    standby 102 priority 110
    standby 102 preempt
    standby 102 authentication md5 key-string 7 xxxxxxxxxxx

    0

    0
  53. Sérgio F.S

    Noossa, post antigo, mas, perfect. Estou trabalhando em uma solução parecida com o exemplo. É por isso que eu acesso este blog todos os dias, hehehe. Uma grande fonte de conhecimento da nossa área.

    Valeu Marco!!!!!!

    0

    0
  54. Edson

    Muito esclarecedor, valeu 😉

    0

    0
  55. gilsilva

    Marco sei que o post é antigo mas agora faz parte da realidade do CCNA. Fiz a simulação no PT 6.0 e até o momento de colocar o TRACK estava tudo certo, porém o router 2911 com o IOS “c2900-universalk9-mz.SPA.151-1.M4.bin” não aceita o comando “track 2 interface serial 1/0 line-protocol” no modo de configuração global, este comando existe apenas na configiração do Standy e não aceita colocar o “decrement” deixando apontar apenas a Interface. Sabe me dizer como é feita a configuração neste caso, tentei com outros router´s porém dão a mesma coisa. E outra dúvida, esta interface que é colocada no Track é a que está ligada ao ISP? Abraços.

    0

    0
  56. Marco Filippetti

    Silva, sugiro que use o GNS-3 e não o PT para este lab. Abs.

    0

    0
  57. rogerio_rsr

    Obrigado Marco muito útil seu poste!

    0

    0
  58. wislleym

    Boa tarde Marco,

    Estou fazendo um laboratório similar ao seu praticando VRRP.

    Realizei todos os passos, porém quando estou executando o comando VRRP 1 TRACK 2 DECREMENT 50 no roteador MASTER ele retorna a mensagem % tracking not supported on IP address owner.

    Li em algumas documentações que se um grupo VRRP é o proprietário do endereço IP, sua prioridade é fixado em 255 e não pode ser reduzida através de rastreamento de objetos.

    Em seu post você explica que o VRRP por padrão tem o modo de preempção ativo. Se o modo de preempção já está como default para que configurar os comandos TRACK 2 INTERFCE SERIAL 0/0 LINE-PROTOCOL e VRRP 1 TRACK 2 DECREMENT 50?

    Obrigado.

    0

    0
  59. wislleym

    Boa noite,

    Acho que resolvi a última dúvida que postei no último comentário “Em seu post você explica que o VRRP por padrão tem o modo de preempção ativo. Se o modo de preempção já está como default para que configurar os comandos TRACK 2 INTERFCE SERIAL 0/0 LINE-PROTOCOL e VRRP 1 TRACK 2 DECREMENT 50?”

    Realizando alguns testes no meu LAB e lendo alguns artigos, entendi que o roteador BACKUP assume como MASTER quando o roteador ficar totalmente indisponível (for desligado) ou quando a interface onde foi configurado o VRRP cair (no seu exemplo a interface F0/1).
    Se a interface conectada com o ISP (S1/0) caísse, o roteador A do seu exemplo continuaria como MASTER e a rede ficaria sem internet.

    Configurando o TRACK poderíamos realizar monitoramentos em outras interfaces ou na tabela de roteamento.

    A questão do problema com o comando VRRP 1 TRACK 2 DECREMENT 50 é que se um grupo grupo VRRP é o proprietário do endereço IP, sua prioridade é fixado em 255 e não pode ser reduzida através de rastreamento de objetos. A confirmação pode ser feita executando o comando SHOW VRRP no MASTER. Vão notar que a prioridade ficará em 255.
    Inclusive no comentário 51 nosso amigo Alisson já tinha percebido isso.

    A solução encontrada foi alterar o IP da interface F1/0 do roteador A para 192.168.10.3.
    Mantive o IP do roteador B como 192.168.10.2 e mantive o VIP em 192.168.10.1.
    Quando alterei o IP do roteador A para 192.168.10.3 e executei o comando SHOW VRRP notei que a prioridade é agora 150 (que eu configurei).
    Agora o comando VRRP 1 TRACK 2 DECREMENT 50 é aceito sem problemas.

    Fiz um teste derrubando a interface Serial (ligada ao ISP) com o comando shutdown e o roteador backup assumiu como MASTER. Segue abaixo os logs do roteador que era MASTER.

    ROUTER_1(config-if)#
    *Mar 1 07:18:05.514: %TRACKING-5-STATE: 2 interface Se0/0 line-protocol Up->Down
    ROUTER_1(config-if)#
    *Mar 1 07:18:07.514: %LINK-5-CHANGED: Interface Serial0/0, changed state to administratively down
    *Mar 1 07:18:08.514: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down
    ROUTER_1(config-if)#
    *Mar 1 07:18:08.850: %VRRP-6-STATECHANGE: Fa0/0 Grp 1 state Master -> Backup
    ROUTER_1(config-if)#

    Show de bola praticar em laboratórios.

    0

    0
  60. AugustooJJ

    Minha duvida é a seguinte

    Eu tenho uma topologia que possui VRRP para a redundância do gateway, mas eu preciso colocar vlans, alguém sabe qual a configuração necessária para funcionar o roteamento entre elas e manter a redundância de gateway ?

    Qualquer opinião ou site com informações já ajuda.

    0

    0
  61. m_machado

    Olá pessoal.
    Tenho uma dúvida sobre este assunto em caso de roteamento entre Vlans.
    É possível utilizar HSRP em 2 roteadores com subinterfaces, como em roteamento entre Vlans?

    0

    0

Deixe uma resposta